Bug 74267 - can't put my dvd drive into DMA mode
can't put my dvd drive into DMA mode
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: hdparm (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Jay Turner
:
: 75252 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-19 01:25 EDT by Thomas M Steenholdt
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-19 01:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2002-09-19 01:25:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
hdparm -d1 /dev/hdc fails with:

   /dev/hdc:
      setting using_dma to 1 (on)
      HDIO_SET_DMA failed: Operation not permitted
      using_dma       =  0 (off)

on HITACHI DVD-ROM GD-S200(from /proc/ide/hdc/model) (ide-cdrom version 4.59)

The drive DOES do DMA - I've used DMA mode with it before... Actually I think
that RH7.3 did not have this problem.
Also I have never had any problems with using it in DMA mode before

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. do hdparm -d1 /dev/hdc
	

Actual Results:  Cannot set the drive to use DMA

Expected Results:  Shoule be able to set the drive to use DMA

Additional info:
Comment 1 Karsten Hopp 2002-09-19 10:33:19 EDT
You need to activate DMA while loading the ide-cd module. This is from 
our Release-Notes: 
* DMA  is  disabled  on CD-ROM drives in this release in a different 
  but  more  reliable way than previously. If you are sure that your 
  CD-ROM  drive  is  capable of IDE DMA, place the following line in 
  the /etc/modules.conf file: 
  options ide-cd dma=1
Comment 2 Karsten Hopp 2002-10-07 05:14:10 EDT
*** Bug 75252 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.