Bug 742695 - EFI install in VirtualBox results in text install
EFI install in VirtualBox results in text install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-01 12:57 EDT by satellitgo
Modified: 2014-07-03 17:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-30 14:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
robatino: needinfo-


Attachments (Terms of Use)
/tmp/X.log from attempted F16 EFI install in VirtualBox 4.1.12 guest (7.31 KB, text/plain)
2012-04-26 06:23 EDT, Andre Robatino
no flags Details
screenshot of where Live EFI boot stops (29.13 KB, image/png)
2013-06-15 22:55 EDT, Andre Robatino
no flags Details
dmesg F19TC3-netinstl (46.28 KB, text/plain)
2013-06-16 16:41 EDT, Chris Murphy
no flags Details
dmesg F19TC3 Live (38.65 KB, text/plain)
2013-06-16 16:42 EDT, Chris Murphy
no flags Details
journalctl F19TC3 Live Desktop (98.18 KB, text/plain)
2013-06-16 16:45 EDT, Chris Murphy
no flags Details
Xorg.0.log F19TC3 Live Desktop (7.98 KB, text/plain)
2013-06-16 17:05 EDT, Chris Murphy
no flags Details

  None (edit)
Description satellitgo 2011-10-01 12:57:05 EDT
Description of problem:EFI Anaconda only installs 203 pkgs; boots to EFI shell 2.10 [1.1] on MacBook Pro i7 using VirtualBox 4.1.2 with Beta RC4 DVD


Version-Release number of selected component (if applicable):
f16 RC4 Beta DVD (EFI Boot-Anaconda)

How reproducible:
Try to install in Virtualbox 4.1.2 from DVD with
System Settings/ [x]Enable EFI (Special OS es only)

Steps to Reproduce:
1.Boot VirtualBox 4.1.2 with Beta RC4 DVD in Host Drive System Settings [x]Enable EFI (Special OS es only)
2.EFI Anaconda installs minimal system only does not allow package selection 
3.
  
Actual results:
Boot from HD
Boots HD to EFI Shell
........
exit shell
.........
Boot Maintenance Manager
boot from file/ enter/ <efi> redhat grub.efi
Boots to console
root/password correctly
yum cannot retrieve repo data...

Expected results:
Boot to Gnome

Additional info:
get message " grub1 conflicts 1:grub2-1.99-5.fc16.x86-64"
install anyway
Comment 1 Chris Lumens 2011-10-03 10:16:17 EDT
Did you do a text install?
Comment 2 satellitgo 2011-10-03 11:08:54 EDT
yes; Anaconda text install is that is all that is offered in EFI boot here.

(there was a suggestion on IRC that this was because x did not recognize the video driver in Virtualbox 4.1.2 for OSX)

and that one could complete the install with

ifconfig eth0 up
dhclient eth0
yum groupinstall gnome

I have not tested this yet.

The conflict between grub1 and grub2 also looks like a bug.
Comment 3 satellitgo 2011-10-03 11:19:01 EDT
ifconfig eth0 up
dhclient eth0
 works...
Comment 4 satellitgo 2011-10-03 17:12:59 EDT
yum groupinstall gnome-desktop fails as there is not enough room on /
Note there is never an opportunity to select the formatting of the drive and it's partitions in EFI boot (text)
Comment 5 Chris Lumens 2011-10-04 10:46:50 EDT
A text install only does a core group install and does not allow for custom partitioning, so the behavior you are describing is not a bug.  I guess the real problem here is why you did not get a graphical install.  Are you doing so from the live media?  Can you attach /tmp/X.log?
Comment 6 satellitgo 2011-10-04 11:16:25 EDT
f16 RC4 Beta DVD (EFI Boot-Anaconda)
in Virtual Box 4.1.2 for OSX
Also see comment 4. the partitioning of /is too small to install gnome
The conflict between grub1 and grub2 also looks like a bug.
  https://bugzilla.redhat.com/show_bug.cgi?id=741781#c29
Comment 7 Chris Lumens 2011-10-05 11:13:23 EDT
Please attach /tmp/X.log like I asked in comment #5 so we can see why you don't have a graphical installation.

Partitioning could be a bug or not.  You could have simply defined too small of an image for your VM to use.  Regardless, please only report one bug per bug report.
Comment 8 Andre Robatino 2012-04-26 06:13:08 EDT
The behavior is the same in 15 Final, 16 Final, and 17 Alpha TC{1,2} in a VirtualBox 4.1.12 guest. For all later 17 TCs/RCs, it drops immediately to a grub prompt (see the first few comments in bug 816410).
Comment 9 Andre Robatino 2012-04-26 06:23:34 EDT
Created attachment 580422 [details]
/tmp/X.log from attempted F16 EFI install in VirtualBox 4.1.12 guest
Comment 10 Andre Robatino 2012-04-26 06:27:04 EDT
Is this related to bug 546166 (which was closed as NOTABUG)?
Comment 11 Andre Robatino 2012-05-10 21:58:12 EDT
I filed bug 820797 for the problem of getting a grub prompt when EFI booting 17 Alpha RC1 or later in VirtualBox.
Comment 12 Andre Robatino 2012-10-04 17:46:58 EDT
With recent F18 install images, we're back to this state - EFI boot works although X startup fails.
Comment 13 G.Wolfe Woodbury 2012-11-14 15:39:47 EST
There is a workaround:
  add inst.usefbx and video=efifb to the linuxefi kernel line in grub2

this allows the X to see and use the framebuffer driver instead of failing with (the missing VGA/VESA) default.

X needs to detect that it is in a EFI environment and there is on BIOS VGA stuff to handle the initialization.

And, yes, the anaconda text mode sucks horribly.
Comment 14 Andre Robatino 2012-11-16 11:21:10 EST
(In reply to comment #13)
> There is a workaround:
>   add inst.usefbx and video=efifb to the linuxefi kernel line in grub2

Confirmed that this works. You filed bug 876787 which is similar, should one of these be marked as a dupe?
Comment 15 G.Wolfe Woodbury 2013-01-10 06:52:48 EST
Can someone recommaned that this be added to the "Common Problems" in the Wiki?
Comment 16 Adam Williamson 2013-01-11 18:05:19 EST
I'm not convinced using UEFI on VBox is at all 'Common'...
Comment 17 Andre Robatino 2013-04-05 09:04:28 EDT
Same behavior in 19 Alpha TC3 (the first one I checked).
Comment 18 Andre Robatino 2013-04-05 09:08:12 EDT
Sorry, I meant 19 Alpha TC5.
Comment 19 Andre Robatino 2013-06-15 22:55:04 EDT
Created attachment 761727 [details]
screenshot of where Live EFI boot stops

Although the workaround in comment 13 works for me with install images, it does not work with lives. Screenshot attached of where boot stops with Fedora-Live-Desktop-x86_64-19-TC3-1.iso, before coming up graphically.
Comment 20 Andre Robatino 2013-06-15 22:57:22 EDT
(Note that I did see the plymouth splash screen, but then hit ESC to get rid of it.)
Comment 21 Chris Murphy 2013-06-16 16:05:50 EDT
Fedora-Live-Desktop-x86_64-19-TC3-1.iso does not work with the kernel parameters in comment 13. There's no plymouth splash screen, and is a text only boot. tty1 doesn't end in a login prompt, but I can switch to other consoles to login.

Fedora-19-TC3-x86_64-netinst.iso works with additions in comment 13. I don't get a plymouth splash screen but I do get a graphical anaconda at the end.
Comment 22 Chris Murphy 2013-06-16 16:41:30 EDT
Created attachment 761885 [details]
dmesg F19TC3-netinstl
Comment 23 Chris Murphy 2013-06-16 16:42:14 EDT
Created attachment 761886 [details]
dmesg F19TC3 Live

Seems to be unrevealing what the problem is.
Comment 24 Chris Murphy 2013-06-16 16:45:39 EDT
Created attachment 761887 [details]
journalctl F19TC3 Live Desktop

Seems more revealing. The first problem is with d-bus and gdm:


Jun 16 10:28:15 localhost dbus-daemon[482]: dbus[482]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.12" (uid=0 pid=780 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.13" (uid=0 pid=808 comm="/usr/libexec/gdm-simple-slave --display-id /org/gn")

Jun 16 10:28:15 localhost dbus[482]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.12" (uid=0 pid=780 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.13" (uid=0 pid=808 comm="/usr/libexec/gdm-simple-slave --display-id /org/gn")


Jun 16 10:28:16 localhost gdm[780]: GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
Jun 16 10:28:16 localhost gdm[780]: GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
Comment 25 Chris Murphy 2013-06-16 17:05:30 EDT
Created attachment 761891 [details]
Xorg.0.log F19TC3 Live Desktop

Seems like X is expecting vboxvideo driver to be available even though I'm asking for it to use efifb. I'd say maybe an X bug?

[    14.121] (WW) Warning, couldn't open module vboxvideo
Comment 26 G.Wolfe Woodbury 2014-06-30 14:45:36 EDT
Obsolete

closing
Comment 27 Andre Robatino 2014-06-30 14:53:10 EDT
Why is this obsolete? F19 is still supported. It's probably still present on F20 and I could check that if necessary. If you meant that it's intended to be fixed in F21, okay but I've heard nothing about that, plus in that case the Version should be bumped to 20.
Comment 28 Chris Murphy 2014-06-30 16:35:30 EDT
I get GUI without special boot parameters in VirtualBox with UEFI enabled for both Fedora 20 and Fedora Rawhide. I had to use some boot parameter I can't remember right now for Fedora 19.
Comment 29 Andre Robatino 2014-06-30 22:59:40 EDT
Yes, I confirmed that using EFI, it's possible to do a minimal GUI install of F20 x86_64 from the install DVD, then boot from the installed system. Thanks. I'll use VirtualBox to do some EFI testing for F21, commenting it as such, just to see if vbox EFI testing is worthwhile.

P.S. You were probably thinking of the boot options in comment 13.
Comment 30 Adam Williamson 2014-07-03 17:18:47 EDT
F19 is still supported, but we can't re-roll its install media, so I don't think we could fix the problem for it...

Note You need to log in before you can comment on or make changes to this bug.