Bug 820797 - in 17 Alpha RC1 and later, EFI booting in VirtualBox drops to grub prompt
in 17 Alpha RC1 and later, EFI booting in VirtualBox drops to grub prompt
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
18
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 21:54 EDT by Andre Robatino
Modified: 2014-03-16 23:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 17:44:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
18-Alpha-TC6 (34.62 KB, image/png)
2012-09-09 17:03 EDT, Andre Robatino
no flags Details
Test this media & start Fedora (24.62 KB, image/png)
2012-09-09 17:05 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2012-05-10 21:54:06 EDT
Description of problem:
In x86_64 images up to and including 17 Alpha TC2, EFI booting in VirtualBox worked, sort of (although graphical anaconda didn't, leading to text install - see bug 742695). However, in 17 Alpha RC1 and later, EFI booting in VirtualBox leads to a grub prompt. This happens on x86_64 DVD, netinst, and Live images. I'm currently using VirtualBox 4.1.14 from the Oracle repo.

I realize that VirtualBox is proprietary and that EFI seems to work on most real hardware, but it would be nice to establish for certain that Fedora isn't doing something to cause it. I have no EFI hardware, so unless support is added to KVM or some other virtualization tool, I'm unable to test EFI.

How reproducible:
always
Comment 1 Andre Robatino 2012-05-10 21:55:37 EDT
See also my comments in bug 816410, which was closed due to EFI working in most real hardware.
Comment 2 Andre Robatino 2012-05-11 22:54:21 EDT
(In reply to comment #0)

> I realize that VirtualBox is proprietary

It's Open Source (GPLv2), not proprietary, sorry.
Comment 3 Chris Murphy 2012-05-19 10:44:48 EDT
Macs are no longer EFI booting Live Desktop either.
Comment 4 Andre Robatino 2012-08-13 04:28:41 EDT
Same with 18 Alpha TC1 and VirtualBox 4.1.18.
Comment 5 Andre Robatino 2012-09-09 17:02:48 EDT
Don't know when the behavior changed, but with 18 Alpha TC6 and VirtualBox 4.1.22, I get a Grub2 menu with two entries, "Fedora 18-Alpha-TC6" and "Test this media & start Fedora". Choosing either one gives "Secure boot not enabled", then after a long wait, it boots and finally drops to emergency mode. Attaching screenshots below.
Comment 6 Andre Robatino 2012-09-09 17:03:56 EDT
Created attachment 611279 [details]
18-Alpha-TC6

end result of booting "18-Alpha-TC6"
Comment 7 Andre Robatino 2012-09-09 17:05:08 EDT
Created attachment 611280 [details]
Test this media & start Fedora

end result of booting "Test this media & start Fedora"
Comment 8 Andre Robatino 2012-09-09 17:06:04 EDT
Should also mention that this looks similar to bug 849389 except no mention of dropping to emergency mode there.
Comment 9 Andre Robatino 2012-10-04 17:44:18 EDT
This appears to be fixed now - in recent 64-bit install images, EFI boots although X startup fails (bug 742695).

Note You need to log in before you can comment on or make changes to this bug.