Bug 743135 - The installer no longer has access to files in the initrd
Summary: The installer no longer has access to files in the initrd
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax   
(Show other bugs)
Version: 16
Hardware: All Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords: Reopened
: 788141 (view as bug list)
Depends On:
Blocks: F16Blocker, F16FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2011-10-04 00:16 UTC by Brian Lane
Modified: 2012-02-13 22:28 UTC (History)
7 users (show)

Fixed In Version: lorax-16.4.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-01 19:21:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Lane 2011-10-04 00:16:16 UTC
Since we now switch the root to the live style filesystem any files that are appended to an initrd are not accessable to the installer. This means that virt-install's inject option and the ability to add kickstart files to an initrd doesn't work.

We need to copy these files over to the /sysroot using a dracut pre-pivot hook script.

Comment 1 Tim Flink 2011-10-06 16:32:41 UTC
This bug is also blocking the execution of the "Kickstart File Path Ks"[1] testcase.

[1] https://fedoraproject.org/wiki/QA:Testcase_Kickstart_File_Path_Ks_Cfg

Comment 2 Adam Williamson 2011-10-07 18:42:47 UTC
Discussed at 2011-10-07 blocker review meeting. Accepted as a blocker per Beta criterion "The installer must be able to use all kickstart delivery methods " (note criterion may get tweaked soon, so we may have to re-evaluate blocker status of this bug).

Comment 3 Fedora Update System 2011-10-11 17:54:05 UTC
lorax-16.4.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.6-1.fc16

Comment 4 Fedora Update System 2011-10-13 04:32:55 UTC
lorax-16.4.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Tim Flink 2011-11-01 16:22:18 UTC
I'm still seeing this with the initrd output from lorax-16.4.7-1 (both RC2 and a custom built initramfs)

I added a ks to the initrd with cpio but the file does not exist in / once the boot process has finished.

When I add rd.break=pre-pivot to the kernel args, I see the kickstart file (simple.ks) but I see no pre-pivot dracut hooks to copy the ks file to the sysimage (I'm pretty sure that /lib/dracut/hooks/pre-pivot/99anaconda-copy-ks.sh is supposed to exist).

Comment 6 Tim Flink 2011-11-01 19:21:07 UTC
It turns out that the root cause of the re-occurance is a bug in dracut: #750603.

Since this isn't the problem, I'm re-closing the bug.

Comment 7 Cole Robinson 2012-02-13 22:28:07 UTC
*** Bug 788141 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.