Bug 788141 - --initrd-inject=ks.cfg doesn't work with F17 anaconda
--initrd-inject=ks.cfg doesn't work with F17 anaconda
Status: CLOSED DUPLICATE of bug 743135
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-07 10:15 EST by Kamil Páral
Modified: 2012-02-14 04:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-13 17:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-02-07 10:15:29 EST
Description of problem:
This used to be true:

       --initrd-inject=PATH
         Add PATH to the root of the initrd fetched with "--location". This can be used to run an automated install without requiring a network hosted kickstart file:

         --initrd-inject=/path/to/my.ks --extra-args "ks=file:/my.ks"


But anaconda in F17 now has very small initrd.img that it throws away before installation and switches root to squashfs.img. Then the kickstart file is not found.

One suggested solution is to inject the file into /updates/ks.cfg in the initrd.img, because that directory gets copied onto the new root. Unfortunately --initrd-inject option does not allow to specify destination path, it always injects into filesystem root.

Please allow somehow to install F17 anaconda without requiring a network hosted kickstart. Either improve --initrd-inject option syntax and allow to specify destination path. Or do this automagically. Or talk to anaconda developers and come up with a better solution. Having to host kickstart files over network is a pain.

The man page documentation will have to change in any case, I believe.

Thanks.

Version-Release number of selected component (if applicable):
anaconda 17.5
Comment 1 Kamil Páral 2012-02-07 10:16:43 EST
python-virtinst-0.600.1-1.fc16.noarch

The whole bug report is about virt-install, if that wasn't clear. Sorry.
Comment 2 Cole Robinson 2012-02-08 18:41:44 EST
Where is there an f17 tree to test this with? All the rawhide trees I see don't seem to have actual kernel/initrd available.
Comment 3 Kamil Páral 2012-02-09 08:03:12 EST
Yup. http://dl.fedoraproject.org/pub/alt/stage/17-Alpha.TC1/

Example (failed) command:

$ virt-install --name AutoQA --ram 1024 --vcpus 1 --os-type linux --disk path=/var/lib/libvirt/images/AutoQA.img,size=8,sparse=false --location http://dl.fedoraproject.org/pub/alt/stage/17-Alpha.TC1/Fedora/x86_64/os/ --network network:default --graphics none --initrd-inject=/usr/share/autotest/tests/rats_install/ks.cfg --extra-args "sshd serial console=ttyS0 root=live:http://dl.fedoraproject.org/pub/alt/stage/17-Alpha.TC1/Fedora/x86_64/os//LiveOS/squashfs.img ks=file:/ks.cfg"
Comment 4 Cole Robinson 2012-02-13 17:28:07 EST
Hmm, I didn't reproduce using 17-Alpha.TC2. Actually I think this was a lorax bug:

https://bugzilla.redhat.com/show_bug.cgi?id=743135

Which according to the build log here only made it into f17 last week:

http://koji.fedoraproject.org/koji/buildinfo?buildID=298168

Duping to that bug

*** This bug has been marked as a duplicate of bug 743135 ***
Comment 5 Kamil Páral 2012-02-14 04:06:53 EST
I can confirm that F17 Alpha TC2 seems to copy the kickstart file when injected into initrd. That is a good news, thanks.

Note You need to log in before you can comment on or make changes to this bug.