Bug 743596 - netinstall f16 Beta of LDXE and sugar (no gnome) fails to start gdm after firstboot
netinstall f16 Beta of LDXE and sugar (no gnome) fails to start gdm after fir...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedNTH
:
: 743924 (view as bug list)
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-10-05 09:36 EDT by satellitgo
Modified: 2011-10-19 12:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: gdm-3.2.0-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-10 23:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
netinstall with graphical desktop (gnome LDXE sugar-desktop) (6.36 KB, text/plain)
2011-10-05 12:41 EDT, satellitgo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 660409 None None None Never

  None (edit)
Description satellitgo 2011-10-05 09:36:18 EDT
Description of problem:
netinstall to HD f16 Beta of LDXE and sugar (no gnome) fails to start gdm after firstboot

Version-Release number of selected component (if applicable):
netinstall RC4 Beta x86-64 CD

How reproducible:
this happens with fedora repo only
and 
with updates testing and fedora repo selected

Steps to Reproduce:
1.install to HD with LXDE and sugar selected in customize now
2.deselect gnome
3.install
  
Actual results:
after completing firstboot:
hangs at verne background and rotating cursor never starts gdm login

Expected results:
log in to gdm

Additional info:
Comment 1 satellitgo 2011-10-05 10:00:48 EDT
booted to init 3 did # yum install gdm
gdm updated to updates testing (It was installed)
start x as user 
pop up->Failed to load session "gnome"

It looks like even with graphical desktop selected ( XFCE and sugar selected; gnome deselected) an incomplete install results.
Comment 2 Stephen John Smoogen 2011-10-05 11:14:52 EDT
I am seeing this problem also with full DVD. Errors in /var/log/gdm/

are 

** (gnome-settings-daemon:1125): WARNING **: Connection failed, reconnecting...

setting the system to setenforce 0 and killing 1125 did not fix the issue so I don;'t think it is selinux related. There are messages in /var/log/messages stating:

Oct  5 09:09:03 emachine01 dbus-daemon[916]: ** (polkitd:930): DEBUG:  user of caller is unix-user:root
Oct  5 09:09:03 emachine01 dbus-daemon[916]: ** (polkitd:930): DEBUG:  user of subject is unix-user:gdm
Oct  5 09:09:03 emachine01 dbus-daemon[916]: ** (polkitd:930): DEBUG: checking whether system-bus-name::1.41 is authorized for org.freedesktop.upower.hibernate
Oct  5 09:09:03 emachine01 dbus-daemon[916]: ** (polkitd:930): DEBUG:   0x1678e60
Oct  5 09:09:03 emachine01 dbus-daemon[916]: ** (polkitd:930): DEBUG:  subject is in session /org/freedesktop/ConsoleKit/Session1 (local=1 active=0)
Oct  5 09:09:03 emachine01 dbus-daemon[916]: ** (polkitd:930): DEBUG:  not authorized
Oct  5 09:09:03 emachine01 dbus-daemon[916]: ** (polkitd:930): DEBUG:


which may be related.
Comment 3 satellitgo 2011-10-05 12:41:32 EDT
Created attachment 526546 [details]
netinstall with graphical desktop (gnome LDXE sugar-desktop)

list of installed packages
2 default repos 10/05/2011
This booted fine to gdm login.
with gnome deselected in netinstall unable to boot to gdm
stalls with Verne background and spinning circle cursor.
Comment 4 satellitgo 2011-10-05 12:43:23 EDT
see attachment for list of installed packages when gnome is selected. It sucessfully boots to gdm and gnome3-shell 3.2.0
Comment 5 satellitgo 2011-10-05 12:52:19 EDT
problem may be that gdm is now part of gnome3-shell....will not work without gnome install in netinstall?
Comment 6 Adam Williamson 2011-10-05 13:10:22 EDT
well, that's not exactly it.

it's more that GNOME doesn't use gdm any more, when 3D acceleration is available: gnome-shell itself does the login. GNOME only uses gdm proper in fallback mode. AIUI, anyway.

But I don't think gdm is intending to stop supporting non-GNOME desktops, so this ought to be fixed.

This isn't a blocker as the only release blocking desktops are GNOME and KDE, but certainly I'd be +1 NTH.
Comment 7 satellitgo 2011-10-05 13:45:50 EDT
install with RC4 DVD of LDXE logs in properly using LDXE login. Is this only with netinstall that this error occurs?
Comment 8 satellitgo 2011-10-05 16:30:19 EDT
Installed correctly with 2nd netinstall with LDXE only graphical desktop ??
(gnome deselected)
got LDXE gdm login
f16 RC4 Beta netinstall x86-64 CD
I did not include sugar-desktop this time?

Do software updates: 8
log out / login works
shutdown start works
Comment 9 Adam Williamson 2011-10-05 16:31:22 EDT
I think sugar will influence things, as sugar uses gdm, right? LXDE does not, it uses lxdm. So I suspect if you install with only LXDE you don't get gdm installed at all, only lxdm, and lxdm is used. If you install with Sugar and LXDE, you get both gdm and lxdm installed, and gdm takes priority. I haven't checked, but that's what I'd guess.
Comment 10 satellitgo 2011-10-05 18:08:35 EDT
yum groupinstall gnome-desktop

dbus-launch gsettings set org.gnome.desktop.session session-name 'gnome-fallback'

starts gnome3 in fallback mode
Comment 11 satellitgo 2011-10-05 18:21:08 EDT
(In reply to comment #10)
> yum groupinstall gnome-desktop
> 
> dbus-launch gsettings set org.gnome.desktop.session session-name
> 'gnome-fallback'
> 
> starts gnome3 in fallback mode

Farther tests:
system settings/graphics/fallback mode off
reboot uses gnome gdm to login to gnome3-shell? (overrides LDXE login)

I need to test this with a netinstall of XFCE and sugar only again.
Comment 12 Adam Williamson 2011-10-05 18:24:31 EDT
j'accuse:

http://git.gnome.org/browse/gdm/commit/?id=f350f58c78551614d8c864921705f26aa2fffa18

I think this reverted a bit more than it should have done. Instead of just reverting the *version check* for gnome-shell, it takes out the check of shell's presence entirely. So as long as /usr/libexec/gnome-session-check-accelerated passes, it will happily try to fire up gnome-shell to handle login...even if gnome-shell does not in point of fact exist on the system.

this is just me poking through git, but that's what it looks like to me.
Comment 13 Adam Williamson 2011-10-05 18:27:19 EDT
...and indeed that was fixed upstream five days ago by this commit:

http://git.gnome.org/browse/gdm/commit/data/gdm-shell.session.in?id=64e6b10f98fe7226a2f41807268dae3afa80236d

we probably just need to pull that back downstream.
Comment 14 Fedora Update System 2011-10-05 19:16:41 EDT
gdm-3.2.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gdm-3.2.0-2.fc16
Comment 15 satellitgo 2011-10-05 21:01:56 EDT
init 3
login
pswd
su
#
wget http://kojipkgs.fedoraproject.org/packages/gdm/3.2.0/2.fc16/x86_64/gdm-3.2.0-2.fc16.x86_64.rpm

rpm -Uvh http://kojipkgs.fedoraproject.org/packages/gdm/3.2.0/2.fc16/x86_64/gdm-3.2.0-2.fc16.x86_64.rpm

Restart

This fixes this bug  LDXE boots from gdm properly
Comment 16 Adam Williamson 2011-10-05 21:08:04 EDT
great, can you file karma on the update? thanks!
Comment 17 satellitgo 2011-10-05 21:24:55 EDT
I cannot file karma. only as Anonymous tester which I did. : (
Comment 18 satellitgo 2011-10-05 22:17:22 EDT
Karma  +1 filed
Comment 19 Elad Alfassa 2011-10-06 11:41:35 EDT
*** Bug 743924 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2011-10-06 17:23:13 EDT
Package gdm-3.2.0-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdm-3.2.0-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-13908
then log in and leave karma (feedback).
Comment 21 Adam Williamson 2011-10-07 15:16:36 EDT
Discussed at 2011-10-07 NTH review meeting. This is a 'blocker' bug for a non-blocking desktop, so NTH.
Comment 22 satellitgo 2011-10-07 15:21:59 EDT
this probably would not show up in a virtual machine test or hardware that does not support hardware acceleration. ie: where fallback gnome3 is called. The fix is the gdm update in comment 15 and 20
Comment 23 Christoph A. 2011-10-07 15:33:31 EDT
Hi,
I did the following:
Installed Fedora 16 Beta:
Added the F16 and F16 updates testing repo and selected "customize now" 
Deselected gnome and choose XFCE.
The gdm version mentioned in comment 15 is in use (gdm-3.2.0-2.fc16.x86_64.rpm)

After reboot the following message is displayed in a box:
'Failed to load session "gdm-shell"'

I stumbled on this bug using the search, but this bug is supposed to be fixed by the gdm version I'm using..

Am I hitting another bug or is this the same one?
Comment 24 Adam Williamson 2011-10-07 18:33:51 EDT
That does sound like this bug, but I'm not sure how it could be passing. Can you check if the gnome-shell package is installed? Can you double-check the gdm package you have?
Comment 25 satellitgo 2011-10-07 18:58:30 EDT
Is this a netinstall of f16 RC4 beta? if so without sugar (which uses gdm and installs the required files) and only XFCE you should get the XFCE login, not the gnome one. Where did you deselect gnome? on initial netinstall? (or later)?
Comment 26 Christoph A. 2011-10-08 02:52:08 EDT
I double checked the gdm package - it is gdm-3.2.0-2.fc16.x86_64.rpm.
This was not the netinstall. I used Fedora-16-Beta-x86_64-DVD.iso
I deselected gnome during the installation process ("customize now").
btw: This is a VM.

For now I "fixed the problem" by installing gnome (yum groupinstall gnome-desktop) to have at least a running system, but I can create a new VM if you want me to further track this down.
Comment 27 Adam Williamson 2011-10-08 02:52:51 EDT
Xfce uses GDM. It doesn't have its own login manager.
Comment 28 Fedora Update System 2011-10-10 23:15:20 EDT
gdm-3.2.0-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Bowie Owens 2011-10-17 00:18:40 EDT
Adam Williamson, I am today having the same problem ('Failed to load session "gdm-shell"') that Christophe A. was having. I too have gdm-3.2.0-2.fc16.x86_64.rpm but I can confirm that I did not have the  gnome-shell package installed at all. 'sudo yum install gnome-shell' fixed the problem.
Comment 30 Adam Williamson 2011-10-17 16:37:40 EDT
'Failed to load session "gdm-shell"' actually seems a slightly different error from what people were getting initially here. Can you please post your full gdm logs?
Comment 31 Bowie Owens 2011-10-17 21:52:09 EDT
Adam, I did a clean install (note I selectED XFCE and unselected GNOME) and here is the greeter log from the /var/log/gdm directory.

owe043@belgrave:foo> cat ':0-greeter.log' 
gnome-session[1315]: DEBUG(+): Enabling debugging
gnome-session[1315]: DEBUG(+): GsmXsmpServer: SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1315,unix/unix:/tmp/.ICE-unix/1315

gnome-session[1315]: DEBUG(+): GsmShell: Not connected to the shell
gnome-session[1315]: DEBUG(+): GsmManager: setting client store 0x15bb920
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 1: signum=4 (nil)
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 4 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 2: signum=7 (nil)
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 7 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 3: signum=11 (nil)
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 11 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 4: signum=6 (nil)
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 6 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 5: signum=5 (nil)
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 5 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 6: signum=8 0x41bf30
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 8 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 7: signum=1 0x41bf30
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 1 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 8: signum=10 0x41bf30
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 10 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 9: signum=15 0x41bf30
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 15 signals
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Adding handler 10: signum=2 0x41bf30
gnome-session[1315]: DEBUG(+): GdmSignalHandler: Registering for 2 signals
gnome-session[1315]: DEBUG(+): fill: *** Getting session 'gdm-shell'
gnome-session[1315]: DEBUG(+): fill: *** Looking if /var/lib/gdm/.config/gnome-session/sessions/gdm-shell.session is a valid session file
gnome-session[1315]: DEBUG(+): Cannot use session '/var/lib/gdm/.config/gnome-session/sessions/gdm-shell.session': non-existing or invalid file.
gnome-session[1315]: DEBUG(+): fill: *** Looking if /etc/xdg/gnome-session/sessions/gdm-shell.session is a valid session file
gnome-session[1315]: DEBUG(+): Cannot use session '/etc/xdg/gnome-session/sessions/gdm-shell.session': non-existing or invalid file.
gnome-session[1315]: DEBUG(+): fill: *** Looking if /usr/share/gdm/greeter/gnome-session/sessions/gdm-shell.session is a valid session file
gnome-session[1315]: DEBUG(+): Cannot use session '/usr/share/gdm/greeter/gnome-session/sessions/gdm-shell.session': non-existing or invalid file.
gnome-session[1315]: DEBUG(+): fill: *** Looking if /usr/local/share/gnome-session/sessions/gdm-shell.session is a valid session file
gnome-session[1315]: DEBUG(+): Cannot use session '/usr/local/share/gnome-session/sessions/gdm-shell.session': non-existing or invalid file.
gnome-session[1315]: DEBUG(+): fill: *** Looking if /usr/share/gnome-session/sessions/gdm-shell.session is a valid session file
gnome-session[1315]: DEBUG(+): fill: *** Launching helper 'bash -c 'gnome-shell --help | grep -q gdm-mode && /usr/libexec/gnome-session-check-accelerated'' to know if session is runnable
bash: gnome-shell: command not found
gnome-session[1315]: WARNING: Session 'gdm-shell' runnable check failed: Exited with code 1
gnome-session[1315]: DEBUG(+): fill: *** Session is not runnable
gnome-session[1315]: DEBUG(+): fill: *** Getting session 'gdm-fallback'
gnome-session[1315]: DEBUG(+): fill: *** Looking if /var/lib/gdm/.config/gnome-session/sessions/gdm-fallback.session is a valid session file
gnome-session[1315]: DEBUG(+): Cannot use session '/var/lib/gdm/.config/gnome-session/sessions/gdm-fallback.session': non-existing or invalid file.
gnome-session[1315]: DEBUG(+): fill: *** Looking if /etc/xdg/gnome-session/sessions/gdm-fallback.session is a valid session file
gnome-session[1315]: DEBUG(+): Cannot use session '/etc/xdg/gnome-session/sessions/gdm-fallback.session': non-existing or invalid file.
gnome-session[1315]: DEBUG(+): fill: *** Looking if /usr/share/gdm/greeter/gnome-session/sessions/gdm-fallback.session is a valid session file
gnome-session[1315]: DEBUG(+): Cannot use session '/usr/share/gdm/greeter/gnome-session/sessions/gdm-fallback.session': non-existing or invalid file.
gnome-session[1315]: DEBUG(+): fill: *** Looking if /usr/local/share/gnome-session/sessions/gdm-fallback.session is a valid session file
gnome-session[1315]: DEBUG(+): Cannot use session '/usr/local/share/gnome-session/sessions/gdm-fallback.session': non-existing or invalid file.
gnome-session[1315]: DEBUG(+): fill: *** Looking if /usr/share/gnome-session/sessions/gdm-fallback.session is a valid session file
gnome-session[1315]: DEBUG(+): fill: *** Checking required components and providers
gnome-session[1315]: DEBUG(+): fill: provider 'windowmanager' looking for component: 'metacity'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking for file 'metacity.desktop'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/var/lib/gdm/.config/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/greeter/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/etc/xdg/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/var/lib/gdm/.local/share/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/greeter/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/applications'
gnome-session[1315]: WARNING: Unable to find default provider 'metacity' of required provider 'windowmanager'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking for file 'gdm-simple-greeter.desktop'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/var/lib/gdm/.config/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/greeter/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/etc/xdg/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/var/lib/gdm/.local/share/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/greeter/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: found in XDG dirs: '/usr/share/gdm/greeter/applications/gdm-simple-greeter.desktop'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking for file 'gnome-settings-daemon.desktop'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/var/lib/gdm/.config/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/greeter/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/etc/xdg/autostart'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/var/lib/gdm/.local/share/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/greeter/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: Looking in '/usr/share/applications'
gnome-session[1315]: DEBUG(+): GsmUtil: found in XDG dirs: '/etc/xdg/autostart/gnome-settings-daemon.desktop'
gnome-session[1315]: DEBUG(+): fill: *** Done checking required components and providers
gnome-session[1315]: DEBUG(+): fill: *** Session is not runnable
Comment 32 Adam Williamson 2011-10-17 23:40:43 EDT
ah - so if you read that, it actually correctly rejects the gdm-shell.session, but then has trouble getting gdm-fallback.session to work. is metacity installed? if not, can you install it and see if that fixes things?
Comment 33 Adam Williamson 2011-10-17 23:41:36 EDT
oh, and gnome-settings-daemon .
Comment 34 Bowie Owens 2011-10-18 18:49:06 EDT
metacity was not installed. gnome-settings-daemon-3.2.0-3.fc16.x86_64 was already installed. Installing metacity-2.34.1-1.fc16.x86_64 (with dependencies zenity and libcanberra-gtk) resolved the problem. I now get same login window I am used to from Fedora 15 with XFCE installed but not Gnome.
Comment 35 Adam Williamson 2011-10-18 19:04:32 EDT
okay, so that's a different bug. can you file it separately?

i'm not sure exactly how we should resolve it - whether we should have gdm require metacity or have metacity pulled in via comps/spin-kickstarts. but file it against gdm for now.
Comment 36 Bowie Owens 2011-10-18 19:49:48 EDT
Adam, I have filed a new bug 747161. Let me know if you need me to add any further information to the bug. I was not sure what severity to assign to the bug so I have left it unspecified.

By the way, I forgot to say thanks for helping resolve my problem. I am trying to install Fedora 16 onto a 4GB USB stick and the fewer packages I have to install the better.

Note You need to log in before you can comment on or make changes to this bug.