Bug 747161 - metacity not installed for XFCE causes 'Failed to load session "gdm-shell"' error
metacity not installed for XFCE causes 'Failed to load session "gdm-shell"' e...
Status: CLOSED DUPLICATE of bug 746693
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-10-18 19:44 EDT by Bowie Owens
Modified: 2011-10-24 17:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-10-24 17:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bowie Owens 2011-10-18 19:44:19 EDT
Description of problem:

After installing Fedora 16 with XFCE but not GNOME gdm correctly rejects the gdm-shell.session, but then has trouble getting gdm-fallback.session to work because metacity is not installed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Fedora 16 from DVD with updates from Test Updates repo.
2. During installation select 'Software Development' style installation, deselect Gnome Desktop and select XFCE.
3. Complete installation and boot system.
Actual results:

Once X starts a blank screen with error dialog box with message:

'Failed to load session "gdm-shell"'

Expected results:

A login screen.

Additional info:

This bug (and its potential resolution) has been discussed in the comments of bug 743596

Comment 1 Matthias Clasen 2011-10-24 17:56:38 EDT

*** This bug has been marked as a duplicate of bug 746693 ***

Note You need to log in before you can comment on or make changes to this bug.