Bug 743642 - bootloader not installed on serial only machines
bootloader not installed on serial only machines
Status: CLOSED DUPLICATE of bug 736993
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Linux
high Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On: 743661
Blocks: 494832
  Show dependency treegraph
 
Reported: 2011-10-05 11:37 EDT by Patrick C. F. Ernzer
Modified: 2011-10-24 19:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 19:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
program.log from an affected machine (71.02 KB, text/plain)
2011-10-05 11:39 EDT, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2011-10-05 11:37:40 EDT
Description of problem:
trying to install F16 Beta (interactive or kickstart), I get this at the end
               ┌──────────────────┤ Warning ├──────────────────┐                
               │                                               │                
               │ There was an error installing the bootloader. │                
               │ The system may not be bootable.               │                
               │                                               │                
               │                    ┌────┐                     │                
               │                    │ OK │                     │                
               │                    └────┘                     │                
               │                                               │                
               │                                               │                
               └───────────────────────────────────────────────┘                

and the system is indeed not bootable

Version-Release number of selected component (if applicable):
anaconda 16.20
grub2-1.99-5.fc16

How reproducible:
always

Steps to Reproduce:
1. install F16 Beta on a system that has no video hardware but does have a serial console
2. wait for install to finish
3. notice error
  
Actual results:
system not bootable

Expected results:
system bootable after installation, just like previous Fedora version were.

Additional info:
I see this on all of
ACPI2-A
ACPI4-A
ACPI4-B
(do not mind the names, they will only mean something to $custmer, TAM and DEE)

$customer can live with this bug in Fedora, but it MUST NOT be present in RHEL7 (RHEL6 works just fine on the machines)
Comment 1 Patrick C. F. Ernzer 2011-10-05 11:39:37 EDT
Created attachment 526527 [details]
program.log from an affected machine

18:05:53,984 ERR program: Serial terminal not available on this platform.

might be what's the problem here.
Comment 2 Patrick C. F. Ernzer 2011-10-05 11:40:33 EDT
ssh-ing into the machine;
[anaconda root@acpi4-12 grub2]# pwd
/mnt/sysimage/boot/grub2
[anaconda root@acpi4-12 grub2]# ls
device.map  grub.cfg  grub.cfg.new  grubenv

But I'm told that serial.mod is expected to be present.
Comment 3 Dave Allan 2011-10-05 21:53:54 EDT
I hit this with F16 beta as well.  It's easy to reproduce when installing to a virtual machine with serial console.  Booting the install cd in rescue mode enabled me to install the bootloader manually with:

grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-install /dev/sda

I'm happy to provide whatever information is needed, or I can work with anybody who wants me to on setting up the libvirt configuration required to reproduce it.
Comment 4 Dave Allan 2011-10-05 21:56:13 EDT
(In reply to comment #3)
> grub2-mkconfig -o /boot/grub2/grub.cfg
> grub2-install /dev/sda

Urgh, that should have been grub2-install /dev/vda in my case.
Comment 5 Mads Kiilerich 2011-10-24 19:54:03 EDT

*** This bug has been marked as a duplicate of bug 736993 ***

Note You need to log in before you can comment on or make changes to this bug.