Bug 736993 - error install bootloader with serial interface install
error install bootloader with serial interface install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
AcceptedBlocker
: Regression, Reopened
: 743642 745035 748964 (view as bug list)
Depends On: 804506
Blocks: 799060 494832 F16Blocker/F16FinalBlocker F17Beta/F17BetaBlocker 799022
  Show dependency treegraph
 
Reported: 2011-09-09 05:30 EDT by Hongqing Yang
Modified: 2012-03-26 14:14 EDT (History)
19 users (show)

See Also:
Fixed In Version: grub2-1.99-18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 799022 (view as bug list)
Environment:
Last Closed: 2012-03-26 14:14:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bootloader install error (2.47 KB, text/x-log)
2011-09-09 05:30 EDT, Hongqing Yang
no flags Details
anaconda logs (310.00 KB, application/x-tar)
2011-09-13 04:08 EDT, Hongqing Yang
no flags Details
anaconda logs (250.00 KB, application/x-tar)
2012-02-06 01:20 EST, Hongqing Yang
no flags Details
Reproducer script for failure of a KVM guest install(specifically 'bootloader' install) via serial console using F17 alpha (1.06 KB, text/plain)
2012-03-06 22:34 EST, Kashyap Chamarthy
no flags Details

  None (edit)
Description Hongqing Yang 2011-09-09 05:30:34 EDT
Created attachment 522285 [details]
bootloader install error

Description of problem:
run test case
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_serial_console

error occurred, 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. boot guest with netinst.iso
2. pass serial console=ttyS0 to kernel
3. run minicom to monitor
  
Actual results:
error to install bootloader

Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-09-09 05:31:38 EDT
after reboot, the guest cannot boot into the system
Comment 2 Chris Lumens 2011-09-09 15:28:23 EDT
Can you attach /tmp/anaconda.log, /tmp/syslog, and /tmp/program.log?  Thanks.
Comment 3 Hongqing Yang 2011-09-13 04:08:11 EDT
Created attachment 522869 [details]
anaconda logs
Comment 4 Hongqing Yang 2011-09-13 04:08:41 EDT
(In reply to comment #2)
> Can you attach /tmp/anaconda.log, /tmp/syslog, and /tmp/program.log?  Thanks.

please find the logs in the attachment, thanks.
Comment 5 Hongqing Yang 2011-09-13 04:09:46 EDT
(In reply to comment #2)
> Can you attach /tmp/anaconda.log, /tmp/syslog, and /tmp/program.log?  Thanks.

please find the logs in the attachment, thanks.
Comment 6 Chris Lumens 2011-09-14 10:21:10 EDT
08:05:13,415 WARNING program: Generating grub.cfg ...
08:05:13,602 WARNING program: cat: /boot/grub2/video.lst: No such file or directory
08:05:13,614 WARNING program: Serial terminal not available on this platform.
Comment 7 Kamil Páral 2011-09-15 04:31:31 EDT
Reproduced with F16 Beta TC2 i686 DVD.
Comment 8 Hongqing Yang 2011-09-16 01:56:16 EDT
Reproduced with F16 Beta RC1 DVD.
Comment 9 Fedora Admin XMLRPC Client 2011-09-16 15:08:23 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Hongqing Yang 2011-09-27 04:48:55 EDT
reproduced on F16 Beta RC3
Comment 11 Hongqing Yang 2011-09-29 02:55:44 EDT
reproduced with F16 beta RC4
Comment 12 Adam Williamson 2011-09-29 15:00:12 EDT
Konrad Wilk has reproduced this with RC4 also.
Comment 13 Mads Kiilerich 2011-09-29 16:11:25 EDT
/etc/grub.d/00_header depends on $GRUB_PREFIX = /boot/grub2/ being populated ... which is done by grub2-install.

AFAICS there is no solution to that upstream.

"konrad" confirmed on IRC that grub2-mkconfig works if grub2-install is run before grub2-mkconfig. I don't know if that can be used as a "solution" in anaconda.
Comment 14 Konrad Rzeszutek Wilk 2011-09-29 16:23:58 EDT
The workaround is to do in the serial console:


15:06:41 Please manually connect your vnc client to tst004.dumpdata.com:1 (192.168.101.24) to begin the install.
Press <enter> for a shell
15:06:41 Starting graphical installation.

sh-4.2# 
sh-4.2# /mnt/sysimage
sh-4.2# grub2-install /dev/sda
Installation finished. No error reported.
sh-4.2#grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.1.0-0.rc6.git0.3.fc16.x86_64
Found initrd image: /boot/initramfs-3.1.0-0.rc6.git0.3.fc16.x86_64.img
done
sh-4.2#
Comment 15 Hongqing Yang 2011-10-17 01:32:01 EDT
reproduced with F16 Final TC1
Comment 16 Adam Williamson 2011-10-17 16:42:25 EDT
marking as a final release blocker, so we can decide if we want serial console to block final release or not.
Comment 17 Adam Williamson 2011-10-21 13:40:51 EDT
Discussed at the 2011-10-21 blocker review meeting. Accepted as a blocker: we feel serial console is used enough to be blocker material at least for final. There isn't current a criteria for this, but we're pretty sure there's meant to be one and it got lost somewhere down the line. We will re-add this criterion.
Comment 18 Hongqing Yang 2011-10-23 23:05:28 EDT
reproduced with F16 Final TC2
Comment 19 Mads Kiilerich 2011-10-24 19:52:55 EDT
*** Bug 745035 has been marked as a duplicate of this bug. ***
Comment 20 Mads Kiilerich 2011-10-24 19:54:03 EDT
*** Bug 743642 has been marked as a duplicate of this bug. ***
Comment 21 Adam Williamson 2011-10-24 20:10:19 EDT
Hongqing, Konrad - pjones tried to reproduce this, but couldn't. He used a bare metal system. Can you provide more details on your exact test configurations? Did you do anything not mentioned in the test case? Did you both use virt or bare metal? Thanks!
Comment 22 Adam Williamson 2011-10-24 20:10:40 EDT
pjones found his storage.log had the grub 'error' in it, but the config was actually written, and the system booted.
Comment 23 Konrad Rzeszutek Wilk 2011-10-24 21:25:15 EDT
It was definitely baremetal, and I think the cause of this was that I had selected _everything_ - including the guestfish? which ended up also installing grub1.

Let me retry it tomorrow and see if I can reproduce it.
Comment 24 Adam Williamson 2011-10-24 21:39:55 EDT
having the grub package selected shouldn't really affect whether grub2-mkconfig succeeds or not, but it would be interesting to know if you can reproduce this with a more normal package set.
Comment 25 Dave Allan 2011-10-24 22:13:54 EDT
This is 100% reproducible for me on a KVM VM installing from the F16 beta DVD. 
The system shows the same error as in the attachment "bootloader install error"
and the system does not boot after the install completes.
Comment 26 Adam Williamson 2011-10-24 22:20:28 EDT
is a valid config file actually apparently produced, or not?
Comment 27 Hongqing Yang 2011-10-24 22:47:34 EDT
(In reply to comment #26)
> is a valid config file actually apparently produced, or not?

The grub2.cfg is empty with minimal installation. I cannnot select package with minicom.
Comment 28 Kamil Páral 2011-10-25 08:22:17 EDT
I can confirm this is extremely easily reproducible with KVM and TC2 DVD. Created grub.cfg is empty.
Comment 29 Adam Williamson 2011-10-25 12:14:32 EDT
So, in case it hasn't been clear thus far, the video.lst file missing isn't the critical error. grub2 warns about that, but continues. The critical problem is /boot/serial.mod:

if [ "x$serial" = x1 ]; then
    if ! test -e ${GRUB_PREFIX}/serial.mod ; then
	echo "Serial terminal not available on this platform." >&2 ; exit 1
    fi

so if it knows it's doing a serial console install and it can't find serial.mod it simply exits.

I don't know why we're hitting that problem on some serial installs but not others, but it's certainly what the problem is.
Comment 30 Adam Williamson 2011-10-25 12:16:03 EDT
that's from grub2's /etc/grub.d/00_header , btw.
Comment 31 Adam Williamson 2011-10-25 13:43:28 EDT
So, pjones went ahead and fixed the issue as diagnosed, without figuring out why he couldn't reproduce, and tflink has tested that it works for him at least. Can others please test with this updates image:

http://pjones.fedorapeople.org/serial-updates.img

and see if that fixes the problem for you? Thanks! To use it, just boot from the TC2 image with the kernel parameter 'updates=http://pjones.fedorapeople.org/serial-updates.img'.
Comment 32 Adam Williamson 2011-10-25 13:50:56 EDT
Filed https://bugzilla.redhat.com/show_bug.cgi?id=748964 as a Rawhide 'clone' of this, as pjones thinks there should be a better long-term fix.
Comment 33 Dave Allan 2011-10-25 14:39:02 EDT
(In reply to comment #31)
> Can others please test with this updates image:
> 
> http://pjones.fedorapeople.org/serial-updates.img

That fixes it on my system.
Comment 34 Fedora Update System 2011-10-25 17:02:07 EDT
anaconda-16.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.23-1.fc16
Comment 35 Kamil Páral 2011-10-26 05:44:16 EDT
When using the updates.img it seems that there is a new dialog in the beginning that asks whether to enable VNC mode or text mode. I don't remember it from previous installs, I'm not sure whether it was there or not.

The updates.img fixes the serial console problem.
Comment 36 Tim Flink 2011-10-28 10:36:22 EDT
Tested with TC3 i686 on bare metal. After installation, the machine booted as expected.
Comment 37 Adam Williamson 2011-10-29 02:40:16 EDT
anaconda 16.24-2 (glibc rebuild) went stable, so CLOSING.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 38 Adam Williamson 2011-11-07 23:34:09 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 39 Hongqing Yang 2012-02-06 01:19:41 EST
I hit this with F17 Alpha TC1
Comment 40 Hongqing Yang 2012-02-06 01:20:50 EST
Created attachment 559554 [details]
anaconda logs
Comment 41 Dave Allan 2012-02-06 21:28:27 EST
I'm also seeing this on F17 Alpha TC1:

┌──────────────────┤ Warning ├──────────────────┐                
│                                               │                
│ There was an error installing the bootloader. │                
│ The system may not be bootable.               │                
│                                               │                
│                    ┌────┐                     │                
│                    │ OK │                     │                
│                    └────┘                     │                
│                                               │                
│                                               │                
└───────────────────────────────────────────────┘                
                                                                                
...and indeed the system does not boot

I am able to get a bootable system as with F16 Beta by booting the install DVD in rescue mode and executing:

sh-4.2# grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.3.0-0.rc2.git1.1.fc17.x86_64
Found initrd image: /boot/initramfs-3.3.0-0.rc2.git1.1.fc17.x86_64.img
done
sh-4.2# grub2-install /dev/vda
Installation finished. No error reported.
sh-4.2#
Comment 42 Hongqing Yang 2012-02-10 06:06:07 EST
reproduced with F17 Alpha TC2
Comment 43 Adam Williamson 2012-02-10 13:23:13 EST
Discussed at 2012-02-10 blocker review meeting. Agreed this does not hit the Alpha criterion, "The installer must be able to complete an installation using the text, graphical and VNC installation interfaces", which intentionally excludes the serial interface. We still haven't decided whether we want serial install to block beta or final, but we're clear that it doesn't block Alpha. Accordingly, this is rejected as an Alpha blocker. Re-proposing as a Beta blocker so this doesn't fall off the radar.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 44 Dave Allan 2012-02-10 16:17:40 EST
Just my $.02, it should block Beta.  Of course, I would say that since nearly all my machines are serial console only.  Although serial console is something of a niche use case, it's not going away, and people who use it depend on it.
Comment 45 Hongqing Yang 2012-02-16 02:10:52 EST
reproduced with F17 Alpha RC2
Comment 46 Patrick C. F. Ernzer 2012-02-20 11:35:18 EST
I'd like to add my voice to those requesting this to be a beta blocker. Well over half the hardware variants used by the customer, I am assigned to, is serial only.
Comment 47 Hongqing Yang 2012-02-22 04:15:17 EST
reproduced with F17 Alpha RC4
Comment 48 Kamil Páral 2012-02-22 04:25:53 EST
I kindly request high priority when solving this bug. Our automated installation tests are blocked by this.
Comment 49 Patrick C. F. Ernzer 2012-03-01 07:44:32 EST
reproduced with F17 Alpha (as released to the general public)
Comment 50 Kashyap Chamarthy 2012-03-06 22:34:19 EST
Created attachment 568107 [details]
Reproducer script for failure of a KVM guest install(specifically 'bootloader' install) via serial console using F17 alpha
Comment 51 Kashyap Chamarthy 2012-03-06 22:35:40 EST
Please find the reproducer(in Comment #50)  for the behaviour in comment #41
Comment 52 Hongqing Yang 2012-03-07 04:50:42 EST
reproduced with F17 Beta TC1
Comment 53 Adam Williamson 2012-03-09 13:35:07 EST
*** Bug 748964 has been marked as a duplicate of this bug. ***
Comment 54 Adam Williamson 2012-03-09 23:10:10 EST
Discussed at 2012-03-09 blocker review meeting. Agreed the bug is a beta blocker: we have general consensus that serial console should be beta blocking. We will update the criteria to reflect this, and conclude the ongoing ML discussion.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 55 Kamil Páral 2012-03-12 10:47:05 EDT
Soo, can you please push modified grub2 to Fedora Updates? Thanks.
Comment 56 Adam Williamson 2012-03-16 14:20:28 EDT
I believe https://admin.fedoraproject.org/updates/FEDORA-2012-3875/grub2-1.99-19.fc17 should have the fix for this. We need to build an image with that grub2 to test.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 58 Adam Williamson 2012-03-19 19:50:19 EDT
This should be fixed in TC2. Please note the syntax for triggering a serial console install has changed: https://bugzilla.redhat.com/show_bug.cgi?id=804506#c2 - we will need to adjust the test case. Hongqing, please re-test, following the new syntax. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 59 Kamil Páral 2012-03-20 07:59:55 EDT
This is currently blocked on bug #804506. Can't verify fix.
Comment 60 Adam Williamson 2012-03-21 17:53:47 EDT
the grub2 update is now actually stable, but we still need to verify the fix with TC3 or RC1.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 61 Adam Williamson 2012-03-24 12:18:11 EDT
It should be possible to verify this with RC1.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 62 Hongqing Yang 2012-03-26 01:29:10 EDT
This is fixed with F17 Beta RC1
Comment 63 Adam Williamson 2012-03-26 14:14:25 EDT
Let's close, then, all relevant components are stable.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.