Bug 74374 - Timestamps of files are in the future after completion of install
Timestamps of files are in the future after completion of install
Status: CLOSED DUPLICATE of bug 6175
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 72011 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-22 09:41 EDT by rh-bugzilla
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rh-bugzilla 2002-09-22 09:41:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; T312461)

Description of problem:
When doing a kickstart install of RH73 over an HTTP connection.  My ks.cfg file 
has timezone entererd WITHOUT --utc, but new files are created which have 
date/times 10 hours advanced from the current time.  My h/w clock is set to 
localtime and after the install, anything created has correct timestamps.  My 
timezone is GMT +10.00 hrs -- so there seems to be a problem with the 
install 'thinking' that my hw clock is set to UTC when I have told it (by 
ommission of --utc in timezone entry) that it is NOT.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Create a ks.cfg file -- include timezone entry, but not the '--utc' option, put 
ks.cfg onto floppy.  Setup install server to install via http method.  Begin 
install.  Look at file timestamps after completion of install.

Additional info:

Tried adjusting time using a shell script to set date -10 hours in %pre section 
with an adjustment of +10 hours in %post section -- did not help at all.
Comment 1 Michael Fulbright 2002-09-27 17:02:07 EDT
*** Bug 72011 has been marked as a duplicate of this bug. ***
Comment 2 petr 2002-10-06 11:58:10 EDT
The same problem with Red Hat 8.0 and standard install. Some files are 2 hours
in the future. It seems to be timezone difference - here we have GMT+02. And I
receive during startup the message:
Warning: File `sendmail.cf' has modification time in the future (2002-10-06
18:04:50 > 2002-10-06 17:04:10)
make: warning: Clock skew detected. Your build may be incomplete.
Comment 3 Jeremy Katz 2002-12-13 17:59:59 EST

*** This bug has been marked as a duplicate of 6175 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:49:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.