Bug 74401 - every second page generated is empty
Summary: every second page generated is empty
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mpage   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 82424 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-23 15:59 UTC by Pawel Salek
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-13 20:21:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pawel Salek 2002-09-23 15:59:02 UTC
Description of problem:
mpage adds empty pages to the generated output: all even pages are such .

Version-Release number of selected component (if applicable):
mpage-2.5.2-4

How reproducible:
Always

Steps to Reproduce:
1. mpage -2 /usr/share/emacs/21.2/etc/refcard.ps > /tmp/a.ps
 or probably any multipage document.
2. gv /tmp/a.ps

Actual Results:  3 pages generated. page number 2 is empty. Original document
had 6 pages, i.e. second page is lost somewhere.

Additional info:
It is not problem with gv since printers actually print what gv shows (i.e.
empty page). 

This bug renders mpage virtually useless.

Comment 1 Tim Waugh 2002-09-26 07:59:24 UTC
Confirmed.  It's spitting out two 'showsheet's instead of one for every real 
page.

Comment 2 Gene Czarcinski 2002-09-30 15:27:50 UTC
Confirmed in 8.0.

Comment 3 Tim Waugh 2002-10-13 20:21:30 UTC
These are coming from post.c:771 and post.c:902, both in do_post_sheet. 
 
Reported upstream.

Comment 4 Tim Waugh 2002-10-20 19:59:16 UTC
Fixed in mpage-2.5.3-1.

Comment 5 Tim Waugh 2003-01-22 13:32:10 UTC
*** Bug 82424 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.