Bug 82424 - extra empty page printed
extra empty page printed
Status: CLOSED DUPLICATE of bug 74401
Product: Red Hat Linux
Classification: Retired
Component: mpage (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-21 19:33 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-01-21 19:33:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
	It seems that the mpage version installed with the
Linux release 8.0 (mpage 2.5.2pre August 1999) does not
behave the way it should (at least, compared to what I used
before, mpage 2.5.1pre2 March 1998).

	Namely, it indeed places two pages on one sheet, but
then it prints an empty sheet after each one containing
text.

	Comparing the versions produced by the two versions
(starting from identical PS files), this defect can be
corrected by eliminating the double occurrence of
"showsheet" in the instances (produced by version 2.5.2):

b Fm(is)f(tr)-5 b(ansitive.)51 b(If)37 b Fo(r)d Fr(\025)e
Ft(2)p Fm(,)p eop
% %%Page: 3 3
grestore
showsheet
showsheet
%%Page: 2 2
gsave
18 774 translate
-90 rotate

(I don't know too much about PS, it looks like showsheet is
invoked after a page is processed; this might not be the
best way to correct the problem).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.dvips -o test.ps FILE.dvi
2.mpage -2 -o test.ps > test.doubleps
3.print the file test.doubleps (lpr test.doubleps)
    

Actual Results:  each second printed page is blank
(the others contain two pages per sheet, as desired)

Expected Results:  no blank pages should be printed

Additional info:
Comment 1 Tim Waugh 2003-01-22 08:32:00 EST

*** This bug has been marked as a duplicate of 74401 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:51:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.