Bug 744082 - gtk3 based applications core
gtk3 based applications core
Status: CLOSED DUPLICATE of bug 744960
Product: Fedora
Classification: Fedora
Component: libXi (Show other bugs)
16
ppc64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Alphappc
  Show dependency treegraph
 
Reported: 2011-10-06 18:29 EDT by Brent Baude
Modified: 2012-03-14 09:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-14 14:21:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file (1.42 MB, application/x-bzip)
2011-10-06 18:34 EDT, Brent Baude
no flags Details

  None (edit)
Description Brent Baude 2011-10-06 18:29:10 EDT
Description of problem:

Gnome and gtk3 based applications core.  This is broader than gtk3 (i.e. observed in most gnome applications) but I am using gtk3-demo as an example.  

Version-Release number of selected component (if applicable):
f16 ppc64

How reproducible:
run gtk3-demo

Also noteworthy, if you run gtk3-demo with gdb it works fine.


gdb info ->
Reading symbols from /usr/bin/gtk3-demo...Reading symbols from /usr/lib/debug/usr/bin/gtk3-demo.debug...done.
done.
[New LWP 1802]

warning: Ignoring non-absolute filename: <linux-vdso64.so.1>
Missing separate debuginfo for linux-vdso64.so.1
Try: yum --disablerepo='*' --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/3f/d5a83c92a0a352532944dbfceab6dc1f9adba7
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `gtk3-demo '.
Program terminated with signal 11, Segmentation fault.
#0  copy_classes (to=0x10035bfd1b0, from=0x10035c08e60, nclasses=0x35bfd1cc) at XExtInt.c:1466
1466	    to->classes = next_block(&ptr_lib, *nclasses * sizeof(XIAnyClassInfo*));
Missing separate debuginfos, use: debuginfo-install atk-2.1.92-1.fc16.ppc64 cairo-1.10.2-4.fc16.ppc64 cairo-gobject-1.10.2-4.fc16.ppc64 expat-2.0.1-11.fc15.ppc64 fontconfig-2.8.0-4.fc16.ppc64 freetype-2.4.6-1.fc16.ppc64 gdk-pixbuf2-2.24.0-1.fc16.ppc64 glib2-2.29.92-1.5.kh.fc16.ppc64 glibc-2.14.90-10.ppc64 libX11-1.4.3-1.fc16.ppc64 libXau-1.0.6-2.fc15.ppc64 libXcomposite-0.4.3-2.fc15.ppc64 libXcursor-1.1.11-3.fc15.ppc64 libXdamage-1.1.3-2.fc15.ppc64 libXext-1.2.0-2.fc15.ppc64 libXfixes-5.0-1.fc16.ppc64 libXinerama-1.1.1-2.fc15.ppc64 libXrandr-1.3.1-2.fc15.ppc64 libXrender-0.9.6-2.fc15.ppc64 libffi-3.0.10-1.kh.fc16.ppc64 libgcc-4.6.1-9.kh.fc16.ppc64 libpng-1.2.46-1.fc16.ppc64 libselinux-2.1.5-5.1.fc16.ppc64 libxcb-1.7-3.fc16.ppc64 pango-1.29.3-2.fc16.ppc64 pixman-0.22.2-1.fc16.ppc64 zlib-1.2.5-4.fc16.ppc64
#0  copy_classes (to=0x10035bfd1b0, from=0x10035c08e60, nclasses=0x35bfd1cc) at XExtInt.c:1466
#1  0x000000803952e198 in XIQueryDevice (dpy=0x10035be8440, deviceid=<optimized out>, ndevices_return=<optimized out>) at XIQueryDevice.c:90
#2  0x00000fffb293afb8 in gdk_x11_device_manager_xi2_constructed (object=0x10035bc2540) at gdkdevicemanager-xi2.c:414
#3  0x00000080386d9178 in .g_object_newv () from /lib64/libgobject-2.0.so.0
#4  0x00000080386d9a8c in .g_object_new_valist () from /lib64/libgobject-2.0.so.0
#5  0x00000080386d9c2c in .g_object_new () from /lib64/libgobject-2.0.so.0
#6  0x00000fffb293762c in _gdk_x11_device_manager_new (display=0x10035bf5000) at gdkdevicemanager-x11.c:66
#7  0x00000fffb293e0e0 in _gdk_x11_display_open (display_name=<optimized out>) at gdkdisplay-x11.c:1228
#8  0x00000fffb293b560 in gdk_x11_display_manager_open_display (manager=0x10035bbba00, name=0x0) at gdkdisplaymanager-x11.c:55
#9  0x00000fffb290fb20 in gdk_display_manager_open_display (manager=<optimized out>, name=<optimized out>) at gdkdisplaymanager.c:380
#10 0x00000fffb290e8a4 in gdk_display_open (display_name=0x0) at gdkdisplay.c:1718
#11 0x00000fffb290395c in gdk_display_open_default_libgtk_only () at gdk.c:354
#12 0x00000fffb2c5cdec in gtk_init_check (argc=<optimized out>, argv=<optimized out>) at gtkmain.c:1136
#13 0x00000fffb2c5ce30 in gtk_init (argc=<optimized out>, argv=<optimized out>) at gtkmain.c:1188
#14 0x00000000100126b8 in main (argc=1, argv=0xfffcda35548) at main.c:947
r0             0x0	0
r1             0xfffcda34450	17591341106256
r2             0x8039558800	550717720576
r3             0x10035bfd1b0	1100413391280
r4             0x10035c08e60	1100413439584
r5             0x35bfd1cc	901763532
r6             0x216	534
r7             0x2	2
r8             0x10035bfd2c0	1100413391552
r9             0x10035bfd2d0	1100413391568
r10            0x801	2049
r11            0x111	273
r12            0x24024842	604129346
r13            0xfffb28cb9e0	17590886644192
r14            0x803870b040	550702723136
r15            0x8038709378	550702715768
r16            0x803870bce8	550702726376
r17            0x8038709378	550702715768
r18            0x803870b040	550702723136
r19            0x80387361d8	550702899672
r20            0x2	2
r21            0x10035bfd1b0	1100413391280
r22            0x35bfd1cc	901763532
r23            0x3	3
r24            0x1	1
r25            0xffffffffffffffff	18446744073709551615
r26            0x10035bfd1b0	1100413391280
r27            0x10035c08e60	1100413439584
r28            0x10035bfd1b0	1100413391280
r29            0x10035bfd1d8	1100413391320
r30            0xfffb29a9a88	17590887553672
r31            0x10035be8440	1100413305920
pc             0x803952c738	0x803952c738 <copy_classes+96>
msr            0x800000000000d032	9223372036854829106
cr             0x24024844	604129348
lr             0x803952e198	0x803952e198 <XIQueryDevice+672>
ctr            0x2	2
xer            0x20000018	536870936
orig_r3        0xc000000000005814	-4611686018427365356
trap           0x300	768
Comment 1 Brent Baude 2011-10-06 18:34:40 EDT
Created attachment 526815 [details]
core file
Comment 2 Matthias Clasen 2011-10-07 13:48:41 EDT
Looks like the problem is actually in XI2. Moving to libXi
Comment 3 Fedora Admin XMLRPC Client 2011-10-11 19:10:37 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Karsten Hopp 2011-10-14 14:21:42 EDT

*** This bug has been marked as a duplicate of bug 744960 ***

Note You need to log in before you can comment on or make changes to this bug.