Bug 744960 - libXi crashes on XIQueryDevice on ppc64
Summary: libXi crashes on XIQueryDevice on ppc64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libXi
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 744082 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-11 00:50 UTC by Peter Hutterer
Modified: 2011-11-29 00:01 UTC (History)
3 users (show)

Fixed In Version: libXi-1.4.3-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-20 03:57:59 UTC
Type: ---


Attachments (Terms of Use)

Description Peter Hutterer 2011-10-11 00:50:34 UTC
Description of problem:
copy_classes() in XIQueryDevice is passed a reference to lib->num_classes. A bad prototype for copy_classes() in that file cuts this from (int*) to (int), causing an invalid memory reference inside copy_classes.


Version-Release number of selected component (if applicable):
libXi-1.4.3-2

How reproducible:
Run "xinput list" on an affected system

Comment 1 Fedora Update System 2011-10-11 01:14:40 UTC
libXi-1.4.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libXi-1.4.3-3.fc16

Comment 2 Fedora Update System 2011-10-11 01:21:48 UTC
libXi-1.4.3-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libXi-1.4.3-3.fc15

Comment 3 Fedora Update System 2011-10-11 03:00:16 UTC
Package libXi-1.4.3-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libXi-1.4.3-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14127
then log in and leave karma (feedback).

Comment 4 Fedora Admin XMLRPC Client 2011-10-11 23:10:41 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Karsten Hopp 2011-10-14 18:21:42 UTC
*** Bug 744082 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2011-10-20 03:57:59 UTC
libXi-1.4.3-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-11-29 00:01:32 UTC
libXi-1.4.3-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.