Bug 744098 - unable to manually install grub2 from livecd
unable to manually install grub2 from livecd
Status: CLOSED DUPLICATE of bug 746394
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-06 23:17 EDT by Joey Boggs
Modified: 2011-10-18 08:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-18 08:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joey Boggs 2011-10-06 23:17:56 EDT
I'm trying to install grub2 from a livecd to a livecd based disk install for ovirt-node(upstream for RHEV-H).

disk is setup as
/dev/sda1 ext2 fs Labeled (RootBackup)
/dev/sda2 ext2 fs Labeled (Root)
/dev/sda3 (LVM partition)

/dev/sda2 | /dev/mapper/0QEMU_QEMU_HARDDISK_drive-scsi0-0-0p2 mounted to /liveos inside the livecd image

For this to work normally with F14 and below installs we create a custom grub.conf then run through grub setup to install to the MBR and copy stage1/1.5/2 files over to /liveos.

With Fedora 16 going with grub2 we're trying to get it working on that now and just can't get grub2-install to find the right disk. All configurations have been generated with grub tools and not our tools.

device.map

From /liveos/grub2/device.map: (generated during grub2-install)
(hd0)	/dev/disk/by-id/scsi-0QEMU_QEMU_HARDDISK_drive-scsi0-0-0

Contents of /liveos
drwxr-xr-x. 2 root root     1024 Oct  7 02:22 LiveOS
drwx------. 2 root root    12288 Oct  7 02:21 lost+found
-r--r--r--. 1 root root      173 Oct  7 00:46 version
-r--r--r--. 1 root root 25954402 Oct  7 00:45 initrd0.img
-r--r--r--. 1 root root  4126672 Oct  7 00:45 vmlinuz0



[root@localhost ~]# grub2-install --boot-directory=/liveos /dev/sda
/sbin/grub2-probe: error: no such disk.
Auto-detection of a filesystem of /dev/mapper/0QEMU_QEMU_HARDDISK_drive-scsi0-0-0p2 failed.
Try with --recheck.
If the problem persists please report this together with the output of "/sbin/grub2-probe --device-map="/liveos/grub2/device.map" --target=fs -v /liveos/grub2" to <bug-grub@gnu.org>


[root@localhost ~]# /sbin/grub2-probe --device-map="/liveos/grub2/device.map" --target=fs -v /liveos/grub2
/sbin/grub2-probe: info: Scanning for dmraid_nv RAID devices on disk hd0.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: scanning hd0 for LVM.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: no LVM signature found.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid09 RAID devices on disk hd0.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid1x RAID devices on disk hd0.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid09 RAID devices on disk hd0.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid09 RAID devices on disk hd0,gpt3.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid09 RAID devices on disk hd0,gpt2.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid09 RAID devices on disk hd0,gpt1.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid1x RAID devices on disk hd0.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid1x RAID devices on disk hd0,gpt3.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid1x RAID devices on disk hd0,gpt2.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: Scanning for mdraid1x RAID devices on disk hd0,gpt1.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: scanning hd0 for LVM.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: no LVM signature found.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: scanning hd0,gpt3 for LVM.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: scanning hd0,gpt2 for LVM.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: no LVM signature found.
/sbin/grub2-probe: info: scanning hd0,gpt1 for LVM.
/sbin/grub2-probe: info: the size of hd0 is 16777216.
/sbin/grub2-probe: info: no LVM signature found.
/sbin/grub2-probe: info: changing current directory to /dev.
/sbin/grub2-probe: info: changing current directory to HostVG.
/sbin/grub2-probe: info: changing current directory to snd.
/sbin/grub2-probe: info: changing current directory to hugepages.
/sbin/grub2-probe: info: changing current directory to libvirt.
/sbin/grub2-probe: info: changing current directory to qemu.
/sbin/grub2-probe: info: changing current directory to mqueue.
/sbin/grub2-probe: info: changing current directory to disk.
/sbin/grub2-probe: info: changing current directory to by-partlabel.
/sbin/grub2-probe: info: changing current directory to by-partuuid.
/sbin/grub2-probe: info: changing current directory to by-uuid.
/sbin/grub2-probe: info: changing current directory to by-label.
/sbin/grub2-probe: info: changing current directory to by-path.
/sbin/grub2-probe: info: changing current directory to by-id.
/sbin/grub2-probe: info: changing current directory to block.
/sbin/grub2-probe: info: changing current directory to char.
/sbin/grub2-probe: info: changing current directory to net.
/sbin/grub2-probe: info: changing current directory to shm.
/sbin/grub2-probe: info: changing current directory to pts.
/sbin/grub2-probe: info: changing current directory to bsg.
/sbin/grub2-probe: info: changing current directory to mapper.
/sbin/grub2-probe: info: opening 0QEMU_QEMU_HARDDISK_drive-scsi0-0-0p2.
/sbin/grub2-probe: error: no such disk.
[root@localhost ~]# 


[root@localhost ~]# e2label /dev/mapper/0QEMU_QEMU_HARDDISK_drive-scsi0-0-0p2
RootNew


drwxr-xr-x.  2 root root      260 Oct  7 02:22 .
drwxr-xr-x. 18 root root     3380 Oct  7 02:22 ..
lrwxrwxrwx.  1 root root        7 Oct  7 02:21 0QEMU_QEMU_HARDDISK_drive-scsi0-0-0 -> ../dm-0
brw-rw----.  1 root disk 253,   1 Oct  7 02:22 0QEMU_QEMU_HARDDISK_drive-scsi0-0-0p1
brw-rw----.  1 root disk 253,   2 Oct  7 02:22 0QEMU_QEMU_HARDDISK_drive-scsi0-0-0p2
lrwxrwxrwx.  1 root root        7 Oct  7 02:21 0QEMU_QEMU_HARDDISK_drive-scsi0-0-0p3 -> ../dm-3
crw-------.  1 root root  10, 236 Oct  7 02:13 control
lrwxrwxrwx.  1 root root        7 Oct  7 02:21 HostVG-Config -> ../dm-7
lrwxrwxrwx.  1 root root        7 Oct  7 02:21 HostVG-Data -> ../dm-9
lrwxrwxrwx.  1 root root        7 Oct  7 02:21 HostVG-Logging -> ../dm-8
lrwxrwxrwx.  1 root root        7 Oct  7 02:21 HostVG-Swap -> ../dm-6
lrwxrwxrwx.  1 root root        7 Oct  7 02:13 live-osimg-min -> ../dm-5
lrwxrwxrwx.  1 root root        7 Oct  7 02:13 live-rw -> ../dm-4
Comment 1 Joey Boggs 2011-10-18 08:52:08 EDT

*** This bug has been marked as a duplicate of bug 746394 ***

Note You need to log in before you can comment on or make changes to this bug.