Bug 746394 - Improve devmapper support in GRUB2
Improve devmapper support in GRUB2
Status: CLOSED DUPLICATE of bug 742226
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 744098 (view as bug list)
Depends On:
Blocks: 744390
  Show dependency treegraph
 
Reported: 2011-10-15 06:38 EDT by Marek Goldmann
Modified: 2011-11-09 13:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-09 13:47:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Improved devmapper for grub2 patch (9.88 KB, patch)
2011-10-15 06:38 EDT, Marek Goldmann
no flags Details | Diff
Improved devmapper for grub2 patch (12.86 KB, patch)
2011-11-07 06:18 EST, Marek Goldmann
no flags Details | Diff

  None (edit)
Description Marek Goldmann 2011-10-15 06:38:50 EDT
Created attachment 528314 [details]
Improved devmapper for grub2 patch

Description of problem:

The current version of GRUB2 has known issues with devmapper when using with loopback devices. It was reported upstream in this bug: http://savannah.gnu.org/bugs/?27737

The issue was fixed in upstream bzr repository in revision 3302. I cherry-picked the commit and tested it - works nicely.

I'm attaching the patch for F16 branch of grub2.
Comment 1 Marek Goldmann 2011-10-16 10:24:40 EDT
You can find packages built with above patch applied here: http://goldmann.fedorapeople.org/bz/746394/
Comment 2 Joey Boggs 2011-10-17 15:39:36 EDT
This patch wfm installing grub to a /dev/mapper device now

bumped priority since patch is a blocker for me in ovirt-node
Comment 3 Joey Boggs 2011-10-18 08:52:08 EDT
*** Bug 744098 has been marked as a duplicate of this bug. ***
Comment 4 Joey Boggs 2011-11-04 12:18:19 EDT
any chance we can get this in a build soon?
Comment 5 Marek Goldmann 2011-11-07 06:18:57 EST
Created attachment 532016 [details]
Improved devmapper for grub2 patch

I've updated one more time RPMs with proposed fix for this issue. These builds also include patch for bug#746730. You can find them here:

http://goldmann.fedorapeople.org/bz/746394/

I'm attaching also updated patch to apply directly to the repo.
Comment 6 Mike Burns 2011-11-07 15:33:44 EST
Is there any chance of this getting into Fedora 16 relatively soon after release?

Thanks
Comment 7 Alan Pevec 2011-11-08 17:14:23 EST
Possible dup of bug 742226 ?
Joey, Marek, does grub2-1.99-12.fc16 work, it seems to include Improve-devmapper-support.patch ?
Comment 8 Joey Boggs 2011-11-08 20:44:20 EST
looks like grub2-1.99-12.fc16 does work for ovirt-node install

marek, may want to retest now and see for your case
Comment 9 Marek Goldmann 2011-11-09 13:47:17 EST
Yes, that looks good for me too. Closing and marking as duplicate of bug 742226.

*** This bug has been marked as a duplicate of bug 742226 ***

Note You need to log in before you can comment on or make changes to this bug.