Bug 7441 - Slow Telnet responce and FTP responce at Login.
Slow Telnet responce and FTP responce at Login.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: telnet (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
:
: 7442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-30 08:14 EST by unixguru10
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-22 17:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description unixguru10 1999-11-30 08:14:10 EST
I have a Dual Pentium III based server and 512 Meg of ram, all running
at 400Mhz. A DPT RAID controler and a tulip 100 Base-T Either Card.
Upon inital contact with the machine the response is very slow. It may
take up to 6 minuites to get a login. But one the login is received the
system works fine. Speed is great I have no complaints. I have tried
different IRQ's for the card and different i/o settings all give the
same results.

Port 21 is next to impossible to log on to. (My FTP Server)
Port 23 is slow ............................(My telnet sessions.)
Port 80 is Damn Fast! ......................(My web Server.)

Below are not my problems but requests Please answer them if you can.

Oh and who the Hell wrote the G++ compiler! Someone send that guy a
check! That is the fastest thing on the planet! Why is he/she giving
it away and not selling it! Geez Louise!

I am also looking for a 386/486/Pentium Assembler. I have a project that
C++ just won't cut do to program size. I really need to get down and
dirty on this project. Can you help me. I am willing to pay for it.

Thankyou for your time.

Michael Velasco
Comment 1 Bill Nottingham 1999-11-30 11:17:59 EST
Most likely it's trying to do a reverse DNS lookup
on the hostname of the connecting machine, and it's
timing out. Make sure your DNS settings are sane.
Comment 2 Bill Nottingham 1999-11-30 11:18:59 EST
*** Bug 7442 has been marked as a duplicate of this bug. ***

------- Email Received From  "Michael Velasco" <unixguru10@hotmail.com> 12/04/99 07:16 -------
Comment 3 Mike Bird 1999-12-19 15:14:59 EST
There is a real bug here too.  "in.telnetd" passes "host space domain" after
the -h flag instead of "host dot domain".  "login" attempts a reverse DNS
lookup on "host dot" which can take forever if there is no route to a root
DNS server, even if all your forward and reverse DNS is complete and consistent.

I was recently locked out of a remote server because of this.  It had lost its
default route and, although I could start a telnet session from the border
router, the bogus reverse DNS lookup always took longer than the login timeout.
Comment 4 Henri Schlereth 2001-01-22 03:02:26 EST
Does this problem still exist with the current release? I am unable to 
duplicate this in the current version.
Comment 5 Mike Bird 2001-01-22 17:18:36 EST
Problem existed in 6.1.  It appears to be fixed in 6.2 (telnet-server-0.16-6).
Comment 6 Henri Schlereth 2001-01-22 20:57:36 EST
Thank closing this bug.

Note You need to log in before you can comment on or make changes to this bug.