Bug 74417 - TB NCHardwareList.py:288:save
TB NCHardwareList.py:288:save
Status: CLOSED DUPLICATE of bug 65073
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 77616 (view as bug list)
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-09-23 18:43 EDT by Alessio Maria Braccini
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-11 05:17:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessio Maria Braccini 2002-09-23 18:43:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
The following is the output of the program after the crash.

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 858dab0>
hw: <netconfpkg.HardwareList.Hardware instance at 8523570>
selfkey: IRQ
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 85a1d30>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 84ea5b0>
confkey: irq
self: [<netconfpkg.HardwareList.Hardware instance at 8523570>,
<netconfpkg.HardwareList.Hardware instance at 8522a68>]

It crashes everytime i try to assign an IRQ number to a nic. I edit the
properties of one of my nic, under the hardware tab, and chose an interrupt
number. Other values (mem, io, dma) are left blank. The crash happens when
applying changes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. On the main window click on the Hardware tab
2. Select a nic and click Modify
3. From the scroll-down menu near IRQ chose a number
4. Click OK
5. Click Apply ---> Crash

(sorry, i translated the name of the buttons and commands directly from my
italian interface, so the name could be different in english)

Actual Results:  The program crashes and ask to submit the bug. The following
text is obtained:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 858dab0>
hw: <netconfpkg.HardwareList.Hardware instance at 8523570>
selfkey: IRQ
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 85a1d30>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 84ea5b0>
confkey: irq
self: [<netconfpkg.HardwareList.Hardware instance at 8523570>,
<netconfpkg.HardwareList.Hardware instance at 8522a68>]


Expected Results:  The program should save changes and exit normally

Additional info:

My configuration is the following:

AMD K6II-450 256Mb ram
20 Gb HD (for Linux) + 10 Gb HD (win98)
VGA Asus V6800
NIC1: PCI realtek compatible
NIC2: ISA 3Com Etherlink III
Audio Sb AWE 64
2 Cd-Rom
ZIP drive plugged to the ide controller located on the audio card
wireless mouse
Comment 1 Harald Hoyer 2002-10-23 05:36:49 EDT
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.
Comment 2 Harald Hoyer 2002-11-11 05:17:34 EST
*** Bug 77616 has been marked as a duplicate of this bug. ***
Comment 3 Harald Hoyer 2002-11-20 12:57:08 EST

*** This bug has been marked as a duplicate of 65073 ***

Note You need to log in before you can comment on or make changes to this bug.