Bug 744390 - Add support for GRUB2
Add support for GRUB2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: appliance-tools (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On: 746394 746730
Blocks: 734351 744388
  Show dependency treegraph
 
Reported: 2011-10-08 04:35 EDT by Marek Goldmann
Modified: 2011-11-27 16:55 EST (History)
8 users (show)

See Also:
Fixed In Version: appliance-tools-006.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-27 16:55:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marek Goldmann 2011-10-08 04:35:59 EDT
Description of problem:

Only Grub Legacy is supported at this time. Fedora 16+ is using Grub2.

Version-Release number of selected component (if applicable):

appliance-tools-005-1.fc16.noarch
Comment 1 Marek Goldmann 2011-10-13 03:01:53 EDT
Hi Alan,

I am currently investigating this and I may provide a patch for it soon. This will most probably require patching also grub2 package, because current version doesn't want play nice with devmapper (I have a patch for this too).
Comment 2 Alan Pevec 2011-10-13 03:11:10 EDT
The most excellent, Marek!
If you have any test builds, please send it to me, I'll test it in bug 734351.
Thanks!
Comment 3 Joey Boggs 2011-10-13 11:33:38 EDT
same here for trying any test builds or any progress, we need this working for ovirt-node installations as they rely on /dev/mapper devices
Comment 4 Marek Goldmann 2011-10-15 07:05:14 EDT
I've posted on the mailing list my initial work on this issue, please add there comments if you have: https://www.redhat.com/archives/thincrust-devel/2011-October/msg00004.html

Every input is greatly appreciated!
Comment 5 Marek Goldmann 2011-11-08 12:17:18 EST
I've commited fix to upstream repo and built temporary RPMs, please take test them at your leisure:

http://goldmann.fedorapeople.org/bz/744390/
Comment 6 Fedora Update System 2011-11-11 09:22:06 EST
appliance-tools-006-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/appliance-tools-006-1.fc16
Comment 7 Fedora Update System 2011-11-11 22:27:34 EST
Package appliance-tools-006-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing appliance-tools-006-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15799
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-11-18 15:59:54 EST
appliance-tools-006.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/appliance-tools-006.1-1.fc16
Comment 9 Fedora Update System 2011-11-27 16:55:54 EST
appliance-tools-006.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.