Bug 74456 - "Network Servers" doesn't work yet
"Network Servers" doesn't work yet
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-vfs2-extras (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: FutureFeature, Triaged
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-09-24 14:07 EDT by Shane Zatezalo
Modified: 2007-04-18 12:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-06 06:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Zatezalo 2002-09-24 14:07:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
You all have done an excellent job w/ rh8. However, on Win32 my users can 
start:run and type \\servername\blah. I can't give them that functionality w/ 
a stock NULL install, atleast that I can find. Or for that matter, an ability 
to right-click and mount, while in gnome.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install null (packages: everything)
2. desktop: standard rh8 'null' gnome
3. try to mount a win32 smb share w/o using command line
	

Additional info:
Comment 1 Miloslav Trmac 2002-09-24 22:53:54 EDT
Type "smb:" in the Nautilus location bar. It's even documented!
(somewhere in the Getting Started Guide IIRC).

You can also specify directly smb:///workgroup/computer/share,
but I'm not sure about this format.
Comment 2 Shane Zatezalo 2002-09-25 09:42:57 EDT
Yes, I know about smb://. However, there are 2 problems with that. First, if you do it,    
and it works, you can't right-click and mount (map in win32) something from a    
server/share. Our win32 users are quite used to this. It would be a great feature to be 
able to run mount straight from there. 
    
Secondly, browsing the shares doesn't always work through the null GUI. I've got admin 
privs on our domain. On the null box, if I goto smb://servername, through Nautilus, I can 
see the shares.  Trying to open one of them, I get "You don't have permissions necessary 
to view contents of "share".   
   
If I KVM over to my RH7.2 box, running KDE3.0.0, and do the same, it works. Not only 
that,  but if I mistype the username, or password, it comes back with a login box again. 
 
The  null box w/ gnome does not do this, just displays that error above, constantly.   
 
On the null box, if I switchdesk to KDE, and try rlan:/ I get: "could not read 
/tmp/resLisa-shane". 
 
On the null box, doing a smbclient -L osba0 -W osba -U szatezalo works like a champ. It's 
the GUI that doesn't seem to be working like it should, through Nautilus and/or Konq. 
 
Comment 3 Alexander Larsson 2002-10-02 03:03:07 EDT
Do you have an anonymous account on that machine that can log in but have no
read-rights? A lot of people have reported that. At the moment you only get the
login dialog if anon login failed, which breaks then.
Comment 4 Leonid Mamtchenkov 2002-10-30 08:23:24 EST
Konqueror allows browsing through smb shares aswell.  Newer versions of
koonqueror even allow one to bookmark the location and then easily go there.  I
think it's a "good enough" solution to mounting problem.  Otherwise, there would
be too much AI involved. :)
Comment 5 Alexander Larsson 2002-11-05 06:00:38 EST
Latest gnome cvs allows that too.
Comment 6 Havoc Pennington 2003-01-12 15:55:11 EST
There's a "Network Servers" menu item (network:/// in nautilus) which lets you 
"bookmark" servers, in the latest code. However I think it's broken 
since it relies on vfolder menu editing backend working, which it does not yet. 
I could be wrong, I didn't try it.
Comment 7 Bastien Nocera 2003-01-13 06:33:27 EST
Yes, it's a gnome-vfs bug. See:
http://bugzilla.gnome.org/show_bug.cgi?id=102533
Comment 8 Havoc Pennington 2003-01-13 10:56:21 EST
Oh great, ANOTHER bug in the new vfolder stuff.

Bastien - at the moment I've backed down to the 8.0 (George's) vfolder code, 
because of several bugs in the new code - basically it doesn't work at all - 
but of course the old stuff lacks all editing support. That's why our 
network:/// is totally inoperable.

I think I can use plain old libdesktop.so (as in the old ~/.gnome/apps)
to get it working.

Sigh.
Comment 9 Bastien Nocera 2003-01-13 12:28:37 EST
At worse you could back out the "Network Servers" entry point, which is in
nautilus, IIRC.
Comment 10 Alexander Larsson 2003-08-06 06:30:12 EDT
What we've done is pointed network servers to smb://

Note You need to log in before you can comment on or make changes to this bug.