This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 745033 - INTEL: spice-client canvas is not being refreshed in specific display layout
INTEL: spice-client canvas is not being refreshed in specific display layout
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: Regression
Depends On:
Blocks: 842499
  Show dependency treegraph
 
Reported: 2011-10-11 04:59 EDT by Lubos Kocman
Modified: 2013-02-21 03:02 EST (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.13.0-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:02:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from the client system (213.68 KB, application/octet-stream)
2011-10-11 04:59 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2011-10-11 04:59:30 EDT
Created attachment 527394 [details]
Xorg.0.log from the client system

Description of problem:

I'm using following display layout on my T400 (see gpu at additional info):

Laptop is connected trough DVI to external display which is on the left side. The laptop screen was disabled trough gnome-display properties. So the only active display is the external one.

If you'll open spice-client in fullscreen mode (only in fullscreen) then the client screen/canvas contains static image which is not being changed/refreshed until it's switched back to window mode.

I've tested this on friends laptop with nvidia which had same spice-client version and the problem did not happen while it's reproducible 100% on my intel.

I've used same display layouts on both displays (but display resolutions were bit different).

The guest seems to receive input events normally (which is proven by switching from fullscreen to window mode, as e.g. start menu appears ...) but the screen is not being refreshed.

It also happened in one of many cases in window mode, then simply moving window helped. So seems like switching client from fullscreen to window mode also changes/re-sets display mode on the client mode and this is probably causing that the screen is again refreshed.

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.15.0-2.el6.x86_64
xorg-x11-server-Xorg-1.10.4-3.el6.x86_64
spice-client-0.8.2-7.el6.x86_64
spice-xpi-2.4-4.el6.x86_64
qemu-kvm-0.12.1.2-2.184.el6.x86_64
spice-server-0.8.2-3.el6.x86_

How reproducible:


Steps to Reproduce:
1. obtain same display layout (extended screen: enabled; laptop_display: disabled;)
1. connect trough spice-client to any guest (happens on windows7x64 and rhel6)
2. switch to fullscreen mode (shift+f11)
3. do some mouse events for few seconds, open window
4. switch to window mode (shift+f11)
  
Actual results:

screen is not being refreshed in step 3
changes on display are displayed after step 4 and are continuing to be draw correctly expect one of many cases in which simple window movement helps (that are described in original description)


Expected results:


screen should be refreshed as normally in any case


Additional info:

1) email / ping lkocman to obtain access to guest/rhevm.

2) happens with both linux and window guest

2) does not happen on nvidia (following device was tested)

01:00.0 VGA compatible controller [0300]: nVidia Corporation GT218 [NVS 3100M] [10de:0a6c] (rev a2)

3) lspci -nn | grep -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)


4) display layout 

xrandr
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1440x900       60.0 +   59.9     59.9     50.0  
   1360x768       60.0  
   1280x800       59.8     59.9  
   1280x768       59.9     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      60.0*+
   1600x1200      60.0  
   1400x1050      60.0  
   1280x1024      75.0  
   1440x900       75.0     59.9  
   1280x960       60.0  
   1280x800       59.8  
   1152x864       75.0  
   1024x768       75.1     75.0     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)


5) Switching from qxl to vesa on rhel guest (not on the client) does not make any difference  so it's not duplicate of Bug 37840

6) downgrading spice-client did not help.
Comment 1 Lubos Kocman 2011-10-11 05:00:51 EDT
Some customers might be affected by this issue as spice will be no longer a technology preview in 6.2
Comment 2 Lubos Kocman 2011-10-11 06:40:18 EDT
Correction: it's not a duplicate of a Bug 737840 due it's non-dependency on qxl driver.
Comment 3 Lubos Kocman 2011-10-11 06:44:05 EDT
Workaround: turning on Compiz or using different layout then mentioned.
Comment 8 Adam Jackson 2012-09-26 11:02:17 EDT
Given the description of the issue and the workaround in comment #3, I suspect this is effectively the same issue as bug #608076.  Said bug is no longer present in current 6.4 snapshots.

Can you reproduce this in a 6.4 snap?
Comment 9 Adam Jackson 2012-10-02 15:35:03 EDT
Moving to xorg-x11-server and MODIFIED, this is almost certainly a dupe of 608076.
Comment 11 RHEL Product and Program Management 2012-10-02 15:51:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 15 errata-xmlrpc 2013-02-21 03:02:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0299.html

Note You need to log in before you can comment on or make changes to this bug.