Bug 745035 - bootloader doesn't install for xenpv guests
bootloader doesn't install for xenpv guests
Status: CLOSED DUPLICATE of bug 736993
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-11 05:02 EDT by Andrew Jones
Modified: 2011-10-24 19:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 19:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (17.90 KB, text/plain)
2011-10-11 10:45 EDT, Andrew Jones
no flags Details
program.log (52.15 KB, text/plain)
2011-10-11 10:46 EDT, Andrew Jones
no flags Details
syslog (177.02 KB, text/plain)
2011-10-11 10:46 EDT, Andrew Jones
no flags Details

  None (edit)
Description Andrew Jones 2011-10-11 05:02:03 EDT
An error message saying the bootloader failed to install is displayed, and then the guest completes installation and is allowed to reboot. However it's not bootable - apparently due to the broken bootloader.

I've only seen this with paravirt xen guest installs. fully-virt xen guests install correctly and are bootable afterwards.
Comment 1 Chris Lumens 2011-10-11 09:19:08 EDT
Please attach /tmp/anaconda.log, /tmp/syslog, and /tmp/program.log from the end of installation (they're in /var/log/anaconda/ post-install) to this bug report.  Thanks.
Comment 2 Andrew Jones 2011-10-11 09:42:53 EDT
Is there a way to break out of a text-only install to a prompt? I can't use F2 on a graphical install, because graphical installs are broken for xenpv guests too (bug 741950). I may be able to mount the disk image after the failed install, but it's not easy due to LVM being used.
Comment 3 Chris Lumens 2011-10-11 09:53:27 EDT
^Z ought to work.
Comment 4 Andrew Jones 2011-10-11 10:44:28 EDT
^Z worked, I'm glad to know it. This looks like the interesting stuff, but I scp'ed off the files and will still attach them.

16:40:28,946 INFO program: Running... grub2-set-default Fedora Linux, with Linux
 3.1.0-0.rc8.git0.1.fc16.x86_64
16:40:29,035 INFO program: Running... grub2-mkconfig -o /boot/grub2/grub.cfg
16:40:30,032 ERR program: Generating grub.cfg ...
16:40:30,083 ERR program: cat: /boot/grub2/video.lst: No such file or directory
16:40:30,086 ERR program: Serial terminal not available on this platform.
Comment 5 Andrew Jones 2011-10-11 10:45:34 EDT
Created attachment 527462 [details]
anaconda.log
Comment 6 Andrew Jones 2011-10-11 10:46:05 EDT
Created attachment 527464 [details]
program.log
Comment 7 Andrew Jones 2011-10-11 10:46:33 EDT
Created attachment 527465 [details]
syslog
Comment 8 Mads Kiilerich 2011-10-24 19:52:55 EDT

*** This bug has been marked as a duplicate of bug 736993 ***

Note You need to log in before you can comment on or make changes to this bug.