Bug 74514 - 'less' shows blank screen until reset-and-clear
'less' shows blank screen until reset-and-clear
Status: CLOSED DUPLICATE of bug 74408
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-25 14:52 EDT by Andrew Huntwork
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 15:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Huntwork 2002-09-25 14:52:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
running 'less' in a gnome-terminal shows a blank screen except for 2 characters
in the lower left corner.  doing a terminal reset-and-clear fixes the problem
for the lifetime of the particular gnome-terminal.  you can see a particular
page of the file you are 'less'ing if you page down past it using the spacebar,
then page back up using 'w'.

all my packages are updated to the latest available through up2date, and I
haven't installed any weird non-redhat packages.  This is the second machine
I've seen this on.  This bug does not appear using the packages on the null iso
image.  It broke when I updated using up2date.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open gnome-terminal
2. type `less filename`, where filename has say 60 lines
3. notice that the gnome-terminal is empty, except for the filename on the
bottom line and one character in the left-most column of the second-to-last line
4. page down using the space bar.  note that the screen is still basically blank
5.  page up using 'w'.  notice that the screen shows the first page of  'filename'
6.  redo the whole process, but replace steps 4-5 with shading and unshading the
window.  the first page is displayed correctly.
7.  redo the whole process, but replace 4-5 with right clicking on the
gnome-terminal window (not the decorations, the 'canvas' area).  the first page
is displayed correctly
8.  redo the whole process, but cause the terminal to reset-and-clear before
step 2.  notice that all screens of 'filename' are displayed correctly without
any of steps 4-7.

Actual Results:  less does not display any page of its file without one of the
workaround in 4-7 executed for each page, or 8 executed once 

Expected Results:  less displays all pages of its file.

Additional info:
Comment 1 Havoc Pennington 2002-09-25 15:11:21 EDT
This should be fixed in final.
Comment 2 Nalin Dahyabhai 2002-10-17 20:34:56 EDT

*** This bug has been marked as a duplicate of 74408 ***

Note You need to log in before you can comment on or make changes to this bug.