Bug 74527 - /sbin not in path so ifup doesn't work in modemlights
/sbin not in path so ifup doesn't work in modemlights
Status: CLOSED DUPLICATE of bug 69971
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-applets (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2002-09-25 19:38 EDT by ramon
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-05 10:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description ramon 2002-09-25 19:38:40 EDT
The modem lights applet (/usr/libexec/modemlights_applet2) apparently does not work.

When I click in it, nothing happens.

The reason for the problem is that, with the default settings, the connexion
command is "ifup ppp0". But ifup is in /sbin, which is not in path for normal
users. Although the problem is easy to workaround once you know the reason, from
the point of view of a new user the applet is completly non-functional.

In addition, I miss the old modem applet in Redhat 7.3, which had a better user
interface: the user selected the Internet provider name, instead of having
to type the command.
Comment 1 Havoc Pennington 2002-09-26 16:54:47 EDT
The ifup command should have been fixed in final release.
Comment 2 Mattias Dahlberg 2002-10-05 04:56:20 EDT
Nope, I have the same problem in 8.0. The reason seems to be exactly what the 
reported explained, ifup is located in /sbin, which the applet can't find when 
run as a normal user.
Comment 3 ramon 2002-10-05 10:00:01 EDT
I have just installed Redhat 8.0 final (an update over Redhat 7.3) and can also
confirm that the problem exits.

As a modest suggestion, seeing that the new dialer has less features than the
old, isn't this an example of the software rewrite sindrome (
http://www.joelonsoftware.com/articles/fog0000000069.html ) ?

Comment 4 Havoc Pennington 2002-10-05 10:55:57 EDT
I don't think modemlights is a new rewrite; it has existed forever, it predates
the rp3 dialer applet which is probably what you are missing.

Thanks for confirming bug still there.
Comment 5 Havoc Pennington 2002-10-05 12:17:20 EDT

*** This bug has been marked as a duplicate of 69971 ***
Comment 6 ramon 2002-10-05 13:31:53 EDT
Why was rp3 dialer removed?
Comment 7 Havoc Pennington 2002-10-05 13:59:33 EDT
I don't know why it was removed. My guess is that it didn't work 
and people didn't have time to fix it.

Note You need to log in before you can comment on or make changes to this bug.