Bug 69971 - modemlights applet very broken in limbo
modemlights applet very broken in limbo
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
: 72628 72629 74527 75262 76403 (view as bug list)
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-07-26 23:59 EDT by Alex Yacoub
Modified: 2007-04-18 12:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 07:53:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Yacoub 2002-07-26 23:59:29 EDT
The modemlights applet will not turn on ppp correctly.  The control button is
mapped to the commands "pppon" and "pppoff", which don't exist on redhat.  This
should instead be "/sbin/ifup ppp0" and "/sbin/ifdown ppp0"

When the ppp link is activated, the applet does not monitor correctly, such that
it doesn't show activity, nor does it let you turn off the link.
Comment 1 Havoc Pennington 2002-07-27 12:02:26 EDT
Filed at http://bugzilla.gnome.org/show_bug.cgi?id=89207
Comment 2 Bill Nottingham 2002-07-29 00:23:32 EDT
HP: we should just fix the ifup/ifdown stuff in a local patch; it's probably RH
specific anyway.
Comment 3 Havoc Pennington 2002-07-29 10:09:17 EDT
Yeah, we had a patch in 7.3 for that.
Comment 4 Havoc Pennington 2002-07-29 12:24:56 EDT
Marking the head of the priority queue with priority high
Comment 5 Havoc Pennington 2002-07-29 15:46:41 EDT
2.0.1-1 should contain a fix for the command

the applet presumably still doesn't work, though.
Comment 6 tom georgoulias 2002-08-07 19:01:05 EDT
After the latest round of updates, I noticed the pppon/pppoff commands were
switched to ifup ppp0 and ifdown ppp0.  The applet in its default config still
doesn't work for me, so I prepended "/etc/sysconfig/network-scripts/" to
ifup/ifdown and was able to dial and shut down the modem through the applet. 
Still doesn't give any status output or use any colors though, it just sits
there and looks the same the whole time.

[tomg@gemini sbin]$ rpm -q gnome-applets
gnome-applets-2.0.1-2
Comment 7 Havoc Pennington 2002-08-07 19:05:48 EDT
Need /sbin/ifup I guess.
Comment 8 tom georgoulias 2002-08-07 20:20:39 EDT
Yup, /sbin/ifup works too.  Still don't get any feedback from the applet after I
connect, and clicking on it to hang up doesn't work.  It just asks if I want to
connect, even though I'm already connected.
Comment 9 Havoc Pennington 2002-08-14 00:42:13 EDT
2.0.1-4 should fix the ifup/ifdown path stuff
Comment 10 Havoc Pennington 2002-08-26 02:21:30 EDT
*** Bug 72629 has been marked as a duplicate of this bug. ***
Comment 11 Havoc Pennington 2002-08-26 02:22:49 EDT
*** Bug 72628 has been marked as a duplicate of this bug. ***
Comment 12 Havoc Pennington 2002-08-26 02:23:26 EDT
applet /sbin path change got lost, still broken.
Comment 13 Havoc Pennington 2002-10-05 12:16:17 EDT
On mailing lists, someone said that the lights don't work because the lock file
is configured incorrectly; if changed to LCK..modem (with full path) then the 
lights and graphs work.

Comment 14 Havoc Pennington 2002-10-05 12:17:13 EDT
*** Bug 74527 has been marked as a duplicate of this bug. ***
Comment 15 Need Real Name 2002-10-11 08:42:49 EDT
I just installed RH 8.0. I am sorry for being so inept, but what is the correct 
path for the lock file. I can find no file on my system that contains the 
LCK...modem terms. I looked in /var/lock and I tried to locate anything about 
LCK or modem. Thanks
Comment 16 Steve Bangert 2002-10-15 00:47:24 EDT
Graphics and modem shutdown will work if modem lock file is set to correct path,
I'm using a USB modem so the path is "/var/lock/LCK..ttyACM0, this file
can _only_ be seen while the modem is connected. Hope this helps.
Comment 17 Need Real Name 2002-10-15 07:10:45 EDT
My thanks to sbangert@mindspring.com. This was helpful. I also found some info 
at gnome.org. Easiest way to locate the correct path is to connect with the 
modem, open a terminal while connected and do $ ls /var/lock/LCK*. This will 
return the correct path.
Comment 18 Brent Fox 2002-10-16 15:49:41 EDT
Does the original problem seem to be fixed in 8.0 final?  I don't have a modem
in order to test it...
Comment 19 Need Real Name 2002-10-17 20:28:24 EDT
On a fresh 8.0 install, had to change connect command from "ifup ppp0" to
"/sbin/ifup ppp0", and similarly for disconnect command.  Also changed
lock file to "/var/lock/LCK..ttyS4" (which shows up when ppp connects
as per the previous comments) and device to "ttyS4".  Modem will
now connect and disconnect OK, but the graphs and lights don't work.  Only
the connect button changes from unlit to yellow, then sits there until
I disconnect.  The connect time updates, though.
Comment 20 Ronny Klein 2002-11-28 04:22:19 EST
I had the same problem with isdn. The lights didn't show up. I tried xisdnload
and that gave me the right hint: /dev/isdninfo isn't world-readable. No idea if
there is a security problem with that; but I changed the permissions so that
other can read /dev/isdninfo: chmod o+r /dev/isdninfo. Now the modemlights are
blinking.
Comment 21 Havoc Pennington 2002-12-19 21:41:42 EST
*** Bug 75262 has been marked as a duplicate of this bug. ***
Comment 22 Bill Nottingham 2003-02-10 23:54:55 EST
/sbin readded in 2.2.0-2.
Comment 23 Bill Nottingham 2003-02-10 23:55:38 EST
*** Bug 76403 has been marked as a duplicate of this bug. ***
Comment 24 Troy 2003-12-06 08:51:31 EST
For people who now have linux but understand little to nothing about
the detail of working out problems such as this modem lights problem....

place your mouse pointer on your blue desktop screen and right click.
A window comes up that has, "New Terminal" as a selection....click on
it. A window comes up with a blinking curser....type in              
   find /var/lock/LCK*  and hit enter.

In my case  /var/lock/LCK..ttS0  is what the screen feed me back.
(that is S zero, not S Oh). Yours may be slightly diffrent. Make note
of exactly what it is.

Now right click on the modem light thing, select "prefrences" and
click the "advanced" tab. In that tab you will see "modem lock file"
followed by an area you can type in. In my case the area read
/var/lock/LCK..modem, which didn't work as there was no such file (we
looked for all /var/lock/LCK files when we ran find /var/lock/LCK* in
the terminal window.....and it wasn't listed). Change this to what was
listed....in my case it became /var/lock/LCK..ttS0.  This fixed my
modem problem 100%, and hopefully it will work for you too.
Comment 25 Troy 2003-12-06 09:20:40 EST
I'm so sorry....tried to make it easy for anyone to fix the modem
lights problem and forgot one aspect (this is in addition to comment
#24 above). In addition to following comment #24, also do the following:

right click on your modemlights and select5 "prefrences". You will see
a connect and disconnect command. In the connect command type 
/sbin/ifup ppp0  (that is a zero not an oh)
In the disconnect command space type in
/sbin/ifdown ppp0

Now you will not only have your modem lights work, but in addition you
can connect and disconnect via clicking the left side of the modem
lights icon.....sorry for leaving this out above.
Comment 26 Mark McLoughlin 2004-12-20 07:53:56 EST
Doesn't look like we've had reports of this since. Closing

Note You need to log in before you can comment on or make changes to this bug.