Bug 745446 - rpmlint-1.2-1.fc15.noarch checks ghost manual pages for encoding
rpmlint-1.2-1.fc15.noarch checks ghost manual pages for encoding
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-12 07:42 EDT by Petr Pisar
Modified: 2011-10-22 04:27 EDT (History)
5 users (show)

See Also:
Fixed In Version: rpmlint-1.3-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-19 00:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2011-10-12 07:42:34 EDT
Run rpmlint of binary package delivering ghost manual pages. Example with `whois' package:

$ rpmlint x86_64/whois-5.0.11-1.fc17.x86_64.rpm 
[...]
whois.x86_64: W: file-not-utf8 /usr/share/man/man1/whois.1.gz
[...]

The ghost file is created with %files line:

%ghost %verify(not md5 size mtime) %{_mandir}/man1/%{name}.1.gz

I think rpmlint should not examine content of ghost files as they do not exist at installation time.
Comment 1 Toshio Ernie Kuratomi 2011-10-12 10:48:06 EDT
The bug report is perhaps technically true but.... What is the purpose of %ghost'ing (and customizing the %verify) for the manpage?  Naively, I'd say that the spec file should be changed in this case.... At the moment, I can't think of any file on /usr that should be %ghost'd.
Comment 2 Petr Pisar 2011-10-12 10:55:47 EDT
The purpose is <https://fedoraproject.org/wiki/Packaging:Alternatives>.

The ghost flag is saved in binary package, so just skipping flagged files should be enough to fix rpmlint. You can practice with live whois package. It's available since F15.
Comment 3 Ville Skyttä 2011-10-12 11:25:39 EDT
Fixed upstream now although this is a rare case (the latter hunk of the patch):
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1886
Comment 4 Toshio Ernie Kuratomi 2011-10-12 13:38:40 EDT
(In reply to comment #2)
> The purpose is <https://fedoraproject.org/wiki/Packaging:Alternatives>.
> 
> The ghost flag is saved in binary package, so just skipping flagged files
> should be enough to fix rpmlint. You can practice with live whois package. It's
> available since F15.

Okay.  That explains the %ghost.  Isn't the %verify extraneous with %ghost used in this manner?
Comment 5 Fedora Update System 2011-10-12 15:03:55 EDT
rpmlint-1.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpmlint-1.3-2.fc15
Comment 6 Fedora Update System 2011-10-12 15:04:08 EDT
rpmlint-1.3-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rpmlint-1.3-2.fc14
Comment 7 Fedora Update System 2011-10-12 15:04:22 EDT
rpmlint-1.3-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpmlint-1.3-2.fc16
Comment 8 Petr Pisar 2011-10-13 03:58:55 EDT
The %verify presents to inhibit content checking but to observe mode of the file (e.g. make sure regular user cannot write into a log).
Comment 9 Fedora Update System 2011-10-13 14:10:35 EDT
Package rpmlint-1.3-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpmlint-1.3-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14240
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-10-19 00:29:20 EDT
rpmlint-1.3-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-10-22 04:22:22 EDT
rpmlint-1.3-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2011-10-22 04:27:55 EDT
rpmlint-1.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.