Bug 74557 - PHP component not compiled with FTP library
PHP component not compiled with FTP library
Status: CLOSED DUPLICATE of bug 72738
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On: 72738
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-26 12:38 EDT by Andy P
Modified: 2006-02-21 13:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the phpinfo() screen after the update (54.34 KB, text/html)
2002-09-26 12:54 EDT, Andy P
no flags Details

  None (edit)
Description Andy P 2002-09-26 12:38:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
the latest PHP update (which bumped version information to 4.1.2) packages have 
a big problem: internal FTP support is disabled (whereas in prior versions it 
was enabled). take a peek at the phpinfo(); screen: it says (within 
configuration options) that it was configured with --with-ftp, which is WRONG, 
WRONG, WRONG. :( the PHP manual clearly states that the correct option is --
enable-ftp. correct this ASAP please. btw, something got changed in the IMAP 
extension, too, i had to reconfigure IMP (to ignore certificate discrepancies, 
which is odd, as i didn't use IMAP-SSL), but i could fix that. this i can't.

Version-Release number of selected component (if applicable):
4.1.2-7.1.4

How reproducible:
Always

Steps to Reproduce:
1. upgrade a 7.1 box with the latest PHP update packages.
2. create a PHP document that has phpinfo(); in it.
3. watch the screen.
optionally: use any of the ftp_* commands. it says that the function doesn't 
exist.
	

Actual Results:  i got severely angry. ;) and FTP support doesn't work.

Expected Results:  nothing. the scripts should have had carried on fine after 
the upgrade.

Additional info:

so again:
--with-ftp : BAAAD!
--enable-ftp : GOOD!

recompile, please.
Comment 1 Andy P 2002-09-26 12:54:59 EDT
Created attachment 77324 [details]
the phpinfo() screen after the update
Comment 2 Andy P 2002-12-24 10:59:04 EST
The new PHP update still contains this bug. Could a quickfix be issued as this 
bug bugs the hell out of me... :( Quite a few applications depend on ftp 
functionality on my servers, and I guess I'm not alone with this... :(((
Comment 3 Axoria Ltd 2003-02-19 08:11:07 EST
This is a DUPLICATE of 72738.

I have added further details there.
Comment 4 Joe Orton 2004-04-05 08:40:48 EDT

*** This bug has been marked as a duplicate of 72738 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:49:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.