Bug 72738 - FTP function in new PHP 4.1.2-7.0.3 are not compiled corectly
FTP function in new PHP 4.1.2-7.0.3 are not compiled corectly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 72971 73489 74557 (view as bug list)
Depends On:
Blocks: 74557
  Show dependency treegraph
 
Reported: 2002-08-27 02:31 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 08:32:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-27 02:31:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
The PHP is compiled with option --with-php which is used for versions 3.x.x of 
PHP and should be --enable-ftp for versions 4.x.x

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try ftp_connect()


	

Actual Results:  Call to undefined function: ftp_connect()

Expected Results:  connection to some ftp services

Additional info:
Comment 1 Phil Copeland 2002-08-27 14:39:11 EDT
*scratch*...
From the spec file for 4.1.2-7.0.4 (current errata) there is no --with-php as
you'll see, the configuire is called as --with-ftp. I don't understand how your
php install is built with --with-php at all because it's just plain not
referanced. I looked at this on 7.0,1,2,3 which all have more or les the same
configure options. ftp_connect is not recognised on 7.0 or 7.1 but is on 7.2 and 7.3

Phil
=--=

%configure \
        --prefix=%{_prefix} \
        --with-config-file-path=%{_sysconfdir} \
        --enable-force-cgi-redirect \
        --disable-debug \
        --enable-pic \
        --disable-rpath \
        --enable-inline-optimization \
        --with-bz2 \
        --with-db3 \
        --with-exec-dir=%{_bindir} \
        --with-png-dir=%{_prefix} \
        --with-gd \
        --enable-gd-native-ttf \
        --with-ttf \
        --with-gdbm \
        --with-gettext \
        --with-ncurses \
        --with-gmp \
        --with-iconv \
        --with-jpeg-dir=%{_prefix} \
        --with-openssl \
        --with-png \
        --with-pspell \
        --with-regex=system \
        --with-ftp \
        --with-zlib \
        --with-layout=GNU \
        --enable-bcmath \
        --enable-debugger \
        --enable-magic-quotes \
        --enable-safe-mode \
        --enable-sockets \
        --enable-sysvsem \
        --enable-sysvshm \
        --enable-discard-path \
        --enable-track-vars \
        --enable-trans-sid \
        --enable-yp \
        --enable-wddx \
        --without-oci8 \
        --with-imap=shared \
        --with-imap-ssl \
        --with-kerberos=/usr/kerberos \
        --with-ldap=shared \
        --with-mysql=shared,%{_prefix} \
        --with-xml \
%if %{oracle}
        --with-oci8=shared \
%endif
        --with-pgsql=shared \
        --with-snmp=shared,%{_prefix} \
        --with-snmp=shared \
        --enable-ucd-snmp-hack \
        --with-unixODBC=shared \
        --enable-memory-limit \
        --enable-bcmath \
        --enable-shmop \
        --enable-versioning \
        --enable-calendar \
        --enable-dbx \
        --enable-dio \
        --enable-mbstring \
        --enable-mbstr-enc-trans \
        $*
Comment 2 Need Real Name 2002-08-28 00:19:49 EDT
Sorry, of cource there is --with-ftp but this option is incorect.
Comment 3 Phil Copeland 2002-08-29 12:55:10 EDT
aye,.. I've been informed that it's supposed to be --enable-ftp not --with-ftp

[root@alpha SPECS]# grep "\-ftp" php*
php-4.1.2-7.0.4.spec:   --with-ftp \
php-4.1.2-7.1.4.spec:   --with-ftp \
php-4.1.2-7.2.4.spec:   --enable-ftp \
php-4.1.2-7.3.4.spec:   --enable-ftp \

guess which ones work and which ones don't.
I'll just go over into a corner here and hide... new errata being made.

Appologies

Phil
=--=
Comment 4 Phil Copeland 2002-08-29 12:55:41 EDT
*** Bug 72971 has been marked as a duplicate of this bug. ***
Comment 5 Phil Copeland 2002-08-29 15:35:21 EDT
php-4.1.2-7.0.5 and php-4.1.2-7.1.5 built... no idea where they'll be available
from as yet.

Comment 6 Phil Copeland 2002-09-05 10:51:49 EDT
*** Bug 73489 has been marked as a duplicate of this bug. ***
Comment 7 Joe Orton 2002-09-26 04:44:46 EDT
Leaving this open whilst an errata is still pending.
Comment 8 Joe Orton 2002-09-27 04:09:08 EDT
*** Bug 74542 has been marked as a duplicate of this bug. ***
Comment 9 Need Real Name 2002-11-14 04:08:57 EST
The same problem is in new nersion php-4.1.2-7.0.6 :-)
Comment 10 Axoria Ltd 2003-02-19 08:08:32 EST
I've added a comment to 74557 saying it's a DUPLICATE of this bug, but I cannot change it's status as I am a lowly mortal ;)

I note this bug has been outstanding for some time, and is _still_ present in even recent patches. Just to re-iterate, the obsolete --with-ftp needs to be replaced by --enable-ftp and whilst this has been done in, for example, php-4.1.2-7.3.6, it still has NOT been fixed in php-4.1.2-7.1.6 despite the two being related, huh? Moreover, the mysql.so extension was missed in the php.ini file, I think - what else is wrong with the php-4.1.2-7.1.6 build?

Still, the main thing is getting the compile-time issue fixed so those of us using 7.1 rather than 7.3 can utilise the built-in FTP functionality. It's become a bit critical for one of our customers in particular, so any urgency with a fix would be greatly apprciated. Whatever happens, I am _hoping_ that the it slips no further into the future than the next scheduled patch/release - perhaps someone can nudge the priority up to HIGH please? :)

Thanks folks.
Comment 11 John R Pierce 2003-10-24 01:10:32 EDT
*STILL* broken in php-4.1.2-7.1.6

yeah, this is a major annoying bug for us too.  have a production server
colocated at a remote site running 7.1 that would be difficult to reinstall to a
newer RH version.  

installed a bunch of security updates, and php4.1.2 came along for the ride, and
BLAM, ftp_connect() stopped working.  I spent several hours figuring out why,
identified the --with-ftp vs --enable-ftp thing, built my own 4.1.2 from SRPMS
(UGH!), and installed it, but am dreading the next round of up2date fixes which
will possibly revert to the broken PHP4....

Comment 12 Joe Orton 2004-04-05 08:32:20 EDT
Thanks for the reports.  Since this bug is fixed in current releases
and 7.1 is no longer supported, closing this bug now.  Please reopen
against a current release if the bug recurs.
Comment 13 Joe Orton 2004-04-05 08:40:50 EDT
*** Bug 74557 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.