Bug 745727 - Key F10 is giving me window manage menu window
Key F10 is giving me window manage menu window
Status: CLOSED DUPLICATE of bug 800856
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-13 04:36 EDT by Zdenek Kabelac
Modified: 2012-10-12 08:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 08:52:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2011-10-13 04:36:37 EDT
Description of problem:

When I run 'mc' and I press the key F10 to get the quit question dialog for midnight commander  I get also a wm menu windows opened as well - and pressing 'enter' usually leads to opening a new g-t window (since I do not expect wm menu window opened and I activate new terminal option through this).

This used to work without a problem since I've not enabled
menu shortcut in keyboard shortcuts g-t options.

Now it doens't matter in which state this toggle button is,
there is always wm menu window.
When toggle button is in enable mode - 'mc' doesn't get F10 key
(and one has to use  Esc+0  to get  quit query dialog).


Version-Release number of selected component (if applicable):
gnome-terminal-3.2.0-1.fc17.x86_64


How reproducible:


Steps to Reproduce:
1. run 'mc'
2. press F10
3.
  
Actual results:

mc shows quit query dialog, and wm menu is displayed as well.


Expected results:
only 'mc' quit dialog being shown.

Additional info:
Comment 1 ph03 2011-11-02 04:01:34 EDT
I have exactly the same issue on Gentoo linux with gnome-terminal.3.2.1 .
I think this is a general GTK issue as F10 opens the menu in all GTK applications, even though I have set 

/desktop/gnome/interface/menubar_accel

in gconf-edit to something else than "F10" ("Ctrl-Shift-M" in my case), but this setting seems to be ignored. Is there already a solution / related bug avaible?
Comment 2 Fedora Admin XMLRPC Client 2012-01-10 10:49:12 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2012-01-10 10:51:00 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Zdenek Kabelac 2012-01-13 05:32:57 EST
This problem is still present with:

gnome-terminal-3.2.1-3.fc17.x86_64
Comment 5 Matthias Clasen 2012-02-13 20:03:49 EST
gnome-settings-daemon is using gsettings for its backing storage nowadays, not gconf anymore. Try

gsettings set org.gnome.desktop.interface menubar-accel "F12"

or something like that
Comment 6 Zdenek Kabelac 2012-04-05 10:01:58 EDT
(In reply to comment #5)
> gnome-settings-daemon is using gsettings for its backing storage nowadays, not
> gconf anymore. Try
> 
> gsettings set org.gnome.desktop.interface menubar-accel "F12"
> 
> or something like that

Hmm - tried - no help

$ gsettings get org.gnome.desktop.interface menubar-accel 
'F12'


And just a side comment - you can't be really serious this now 'the Gnome path' to properly configure  gnome-terminal to allow users to use F10 key right ?

This  bz is getting quite old and with:

gnome-shell-3.3.90-2.fc17.x86_64
gnome-terminal-3.3.0-1.fc17.x86_64

I'm still not able to get usable F10 key inside terminal (i.e. to quit 'mc')
Comment 7 Pavel Stehule 2012-05-04 14:09:58 EDT
There is probably wrong handling of functional keys - because when I press F10, then gnome-menu is showed and mc dialog is showed too.I would to previous behave - when terminal-menu is active, then F10 is handled by terminal menu, and when menu is invisible, then F10 is handled by appliacation executed in terminal. Because mc is important application, then this bug is very important for me.
Comment 8 Petr Tuma 2012-06-07 14:40:06 EDT
Duplicate of bug 800856 (where workaround is posted).
Comment 9 Kamil Páral 2012-10-12 08:52:12 EDT

*** This bug has been marked as a duplicate of bug 800856 ***

Note You need to log in before you can comment on or make changes to this bug.