Bug 74625 - fails completely on system with two video cards
fails completely on system with two video cards
Status: CLOSED DUPLICATE of bug 77679
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-27 17:36 EDT by Chris Ricker
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-09-27 17:36:36 EDT
I have a box which has two video cards, an on-board 810 and a PCI nVidia RIVA TNT2:

[root@dartagnan root]# lspci 
00:00.0 Host bridge: Intel Corp. 82810 GMCH [Graphics Memory Controller Hub]
(rev 03)
00:01.0 VGA compatible controller: Intel Corp. 82810 CGC [Chipset Graphics
Controller] (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corp. 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corp. 82801AA USB (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801AA AC'97 Audio (rev 02)
01:0d.0 VGA compatible controller: nVidia Corporation RIVA TNT2 Model 64 (rev 15)
01:0e.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
[root@dartagnan root]# 

I'm only using the nVidia card.

redhat-config-xfree86 fails totally in generating a config for this system.  I
could only get an X setup by running XFree86 -configure, copying the output to
/etc/X11/XF86Config, and using that as a starting point for redhat-config-xfree86
Comment 1 Alexander Larsson 2002-10-02 03:21:01 EDT
Also related to bug 58532.
Comment 2 Brent Fox 2002-12-03 14:57:15 EST
Is the i810 card disabled in the bios?
Comment 3 Chris Ricker 2002-12-03 15:11:36 EST
The BIOS doesn't support enabling or disabling on-board video (it's a rather
sucky Phoenix BIOS)
Comment 4 Brent Fox 2002-12-19 01:53:16 EST
Systems whose bioses don't allow you to properly disable the onboard video seems
to be an increasingly common problem.
Comment 5 Brent Fox 2002-12-20 04:06:47 EST
Can you test with redhat-config-xfree-0.7.0-4 in Rawhide?  There have been lots
of  changes to the code.  I believe that the rhpl libraries now handle multiple
cards better.

On my wife's Dell, which has an on-board i845 graphics card (with no monitor)
and a PCI Radeon 7500 (which has the monitor attached to it), the program no
longer crashes but it identifies the on-board card instead of the Radeon.

I suspect that this is because kudzu scans the system in PCI bus order and it is
finding the on-board card first, so that's what is getting returned.  I'm
willing to bet that on your machine, the GUI will show the i810 card and not the
nVidia.

At least the program doesn't crash anymore.  I think that once the GUI is up,
you should be able to go to the Advanced tab and click "Configure" in the
videocard section.  This should allow you to select the nVidia card in the video
card dialog.

Detecting which card is correct is a much more difficult problem.  We may not
get that level of detection done with the next release.
Comment 6 Brent Fox 2003-01-17 16:36:43 EST
Chris: ping?
Comment 7 Brent Fox 2003-01-20 17:47:32 EST

*** This bug has been marked as a duplicate of 77679 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:49:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.