Bug 77679 - won't start with disabled on-board video card and add-on video card
won't start with disabled on-board video card and add-on video card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 74625 (view as bug list)
Depends On: 77676
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-11 17:25 EST by Tammy Fox
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:30:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of redhat-config-xfree86 --verbose --reconfig (from console) (541 bytes, text/plain)
2002-11-11 17:27 EST, Tammy Fox
no flags Details

  None (edit)
Description Tammy Fox 2002-11-11 17:25:11 EST
On a Dell Dimension 4500S, I disabled the Intel on-board video card and 
added an ATI Radeon 7500 (PCI). ddcprobe lists the Radeon, lspci shows both
cards.

redhat-config-xfree86 will not start from a console because
rhpl.videocard.VideoCardInfo() returns the onboard card (it only returns the
first card in the list from kudzu).

This bug depends on rhpl being fixed (#77676).
Comment 1 Tammy Fox 2002-11-11 17:27:14 EST
Created attachment 84587 [details]
output of redhat-config-xfree86 --verbose --reconfig (from console)
Comment 2 Alexander Larsson 2002-11-12 02:34:10 EST
Probably a dup of bug 74625 or bug 58532.
Comment 3 Brent Fox 2002-12-15 10:29:50 EST
I think maybe it's a little incorrect to say the on-board card was disabled. 
The Dell bios is pretty crappy and only allows you to either use the on-board
card *only* or else set it to "Auto".  It's not clear that "Auto" will actually
disable the on-board card.  Since lspci still sees the on-board card, I suspect
that the on-board card isn't being disabled at all.  

From looking at bug #74625, it looks like it's a pretty common problem for the
bioses to not fully disable the on-board card.  We need a way to handle multiple
video cards anyway.  I don't know if I'll have time for it this release, though.
Comment 4 Brent Fox 2003-01-20 11:24:37 EST
I think I've got a fix for this, but I will test it out some more before I check
it into cvs.  Instead of just trying on the first card that we find (which is
almost always the onboard card due to PCI bus order), I now grab a list of all
the video cards found on the machine and cycle through the list until one card
works.  This seems to work pretty well, but there are some other mouse related
bugs that I have to fix first.
Comment 5 Brent Fox 2003-01-20 14:58:37 EST
This should be fixed with redhat-config-xfree86-0.7.2-2.  You will also have to
upgrade redhat-config-mouse and run it once.  Earlier versions of
redhat-config-mouse was writing an incorrect /etc/sysconfig/mouse file, which
was causing redhat-config-xfree86 to generate an XF86Config file with an invalid
pointer.

QA, please verify.  You will need a machine with 2 video cards.
Comment 6 Brent Fox 2003-01-20 17:47:35 EST
*** Bug 74625 has been marked as a duplicate of this bug. ***
Comment 7 Chris Ricker 2003-01-30 11:12:34 EST
I'm now back home for a couple of days, so I can actually try this on the
machine in Bug 74625 ;-)

That machines has on-board Intel 810 and an additional Riva TNT2 PCI card. The
BIOS has no options regarding disabling the on-board or changing the priority of
on-board vs off-board....

I put r-c-xfree86-0.7.3-1 on there, moved the existing working XF86Config, and
tried to run r-c-x. Here's what I saw then:

[root@dartagnan root]# redhat-config-xfree86 
<screen flashes briefly>
Couldn't start X server, trying with a fresh configuration
Trying with card: Intel 810
<screen flashes briefly>
Couldn't start X server, trying with a fresh configuration
Trying with card: RIVA TNT2
<tries to switch to video mode -- monitor makes popping noise it makes when
switching modes, screen goes black, etc>
Error, cannot start X server.
[root@dartagnan root]# 

From the log file, it looks like now it's kinda working, its just generating a
XF86Config with an incorrect mouse type:

[root@dartagnan log]# more XFree86.setup.log 

XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-72) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-11smp i686 [ELF] 
Build Host: daffy.perf.redhat.com
 
Module Loader present
OS Kernel: Linux version 2.4.18-14 (bhcompile@stripples.devel.redhat.com) (gcc v
ersion 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 13:35:50 EDT 2002 
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/dev/null", Time: Thu Jan 30 08:58:40 2003
(++) Using config file: "/tmp/@8979.2xf86config"
(EE) Mouse0: Unknown protocol "genericwheelps/2"
(EE) PreInit failed for input device "Mouse0"
No core pointer

Fatal server error:
failed to initialize core devices

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/dev/null".
Please report problems to xfree86@xfree86.org.

[root@dartagnan log]#

[root@dartagnan tmp]# more \@8979.2xf86config 
<snip>
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "genericwheelps/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
<snip>
Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"
        VendorName  "Videocard vendor"
        BoardName   "RIVA TNT2"
EndSection
<snip>
[root@dartagnan tmp]# 

So at least one of the generated test XF86Config fils has the correct video
card. It just has the incorrect mouse, so it still doesn't work ;-)
Comment 8 Brent Fox 2003-01-30 11:31:21 EST
I think you need to upgrade your redhat-config-mouse.  This is kind of a crufty
bug, but redhat-reconfig-mouse was writing a protocol for "XMOUSETYPE" to
/etc/sysconfig/mouse that isn't a valid X protocol.  When redhat-config-xfree86
has to generate a config file from scratch, it reads /etc/sysconfig/mouse to see
what protocol it should use.  So, it was getting a bogus protocol.

So, once you upgrade your redhat-config-mouse, run it and click "OK".  The new
r-c-mouse should write a correct /etc/sysconfig/mouse file now.  Then try
running redhat-config-xfree86 again.  Things *should* work now.  :)
Comment 9 Chris Ricker 2003-01-30 11:36:43 EST
Ah. I'd upgraded r-c-mouse, but didn't actually run it.

I'll try in a sec and see what happens
Comment 10 Chris Ricker 2003-01-30 11:59:05 EST
Okay, I ran r-c-mouse, and then r-c-xfree86. Everything worked!

thanks
Comment 11 Brent Fox 2003-01-30 12:50:31 EST
Great.  Glad to know it works now.
Comment 12 Brent Fox 2003-05-25 10:30:37 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.