Bug 746322 - [AS7 plugin] EAP6 instances never turn 'online'
[AS7 plugin] EAP6 instances never turn 'online'
Status: CLOSED DUPLICATE of bug 738642
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.1
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
Jan Martiska
:
Depends On:
Blocks: as7-plugin rhq42
  Show dependency treegraph
 
Reported: 2011-10-14 14:45 EDT by Jan Martiska
Modified: 2011-10-20 06:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 06:59:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2011-10-14 14:45:09 EDT
Description of problem:
EAP instances don't go 'online', they stay red.

Version-Release number of selected component (if applicable):
RHQ
Version: 4.1.0-SNAPSHOT
Build Number: dc2eeb6 (October 14 2011)

JBoss EAP
Version: 6.0.0.DR4 (http://porkchop.devel.redhat.com/devel/candidates/JBEAP/JBEAP-6.0.0-DR4/)

Steps to Reproduce:
1. Start an RHQ server with an agent+EAP plugin
2. Run an EAP 6.0.0.DR4 instance, wait for discovery (or use manual autodiscovery)
3. Import EAP into your inventory
  
Actual results:
The EAP instance stays offline.

Expected results:
The EAP instance should be 'online' if it is currently running.

Additional info:
- this applies to both standalone and managed instances and also to Host Controllers.

in EAP server log, the following lines appear (repeatedly):
14:01:39,884 ERROR [org.jboss.as.controller] (HttpManagementService-threads - 1) Operation ("read-children-names") failed - address: ([]) - failure description: "No known child type named host"
14:01:40,853 ERROR [org.jboss.as.controller] (HttpManagementService-threads - 1) Operation ("read-children-names") failed - address: ([]) - failure description: "No known child type named profile"
14:01:40,897 ERROR [org.jboss.as.controller] (HttpManagementService-threads - 1) Operation ("read-children-names") failed - address: ([]) - failure description: "No known child type named server-group"

I was unable to find any other related errors in logs.
Comment 1 Heiko W. Rupp 2011-10-19 11:04:06 EDT
Can you check if this is coming from https://bugzilla.redhat.com/show_bug.cgi?id=738642 ?
Comment 2 Heiko W. Rupp 2011-10-20 06:49:52 EDT
Works for me with 73862 applied ( beta 3 only ?)

Takes a while, but the server comes up with its subsystems.

> avail
Availability Report from 20.10.2011 12:46:38
Resources in report: 364
Includes Only Changed Resources: false
[..]
UP:     en0
UP:     /Users/hrupp/downloads/jboss-eap-6.0.0.Alpha2
Comment 3 Jan Martiska 2011-10-20 06:59:55 EDT
Yes, with the latest version (with patch from #738642) it works now, all instances are online. I guess these problems were indeed closely related, so I will close this as a duplicate and only perform verification of 738642.

*** This bug has been marked as a duplicate of bug 738642 ***

Note You need to log in before you can comment on or make changes to this bug.