Bug 746529 - black screen after installing Fedora-16-TC1-x86_64-Live-Desktop.iso to hard drive ( 2)
black screen after installing Fedora-16-TC1-x86_64-Live-Desktop.iso to hard d...
Status: CLOSED DUPLICATE of bug 746844
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-16 17:56 EDT by Flóki Pálsson
Modified: 2011-10-18 18:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 23:37:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
boot.log from tc1 (5.05 KB, text/plain)
2011-10-16 17:56 EDT, Flóki Pálsson
no flags Details
messages in tc1 (80.08 KB, text/plain)
2011-10-16 17:57 EDT, Flóki Pálsson
no flags Details
/media/_Fedora-16-TC1-x/var/log/Xorg.9.log (34.86 KB, text/plain)
2011-10-17 19:06 EDT, Flóki Pálsson
no flags Details
smoltprofile.txt (2.72 KB, text/plain)
2011-10-17 19:16 EDT, Flóki Pálsson
no flags Details
dmesg.txt (91.58 KB, text/plain)
2011-10-17 20:05 EDT, Flóki Pálsson
no flags Details
from /var/log/messages grep abrt (3.66 KB, text/plain)
2011-10-17 20:18 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2011-10-16 17:56:09 EDT
Created attachment 528416 [details]
boot.log from tc1

Description of problem:
After installing Fedora-16-TC1-x86_64-Live-Desktop.iso  to /dev/sdb14 and rebooting there there is only black screen. 


Version-Release number of selected component (if applicable):
Fedora-16-TC1-x86_64-Live-Desktop.iso

How reproducible:
always 


Steps to Reproduce:
1.  boot Fedora-16-TC1-i686-Live-Desktop.iso
2.  install to custom layout /dev/sdb14   Mount / boot loader on /dev/sdb14
3.  boot to tc1 select menu entry  
	root (hd0,13)
	kernel /boot/grub2/core.img
	boot
  
Actual results:
black screen.  

Expected results:
Gnome-shell

Additional info:
Alt+Ctrl+2 works.  init 3 and init 5 doesn not work.
beta rc4 works.
also Fedora-16-TC1-i686-Live-Desktop.iso has same problem.
Comment 1 Flóki Pálsson 2011-10-16 17:57:16 EDT
Created attachment 528417 [details]
messages in tc1
Comment 2 Adam Williamson 2011-10-17 15:48:39 EDT
is this a VirtualBox system?
Comment 3 Flóki Pálsson 2011-10-17 15:54:09 EDT
>is this a VirtualBox system?
No.
Comment 4 Adam Williamson 2011-10-17 17:00:04 EDT
Can you please attach /var/log/Xorg.0.log and generally provide the info recommended at https://fedoraproject.org/wiki/How_to_debug_Xorg_problems ? thanks.
Comment 5 Flóki Pálsson 2011-10-17 19:06:27 EDT
Created attachment 528670 [details]
/media/_Fedora-16-TC1-x/var/log/Xorg.9.log

Xorg.9.log  as it is now on /dev/sdb14.
There is no /var/log/Xorg.0.log.   

Xorg.9.log is the only Xorg file in /var/log now
# cd /media/_Fedora-16-TC1-x/var/log 
[root@f16brc4 log]# ls | grep Xorg
Xorg.9.log
[root@f16brc4 log]#
Comment 6 Adam Williamson 2011-10-17 19:14:26 EDT
Can you check /var/log/messages for reports of crashes in firstboot, fprintd and gtk-update-icon-cache? I think these probably are all the same bug after all, it's something in glibc not an X issue.
Comment 7 Flóki Pálsson 2011-10-17 19:16:56 EDT
Created attachment 528672 [details]
smoltprofile.txt

 result from F16Ftc1 on /dev/sdb14 smoltSendProfile -p > /tmp/smoltprofile.txt
Comment 8 Flóki Pálsson 2011-10-17 19:32:49 EDT
No xorg.conf file.  I have just installed and tried to boot. 
Nothing in /media/_Fedora-16-TC1-x/var/gdm
Comment 9 Adam Williamson 2011-10-17 19:58:46 EDT
just boot, switch to a console and look at /var/log/messages for crash reports frm abrt, please.
Comment 10 Flóki Pálsson 2011-10-17 20:05:25 EDT
Created attachment 528675 [details]
dmesg.txt

output output of the dmesg command 
(please add drm.debug=14 log_buf_len=16M as boot parameters and reboot)
booting with 
title sdb14 Fedora Linux f, with Linux 3.1.0-0.rc9.git0.3.fc16.x86_64
	root (hd0,13)
	kernel /boot/vmlinuz-3.1.0-0.rc9.git0.0.fc16.x86_64 root=UUID=146328cf-4dda-476f-9403-76ebefb79dc2 ro rd.md=0 rd.lvm=0 rd.dm=0  KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8  drm.debug=14 log_buf_len=16M
	initrd	/boot/initramfs-3.1.0-0.rc9.git0.0.fc16.x86_64.img
Comment 11 Flóki Pálsson 2011-10-17 20:18:05 EDT
Created attachment 528676 [details]
from /var/log/messages grep abrt
Comment 12 Flóki Pálsson 2011-10-17 20:31:24 EDT
 cd ccpp-2011-10-17-23:09:09-1119
[root@f16brc4 ccpp-2011-10-17-23:09:09-1119]# ll
total 612
-rw-r-----. 1 abrt root      9 okt 17 23:09 abrt_version
-rw-r-----. 1 abrt root      4 okt 17 23:09 analyzer
-rw-r-----. 1 abrt root      6 okt 17 23:09 architecture
-rw-r-----. 1 abrt root     20 okt 17 23:09 cmdline
-rw-r-----. 1 abrt root      7 okt 17 23:09 component
-rw-r-----. 1 abrt root 671744 okt 17 23:09 coredump
-rw-r-----. 1 abrt root      1 okt 18 00:09 count
-rw-r-----. 1 abrt root   2533 okt 17 23:09 dso_list
-rw-r-----. 1 abrt root     97 okt 17 23:09 environ
-rw-r-----. 1 abrt root     20 okt 17 23:09 executable
-rw-r-----. 1 abrt root     21 okt 17 23:09 hostname
-rw-r-----. 1 abrt root     30 okt 17 23:09 kernel
-rw-r-----. 1 abrt root  10514 okt 17 23:09 maps
-rw-r-----. 1 abrt root     25 okt 17 23:09 os_release
-rw-r-----. 1 abrt root     20 okt 17 23:09 package
-rw-r-----. 1 abrt root     62 okt 17 23:09 reason
-rw-r-----. 1 abrt root     10 okt 17 23:09 time
-rw-r-----. 1 abrt root      1 okt 17 23:09 uid
-rw-r-----. 1 abrt root      5 okt 17 23:09 username
-rw-r-----. 1 abrt root     40 okt 17 23:09 uuid
-rw-r-----. 1 abrt root    316 okt 17 23:09 var_log_messages



# pwd
/media/_Fedora-16-TC1-x/var/spool/abrt/ccpp-2011-10-17-23:09:09-1119
[root@f16brc4 ccpp-2011-10-17-23:09:09-1119]# cat reason
Process /usr/libexec/fprintd was killed by signal 11 (SIGSEGV)[root@f16brc4 ccpp-2011-10-17-23:09:09-1119]# 

# cat var_log_messages
Oct 17 23:09:09 localhost kernel: [   54.141933] fprintd[1119]: segfault at 8 ip 00007fabe2501aaa sp 00007fffe38a7510 error 4 in ld-2.14.90.so[7fabe24f6000+22000]
Oct 17 23:09:09 localhost abrt[1120]: saved core dump of pid 1119 (/usr/libexec/fprintd) to /var/spool/abrt/ccpp-2011-10-17-23:09:09-1119 (671744 bytes)
Comment 13 Adam Williamson 2011-10-17 23:37:14 EDT
yup, so that's the same bug.

*** This bug has been marked as a duplicate of bug 746844 ***
Comment 14 Andre Robatino 2011-10-18 09:36:57 EDT
Flóki: See https://bugzilla.redhat.com/show_bug.cgi?id=746844#c12 - if you're still convinced you saw the bug on i686, you might want to retest to be sure.
Comment 15 Flóki Pálsson 2011-10-18 18:07:31 EDT
#14  if you're
>still convinced you saw the bug on i686, you might want to retest to be sure.
No.

I have retested and Fedora-16-TC1-i686-Live-Desktop.iso has not same problem.
i686  has not this bug.

Note You need to log in before you can comment on or make changes to this bug.