Bug 746844 - files in gdk-pixbuf2 are corrupted when installing from F16 Final TC1 x86_64 desktop live image, any app that uses gtk segfaults on run, system boots to black screen
files in gdk-pixbuf2 are corrupted when installing from F16 Final TC1 x86_64 ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:ea9b1386b1f5a63406257436231...
:
: 746509 746529 746827 (view as bug list)
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-17 18:57 EDT by Adam Williamson
Modified: 2011-10-20 00:03 EDT (History)
13 users (show)

See Also:
Fixed In Version: anaconda-16.22-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 00:03:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: coredump (8.03 MB, text/plain)
2011-10-17 18:58 EDT, Adam Williamson
no flags Details
File: maps (30.70 KB, text/plain)
2011-10-17 18:58 EDT, Adam Williamson
no flags Details
File: backtrace (107.75 KB, text/plain)
2011-10-17 18:58 EDT, Adam Williamson
no flags Details
Output from running eu-readelf -a /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0 (4.34 KB, text/plain)
2011-10-18 14:07 EDT, Dave Malcolm
no flags Details
The library itself: /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0 (135.51 KB, application/octet-stream)
2011-10-18 14:08 EDT, Dave Malcolm
no flags Details
diff -up /tmp/hexdump-from-koji.txt /tmp/hexdump-corrupt.txt (28.23 KB, text/plain)
2011-10-18 14:40 EDT, Dave Malcolm
no flags Details

  None (edit)
Description Adam Williamson 2011-10-17 18:57:25 EDT
libreport version: 2.0.6
abrt_version:   2.0.4.981
backtrace_rating: 4
cmdline:        python /usr/sbin/firstboot
comment:        
crash_function: _dl_relocate_object
executable:     /usr/bin/python
kernel:         3.1.0-0.rc9.git0.0.fc16.x86_64
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Mon Oct 17 15:40:32 2011
uid:            0
username:       root

backtrace:      Text file, 110341 bytes
maps:           Text file, 31437 bytes

build_ids:
:37d977659123fa04606aa35cba63f9491cc75bbf
:21d5dd609a26d6a87b7e3929b848f45275d5218f
:0c69b22db3e930d2029b8c5fa73a4c40a3604f18
:a4ef06dae501f6b75a79e9d38ebce6c7a09d3832
:61b4ed2e93cbcc694e8c344861a811c07fcd0a4f
:0adaf9dc82e2f0b2d804141f68d33907876224a4
:fba57132982806e8ecf6d3c35c9face867ed9793
:81d43c548b66f976fdacd71d55dcf7d31238791a
:44ece411beb2ef1acdb5eb2161666de41cc2f31d
:98fa95d21e16075ada6df19748c6c133ee9165d0
:89017ab0b75e533e4294f74ee8f7db3daceea536
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:aaf62304b0fc10611d35b4f56005479d4c58868d
:181c11f44ffae21a43ef859652a654a0ffdfb897
:e21d62a3622c3edb824299d83be75df8fdddbe53
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:f9a1b6daef0430cb9fd451e3887cf2d97c5e2845
:0ce9819eb7014de7e72eec40979dd5e4d6566dca
:3a71f33895a6b1739f661cda700421d684373a32
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:f63f0b61d3a9c0237931a9a24d0231ddbba0f481
:fe3662384ae14475beec309064e470d1d26fce01
:cc9a4d25b0cf4d79e75390f3b75d6b95efd6365f
:b1fc49122f65accdfc46f74613682b9b76e616db
:642608cdb0b4270c6fb0eac3b5237f54a9327ebd
:a651d5e608f702d542a11fa4b74d368becdd133a
:cdde3e129757dbf0273261db11ce5e0240c4dbf1
:33001d9c43203911ccf35a2f3db5b6b2d70cb292
:d807273f3f376bc0f59a168e0530289feaad853e
:c8a4e40c84c2f52e78c64d31efc0191c565a9049
:8acc43df965b3c0a70dcfad11c0ade056bdb055b
:ed91e7cbb6d7056226b7d9d50fff88e24dd5eaac
:804daf9cbc7217804dc4366e92c2919ab500638f
:163b323da65b708418226eb5fa8b057c731d1475
:6ecc3efaedf849a17c30a67fe15b4dacca1bd981
:0911ea7c180d733724f89037b8e8a34e64024aec
:34bd5893efcbdb4aef1e64ba0c912c86cc243312
:376567a97a463859c28334ed8bf71262183298c2
:f47fce6e45fa4fdaf051267eaa7ed685f4f9125e
:a097bfc2470874f383b25a209edc1632e708826f
:485fb0ab01330a7389d2d626c1fa4277e4cd9a1e
:8e751985e4819c5c277b638cf1244fc36e350198
:cb04056dcb40f1e6ef5df3e1299aeffcbc727e4a
:f9cfcb8482edf78b60ae321676b8cdf8557c2591
:9720507f13b926fbd00cc771f54572aad617f63c
:aaf7ed41612348bd1141db06cadd428244aa6ea5
:6a8209fa3c28d7db903aa25671d11c35594872c4
:4c842320387ff7f6f91b7842b223c16518be909f
:1c6a95451ee19617be5abea3d121f0226d21ddda
:f0d50e3af2dfee021a327fb85a993a2312a98145
:80023b964a716230dd4bb1b41f04a2b0f09923d7
:a518a8b1b5c3e80dee813df05e951d205d6ac48c
:01525e05e0ca2b3ae5b6e418af1341c6b4998db0
:fe513270287bf1c2086737cd79ee1fb18f593d40
:07470201df55a5254027d05fa4dc509b10f2986a
:3df30a759480b10a1013a4defedb8f618c6703ff
:02163872e7bf6789e65433943eaa281def85b842
:5b527bf8f08f189867c32a36ed4598b69c4c5409
:99969eb9ac23e8e7d69f25f216ea64be5b365152
:51a78844d8347cde69a77178e4796311a98c6250
:91689252818532ec13597b6528d38be93b2706c4
:c0516bb2083183aa526e64fdc452a92d9a0e4f4f
:b6d45c17a4fae97648c832d68c06a1b0233087a1
:b6bde456ce955a9205a6c653a1e1ad36f8e621d9
:041506416aba65a4fdbb44be48ab1e97294a9503
:9afa4a71f0f6a189e8dcf1179b9445a81df0ab28
:ed6642816767576d8792b5f7f7d2b214ade01db5
:989ae6528c12f0c2860156deb76c7eed3dbdf9c4
:2431b55e3253fab5169f214c6cb29cf8d92e8d0d
:bc9641f97ed421f48e67249d836d1af410cf06f7
:790f206de27690431bcd8fd1c818faf3375a83c6
:f1ed2e993eada8d974044e16902b843651e918b4
:36a149d1e2c29890b616402f6bc5e3f69ca2738e
:d440afe7396b3365dcb935f9bf7f2fb28f3839de
:48aea888319e1848137073c9cbde54a4c2a731c9
:ee8a8ced576ef1c94d19f9749154d86dc77ffebb
:cc270d3b30649c06a1888b3c92a0e1a118ba5e75
:4c6a74d7b059fdafa9a456e83cd140e6aa5df494
:f48a81f4d95986c8870e6f07fc75801f65393f0a
:7108012e0ef6adba96f7e5f010bf3bdcc2d3a8bb
:8ec458a1d4aa9f77a71fc6cb5f7a958c0b27f927
:be507c791e34415e8f42f0e6030c889b2895cf9a

dso_list:
:/usr/lib64/libXcursor.so.1.0.2 libXcursor-1.1.11-3.fc15.x86_64 (Fedora Project) 1318565657
:/usr/lib64/python2.7/lib-dynload/itertoolsmodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/lib64/libm-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/lib64/libkrb5.so.3.3 krb5-libs-1.9.1-15.fc16.x86_64 (Fedora Project) 1318565658
:/usr/lib64/libxcb.so.1.1.0 libxcb-1.7-3.fc16.x86_64 (Fedora Project) 1318565657
:/usr/lib64/libpango-1.0.so.0.2904.0 pango-1.29.4-1.fc16.x86_64 (Fedora Project) 1318565692
:/usr/lib64/python2.7/lib-dynload/stropmodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/lib64/libkeyutils.so.1.4 keyutils-libs-1.5.2-1.fc16.x86_64 (Fedora Project) 1318565658
:/usr/lib64/python2.7/site-packages/_dbus_bindings.so dbus-python-0.83.0-8.fc15.x86_64 (Fedora Project) 1318565673
:/usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0 gdk-pixbuf2-2.24.0-1.fc16.x86_64 (Fedora Project) 1318565660
:/lib64/libgmodule-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.x86_64 (Fedora Project) 1318565656
:/lib64/libresolv-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/usr/lib64/libgdk-x11-2.0.so.0.2400.6 gtk2-2.24.6-1.fc16.x86_64 (Fedora Project) 1318565692
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-1.fc16.x86_64 (Fedora Project) 1318565655
:/usr/lib64/python2.7/lib-dynload/math.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/python2.7/site-packages/glib/_glib.so pygobject2-2.28.6-2.fc16.x86_64 (Fedora Project) 1318565675
:/usr/lib64/python2.7/lib-dynload/_collectionsmodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/libreport.so.0.0.1 libreport-2.0.6-1.fc16.x86_64 (Fedora Project) 1318565685
:/usr/lib64/python2.7/site-packages/report/_pyreport.so libreport-python-2.0.6-1.fc16.x86_64 (Fedora Project) 1318565685
:/usr/lib64/python2.7/lib-dynload/_bisectmodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/bin/python python-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/libXinerama.so.1.0.0 libXinerama-1.1.1-2.fc15.x86_64 (Fedora Project) 1318565658
:/usr/lib64/libpangoft2-1.0.so.0.2904.0 pango-1.29.4-1.fc16.x86_64 (Fedora Project) 1318565692
:/usr/lib64/python2.7/site-packages/gobject/_gobject.so pygobject2-2.28.6-2.fc16.x86_64 (Fedora Project) 1318565675
:/usr/lib64/libXfixes.so.3.1.0 libXfixes-5.0-1.fc16.x86_64 (Fedora Project) 1318565657
:/usr/lib64/libpython2.7.so.1.0 python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/lib64/libcrypto.so.1.0.0e openssl-1.0.0e-1.fc16.x86_64 (Fedora Project) 1318565672
:/lib64/libglib-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.x86_64 (Fedora Project) 1318565656
:/usr/lib64/python2.7/lib-dynload/_functoolsmodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/usr/lib64/libXrender.so.1.3.0 libXrender-0.9.6-2.fc15.x86_64 (Fedora Project) 1318565657
:/lib64/libgobject-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.x86_64 (Fedora Project) 1318565656
:/usr/lib64/libX11.so.6.3.0 libX11-1.4.3-1.fc16.x86_64 (Fedora Project) 1318565657
:/usr/lib64/libXdamage.so.1.1.0 libXdamage-1.1.3-2.fc15.x86_64 (Fedora Project) 1318565657
:/usr/lib64/python2.7/lib-dynload/pyexpat.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/python2.7/site-packages/ethtool.so python-ethtool-0.7-2.fc16.x86_64 (Fedora Project) 1318565677
:/usr/lib64/python2.7/lib-dynload/_struct.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/_gtk.so pygtk2-2.24.0-3.fc15.x86_64 (Fedora Project) 1318565693
:/lib64/libselinux.so.1 libselinux-2.1.5-5.1.fc16.x86_64 (Fedora Project) 1318565654
:/usr/lib64/libpyglib-2.0-python.so.0.0.0 pygobject2-2.28.6-2.fc16.x86_64 (Fedora Project) 1318565675
:/lib64/libdbus-1.so.3.5.6 dbus-libs-1:1.4.10-3.fc16.x86_64 (Fedora Project) 1318565654
:/usr/lib64/python2.7/lib-dynload/binascii.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/python2.7/lib-dynload/_ssl.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/python2.7/lib-dynload/selectmodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/lib64/libdl-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/lib64/libkrb5support.so.0.1 krb5-libs-1.9.1-15.fc16.x86_64 (Fedora Project) 1318565658
:/etc/ld.so.cache glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/usr/lib64/python2.7/lib-dynload/_localemodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/lib64/libk5crypto.so.3.1 krb5-libs-1.9.1-15.fc16.x86_64 (Fedora Project) 1318565658
:/usr/lib64/libssl.so.1.0.0e openssl-1.0.0e-1.fc16.x86_64 (Fedora Project) 1318565672
:/lib64/libgcc_s-4.6.1-20111002.so.1 libgcc-4.6.1-10.fc16.x86_64 (Fedora Project) 1318565646
:/lib64/libgssapi_krb5.so.2.2 krb5-libs-1.9.1-15.fc16.x86_64 (Fedora Project) 1318565658
:/usr/lib64/libpng12.so.0.46.0 libpng-2:1.2.46-1.fc16.x86_64 (Fedora Project) 1318565654
:/usr/lib64/libatk-1.0.so.0.20209.1 atk-2.2.0-1.fc16.x86_64 (Fedora Project) 1318565656
:/lib64/libc-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/usr/lib64/libfontconfig.so.1.4.4 fontconfig-2.8.0-4.fc16.x86_64 (Fedora Project) 1318565671
:/lib64/librt-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/usr/lib64/python2.7/lib-dynload/timemodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/python2.7/lib-dynload/fcntlmodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/lib64/libpthread-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/lib64/ld-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/usr/lib64/libXau.so.6.0.0 libXau-1.0.6-2.fc15.x86_64 (Fedora Project) 1318565657
:/usr/lib64/libpixman-1.so.0.22.2 pixman-0.22.2-1.fc16.x86_64 (Fedora Project) 1318565656
:/usr/lib64/python2.7/lib-dynload/_heapq.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/libpangocairo-1.0.so.0.2904.0 pango-1.29.4-1.fc16.x86_64 (Fedora Project) 1318565692
:/usr/lib64/python2.7/lib-dynload/_hashlib.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/libXrandr.so.2.2.0 libXrandr-1.3.1-2.fc15.x86_64 (Fedora Project) 1318565657
:/lib64/libz.so.1.2.5 zlib-1.2.5-4.fc16.x86_64 (Fedora Project) 1318565654
:/usr/lib64/python2.7/lib-dynload/operator.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/libXext.so.6.4.0 libXext-1.2.0-2.fc15.x86_64 (Fedora Project) 1318565657
:/lib64/libnl.so.1.1 libnl-1.1-14.fc16.x86_64 (Fedora Project) 1318565657
:/lib64/libgio-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.x86_64 (Fedora Project) 1318565656
:/usr/lib64/libgtk-x11-2.0.so.0.2400.6 gtk2-2.24.6-1.fc16.x86_64 (Fedora Project) 1318565692
:/lib64/libgthread-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.x86_64 (Fedora Project) 1318565656
:/usr/lib/locale/locale-archive glibc-common-2.14.90-10.x86_64 (Fedora Project) 1318565651
:/usr/lib64/libXcomposite.so.1.0.0 libXcomposite-0.4.3-2.fc15.x86_64 (Fedora Project) 1318565657
:/lib64/libutil-2.14.90.so glibc-2.14.90-10.x86_64 (Fedora Project) 1318565652
:/lib64/libexpat.so.1.5.2 expat-2.0.1-11.fc15.x86_64 (Fedora Project) 1318565656
:/usr/lib64/python2.7/lib-dynload/_socketmodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/lib64/libcom_err.so.2.1 libcom_err-1.41.14-2.fc15.x86_64 (Fedora Project) 1318565655
:/usr/lib64/python2.7/lib-dynload/cStringIO.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/libcairo.so.2.11000.2 cairo-1.10.2-4.fc16.x86_64 (Fedora Project) 1318565672
:/usr/lib64/libfreetype.so.6.7.1 freetype-2.4.6-1.fc16.x86_64 (Fedora Project) 1318565654
:/usr/lib64/python2.7/lib-dynload/_randommodule.so python-libs-2.7.2-4.fc16.x86_64 (Fedora Project) 1318565673
:/usr/lib64/libXi.so.6.1.0 libXi-1.4.3-2.fc16.x86_64 (Fedora Project) 1318565657

environ:
:BOOT_IMAGE=/vmlinuz-3.1.0-0.rc9.git0.0.fc16.x86_64
:PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
:SYSFONT=latarcyrheb-sun16
:LANG=en_US.UTF-8
:PWD=/
:KEYTABLE=us

var_log_messages:
:Oct 17 15:40:32 localhost kernel: [    4.003538] python[981]: segfault at 8 ip 00007f17644d8aaa sp 00007fffa427bb50 error 4 in ld-2.14.90.so[7f17644cd000+22000]
:Oct 17 15:40:32 localhost abrt[982]: saved core dump of pid 981 (/usr/bin/python) to /var/spool/abrt/ccpp-2011-10-17-15:40:32-981 (8421376 bytes)
Comment 1 Adam Williamson 2011-10-17 18:58:07 EDT
Created attachment 528667 [details]
File: coredump
Comment 2 Adam Williamson 2011-10-17 18:58:10 EDT
Created attachment 528668 [details]
File: maps
Comment 3 Adam Williamson 2011-10-17 18:58:11 EDT
Created attachment 528669 [details]
File: backtrace
Comment 4 Adam Williamson 2011-10-17 19:00:27 EDT
This is the 'F16 Final TC1 x86_64 hangs at a black screen after install from live image' bug. It's not in firstboot as lots of stuff crashes with a traceback in ld-2.14.90.so - firstboot, im-settings-daemon, gnome-session, whatever. just after the first boot you have crashes in firstboot, gtk-update-icon-cache, and fprintd. Taking a shot at glibc, but not really sure what's going wrong.

Doesn't seem to affect i686, that works okay.
Comment 5 Adam Williamson 2011-10-17 19:01:16 EDT
*** Bug 746509 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2011-10-17 19:01:52 EDT
Proposing as final blocker: this renders x86_64 live installs useless.
Comment 7 Adam Williamson 2011-10-17 19:17:48 EDT
Current nightly has the same problem, so this isn't some one-off problem in the TC1 compose.
Comment 8 Adam Williamson 2011-10-17 19:29:32 EDT
x86_64 DVD install works fine.
Comment 9 Adam Williamson 2011-10-17 19:50:45 EDT
Just tested TC1 x86_64 LXDE live and it worked.
Comment 10 Adam Williamson 2011-10-17 23:37:14 EDT
*** Bug 746529 has been marked as a duplicate of this bug. ***
Comment 11 Andre Robatino 2011-10-18 00:59:38 EDT
Just noting that bug 746529 affected both i686 and x86_64, so if it's the same bug, then this affects both arches.
Comment 12 Adam Williamson 2011-10-18 01:27:44 EDT
I'm not entirely convinced about that. It's clearly the same bug - check the abrt reports in /var/log/messages - but it definitely doesn't hit i686 for me. May have been human error somewhere in that test.
Comment 13 Richard Hughes 2011-10-18 10:38:26 EDT
Just a "me too" on a clean Lenovo T510. Blocker with flashing lights IMO.
Comment 14 Dave Malcolm 2011-10-18 11:02:48 EDT
Looking at attachment 528669 [details], I see /usr/bin/firstboot (implemented in Python) is attempting to "import gtk".   In frames 12 and below it is importing gtk._gtk i.e. dynamically loading this shared library:
  /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/_gtk.so
From frame 7 and below, we're inside __dlopen(), and something is going badly wrong.  Am attempting to reproduce.
Comment 15 Adam Williamson 2011-10-18 13:08:01 EDT
according to rpm -Va, some files in gdk-pixbuf2 have an md5sum mismatch, and indeed, 'yum reinstall gdk-pixbuf2' seems to fix the bug.
Comment 16 Adam Williamson 2011-10-18 13:29:36 EDT
2011-10-18 nightly - http://koji.fedoraproject.org/koji/taskinfo?taskID=3440929 - is not affected by the bug. (remember, 2011-10-16 nightly *was* affected by the bug).
Comment 17 Adam Williamson 2011-10-18 13:56:50 EDT
Okay, it seems like the files get corrupted *before* you ever boot the installed system - so during the installation process, somehow.

The correct sha256sum for /usr/lib64/libgdk_pixbuf_xlib-2.0.so.0.2400.0 is 65975d97a3f17b63137454086750665fb6d2f5195059466540ef4df819a4d0ba . This is what you get when booted live, and post-install on any working image.

The incorrect sha256sum that you get on a 'broken' install is 8060fd8e9a5f34d3772428d9af0b1bb33e312d2f4b4e517569bebbdef45958e6 . This seems to be consistent, at least, it's been the same across two tries for me. So it's not _random_ corruption of the file.

If I do an installation, then reboot back to the live image - i.e. the installed system has never been booted - mount the installed root partition to /mnt/temp and do sha256sum /mnt/temp/usr/lib64/libgdk_pixbuf_xlib-2.0.so.0.2400.0 , I get the 'bad' sha256sum. So the file is 'bad' before the installed system has ever been booted.
Comment 18 Adam Williamson 2011-10-18 13:58:30 EDT
prelink --undo refuses to run on the file, claiming it's not an ELF file, so it seems extremely unlikely prelink is involved in this. It's something happening during install.
Comment 19 Dave Malcolm 2011-10-18 14:04:42 EDT
I see the same behavior: I downloaded:
http://dl.fedoraproject.org/pub/alt/stage/16.TC1/Live/x86_64/Fedora-16-TC1-x86_64-Live-Desktop.iso
and ran it.  I verified that "import gtk" worked successfully.

I then tried to install it to the disk, and ran into these issues.

On this box, the broken library has the same incorrect sha256sum as reported in comment #17:
[root@F16-TC1-From-LiveDVD ~]# sha256sum /usr/lib64/libgdk_pixbuf_xlib-2.0.so.0.2400.0
8060fd8e9a5f34d3772428d9af0b1bb33e312d2f4b4e517569bebbdef45958e6  /usr/lib64/libgdk_pixbuf_xlib-2.0.so.0.2400.0
Comment 20 Dave Malcolm 2011-10-18 14:07:11 EDT
Created attachment 528858 [details]
Output from running eu-readelf -a /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0

eu-readelf -a on the library shows corruption
Comment 21 Dave Malcolm 2011-10-18 14:08:33 EDT
Created attachment 528859 [details]
The library itself: /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0
Comment 22 Adam Williamson 2011-10-18 14:09:49 EDT
both gdk_pixbuf libraries are corrupted, just to be clear on that. seems like lots of files in the package are screwed.

as you'd expect, on the unaffected 2011-10-18 nightly image, the files have correct sha256sums post-install. trying to figure what's the difference between affected and unaffected images.
Comment 23 Dave Malcolm 2011-10-18 14:14:47 EDT
hexdump -C /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0 |less

shows a long run of zeroes at the end of the file (about 7KB):
-------------------------------------------------------------------------------
00020000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
00021e00  00 00 00 00 00 00 00 00                           |........|
00021e08
-------------------------------------------------------------------------------

Also, # # rpm -Va gdk-pixbuf2 shows various other files with issues:
5........    /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0
5........    /usr/lib64/libgdk_pixbuf_xlib-2.0.so.0.2400.0
5........    /usr/share/locale/af/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/ar/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/as/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/ast/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/az/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/be/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/be@latin/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/bg/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/bn/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/bn_IN/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/bs/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/ca/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/ca@valencia/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/crh/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/cs/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/cy/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/da/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/de/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/dz/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/el/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/en@shaw/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/en_CA/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/io/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/mi/LC_MESSAGES/gdk-pixbuf.mo
5........    /usr/share/locale/ps/LC_MESSAGES/gdk-pixbuf.mo
5........  d /usr/share/man/man1/gdk-pixbuf-query-loaders.1.gz

All of the .mo files listed above appear to be all zero-filled, with no non-zero bytes.  For example:
# hexdump -C /usr/share/locale/de/LC_MESSAGES/gdk-pixbuf.mo
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
00005770  00 00 00 00 00 00 00 00  00 00 00 00 00           |.............|
0000577d

Similarly for the manpage:
# hexdump -C /usr/share/man/man1/gdk-pixbuf-query-loaders.1.gz
00000000  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000003f0  00 00 00                                          |...|
000003f3
Comment 24 Dave Malcolm 2011-10-18 14:19:11 EDT
# rpm -qf /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0
gdk-pixbuf2-2.24.0-1.fc16.x86_64
Comment 25 Dave Malcolm 2011-10-18 14:38:38 EDT
This file appears in Koji as:
http://koji.fedoraproject.org/koji/fileinfo?rpmID=2679902&filename=/usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0
which says that it has a size of 138760 bytes

Comparing with the corrupt library:
# ll /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0
-rwxr-xr-x. 1 root root 138760 Aug 30 18:24 /usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0
shows that it does have an on-disk size of 138760

Manually downloading the rpm from Koji:
$ wget http://kojipkgs.fedoraproject.org/packages/gdk-pixbuf2/2.24.0/1.fc16/x86_64/gdk-pixbuf2-2.24.0-1.fc16.x86_64.rpm

$ rpmdev-extract gdk-pixbuf2-2.24.0-1.fc16.x86_64.rpm

$ hexdump -C gdk-pixbuf2-2.24.0-1.fc16.x86_64/usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0 > /tmp/hexdump-from-koji.txt

Comparing with the corrupt library:
$ hexdump -C /tmp/libgdk_pixbuf-2.0.so.0.2400.0 > /tmp/hexdump-corrupt.txt

$ diff -up /tmp/hexdump-from-koji.txt /tmp/hexdump-corrupt.txt > /tmp/diff-from-koji-to-corrupt.txt

Am attaching the textual diff
Comment 26 Dave Malcolm 2011-10-18 14:40:38 EDT
Created attachment 528869 [details]
diff -up /tmp/hexdump-from-koji.txt /tmp/hexdump-corrupt.txt

Textual difference between hexdump of the library taken from Koji, vs the hexdump of the library on disk after install from live DVD.

This shows that the first 128KB of the file is correct, but every subsequent byte was zeroed.
Comment 27 Adam Williamson 2011-10-18 14:42:59 EDT
gave the bug a better summary.
Comment 28 Dave Malcolm 2011-10-18 14:56:34 EDT
# rpm -qf /usr/bin/liveinst
anaconda-16.21-1.fc16.x86_64

Reassigning to "anaconda" in lieu of knowing exactly what's introducing the corruption.
Comment 29 Adam Williamson 2011-10-18 16:36:14 EDT
so we think liveinst is truncating files for some reason, and we think it happens even in the 'working' cases - it just happens to truncate files that aren't so obviously important.

in the 'working' 2011-10-18 nightly image I see md5sum errors from rpm -Va for /usr/share/misc/magic and /usr/share/misc/magic.mgc , and they do appear to be cut off like the gdk-pixbuf2 files in the 'broken' case.

bcl thinks he's nailed the bug:

<bcl> adamw: truncated copy
<bcl> A quick kludge is to add 1 to self.anaconda.storage.liveImage.format.currentSize
<bcl> yeah, it depends on the size of the image and how close to the 1MB roundoff it falls.
 the core problem may be in wherever currentSize comes from, which should be fixed too, but I think it safer to just read the livefs until the end instead of depending on an exact < match.
Comment 30 Brian Lane 2011-10-18 17:03:53 EDT
Here's an update image for this, it also includes a couple other patches since the last build of anaconda.
Comment 31 Brian Lane 2011-10-18 17:04:26 EDT
ok, so it would be helpful to paste the url, wouldn't it?

http://bcl.fedorapeople.org/updates/746844.img
Comment 32 Adam Williamson 2011-10-18 18:27:53 EDT
update looks good at a first test with the tc1 image: the installed system boots, nothing crashes, and rpm -Va shows no 'valid' md5sum errors (only files that are legitimately changed post-install). Will check with a few other images too.
Comment 33 Adam Williamson 2011-10-18 18:42:33 EDT
Looks good testing the 11-18 nightly as well: those /usr/share/misc/magic files are not truncated. so the fix is looking nice.
Comment 34 Adam Williamson 2011-10-18 19:12:34 EDT
*** Bug 746827 has been marked as a duplicate of this bug. ***
Comment 35 Fedora Update System 2011-10-19 14:43:44 EDT
anaconda-16.22-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.22-1.fc16
Comment 36 Adam Williamson 2011-10-19 17:51:20 EDT
16.22 looks good: installed it after booting TC1 live desktop x86_64, did an installation, installed system boots fine, nothing is corrupted.
Comment 37 Fedora Update System 2011-10-19 22:25:21 EDT
Package anaconda-16.22-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.22-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14624
then log in and leave karma (feedback).
Comment 38 Fedora Update System 2011-10-20 00:03:52 EDT
anaconda-16.22-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.