Bug 746554 - [abrt] blueman-1.21-10.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
[abrt] blueman-1.21-10.fc15: connection.py:630:call_blocking:DBusException: o...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
abrt_hash:b4e88a3d55f6d330be23fdce98e...
:
: 801321 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 00:34 EDT by kalgecin
Modified: 2012-05-06 00:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: blueman-1.23-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-05 21:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kalgecin 2011-10-17 00:34:32 EDT
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/bin/blueman-manager
comment:        trying to pair samsung galaxy s2
component:      blueman
executable:     /usr/bin/blueman-manager
kernel:         2.6.40.6-0.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        blueman-1.21-10.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
time:           Mon Oct 17 07:33:39 2011
uid:            500
username:       kalgecin

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 702, in _message_cb
:    retval = candidate_method(self, *args, **keywords)
:  File "<string>", line 2, in CancelDeviceCreation
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/DBusService.py", line 145, in CancelDeviceCreation
:    if self.applet.Manager:
:AttributeError: 'DBusService' object has no attribute 'applet'
:
:
:Traceback (most recent call last):
:  File "/usr/bin/blueman-manager", line 258, in <lambda>
:    prog.connect("cancelled", lambda x: applet.CancelDeviceCreation(adapter.GetObjectPath(), device.Address))
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 702, in _message_cb
:    retval = candidate_method(self, *args, **keywords)
:  File "<string>", line 2, in CancelDeviceCreation
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/DBusService.py", line 145, in CancelDeviceCreation
:    if self.applet.Manager:
:AttributeError: 'DBusService' object has no attribute 'applet'
:
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SessionBus (session) at 0x1302ef0>
:args: (dbus.ObjectPath('/org/bluez/668/hci0'), dbus.String(u'0C:DF:A4:13:CB:F2'))
:utf8_strings: False
:bus_name: 'org.blueman.Applet'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/'
:timeout: -1.0
:signature: u'ss'
:dbus_interface: 'org.blueman.Applet'
:message: <dbus.lowlevel.MethodCallMessage object at 0xe1bcc0>
:method: 'CancelDeviceCreation'
Comment 1 Andre Vehreschild 2012-03-27 03:27:10 EDT
Tried to pair a device.

Package: blueman-1.21-10.fc16
OS Release: Fedora release 16 (Verne)
Comment 2 Christoph Wickert 2012-04-26 18:54:20 EDT
*** Bug 801321 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-04-27 06:00:47 EDT
blueman-1.23-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/blueman-1.23-1.fc17
Comment 4 Fedora Update System 2012-04-27 06:01:14 EDT
blueman-1.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/blueman-1.23-1.fc16
Comment 5 Fedora Update System 2012-04-27 11:43:25 EDT
Package blueman-1.23-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing blueman-1.23-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6784/blueman-1.23-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-05-05 21:29:29 EDT
blueman-1.23-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-05-06 00:56:56 EDT
blueman-1.23-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.