Bug 74669 - clicking links inside evolution does nothing
clicking links inside evolution does nothing
Status: CLOSED DUPLICATE of bug 75102
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-30 09:48 EDT by Preston Brown
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preston Brown 2002-09-30 09:48:30 EDT
Description of Problem: 
Clicking links inside evolution does nothing.  If it is trying to start up 
galeon to view them (which I don't have installed) that's a problem.  It 
should be trying to use htmlview. 
 
1.0.8-10.
Comment 1 Jeremy Katz 2002-10-01 18:52:58 EDT
It just uses the gnome-libs url opening bits and works for me both on my laptop
with a fresh install and my weird upgraded workstation setup.
Comment 2 Preston Brown 2002-10-02 10:29:55 EDT
where do you want me to look next?  I'm running evolution under KDE on this machine.
Comment 3 Havoc Pennington 2002-10-02 11:08:04 EDT
I guess the question is what it's trying to launch. Probably gnome-moz-remote?
strace -f on evolution might show up the fork/exec.

Maybe also see if gnome-moz-remote works for you on the command line...
Comment 4 Preston Brown 2002-10-02 11:11:00 EDT
It is trying to run galeon.  This is an upgrade 7.3 box.
Comment 5 Preston Brown 2002-10-02 11:13:37 EDT
If I run "gnome-default-applications-properties", I see that "Custom Web
Browser" is selected, with Command "mozilla "%s"".  That is good.

"gnome-file-types-properties" shows that "HTML page" file type (text/html) has a
Default action of "htmlview".

As an aside, shouldn't the above two things be linked some how?

Comment 6 Preston Brown 2002-10-02 11:15:32 EDT
gnome-moz-remote doesn't seem to be working either. gnome-moz-remote --newwin
does nothing even when mozilla is already running.



Comment 7 Havoc Pennington 2002-10-02 12:22:57 EDT
My guess is that an old ~/.gnome/Gnome contains galeon and nuking that file 
would revert to gnome-moz-remote.
Comment 8 Preston Brown 2002-10-03 11:36:29 EDT
Bingo.  We gotta work on the upgrade path here a bit.
Comment 9 Havoc Pennington 2003-01-07 16:45:58 EST

*** This bug has been marked as a duplicate of 75102 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:49:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.