Bug 75102 - hardcode gnome-libs to htmlview
hardcode gnome-libs to htmlview
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
: Triaged
: 71327 74669 76201 80128 (view as bug list)
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-10-04 11:41 EDT by Sven Neuhaus
Modified: 2007-04-18 12:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 09:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Neuhaus 2002-10-04 11:41:57 EDT
evolution opens mozilla when I click hyperlinks in it instead of my favourite
browser.

When I change my preferred browser with the 
"gnome-default-applications-properties" program, the file ~/.gnome/Gnome is 
not updated. The section [URL Handlers] still contains the entry
default-show=gnome-moz-remote --newwin "%s"
which is what evolution uses for hyperlinks clicked in emails and in the summary.

I found no other tool that edited this file.
Why isn't the default browser in the file "htmlview" instead of gnome-moz-remote?

It seems that "gnome-default-applications-properties" only puts the browser
choice in the file
~/.gconf/desktop/gnome/url-handlers/unknown/%gconf.xml

Is evolution supposed to use this file instead of ~/.gnome/Gnome ?
Comment 1 Havoc Pennington 2002-10-04 12:34:02 EDT
Evolution isn't quite caught up to the newer GNOME control panel.
Comment 2 Havoc Pennington 2002-12-19 18:03:01 EST
Didn't someone make htmlview read a config setting?

If so we could just hardwire the GNOME 1.4 stuff to htmlview and then 
it would track GNOME 2.
Comment 3 Jeremy Katz 2002-12-19 19:03:00 EST
Yes, twaugh made htmlview look at the gconf setting
Comment 4 Havoc Pennington 2002-12-19 19:17:04 EST
OK, moving to gnome-libs; we'll ignore the .gnome config file, and hardwire
htmlview for GNOME 1 apps.
Comment 5 Havoc Pennington 2002-12-21 15:37:35 EST
*** Bug 80128 has been marked as a duplicate of this bug. ***
Comment 6 Havoc Pennington 2002-12-21 15:39:52 EST
Bug 80128 points out that we need to handle mailto: as well, is it total crack
to make htmlview do that? Or does it already?

The Preferred Applications control panel doesn't seem to have a choice 
for email, though. We could add one pretty quickly I suppose.
Comment 7 Tim Waugh 2002-12-23 08:11:06 EST
It doesn't, currently.  It could easily be added if you like.  As to whether or
not it's total crack, I'm not sure. ;-)

The htmlview magic is just this at the moment:

  if [ "x`/sbin/pidof gnome-session`" != "x" ]; then
-         X11BROWSERS="$X11BROWSERS_GENERIC $X11BROWSERS_GNOME $X11BROWSERS_KDE"
+         GCONF=$(gconftool-2 -g /desktop/gnome/url-handlers/unknown/command \
+                 2>/dev/null | sed -e 's/%s//')
+         X11BROWSERS="$GCONF $X11BROWSERS_GENERIC $X11BROWSERS_GNOME
$X11BROWSERS_KDE"
          TERMS="$CONSOLE $TERMS_GENERIC $TERMS_GNOME $TERMS_KDE"
  else
          X11BROWSERS="$X11BROWSERS_GENERIC $X11BROWSERS_KDE $X11BROWSERS_GNOME"
          TERMS="$CONSOLE $TERMS_GENERIC $TERMS_KDE $TERMS_GNOME"
  fi

It isn't particularly robust or anything.  Hope %s is at the end, etc.
Comment 8 Havoc Pennington 2003-01-07 16:05:40 EST
*** Bug 71327 has been marked as a duplicate of this bug. ***
Comment 9 Havoc Pennington 2003-01-07 16:46:01 EST
*** Bug 74669 has been marked as a duplicate of this bug. ***
Comment 10 Havoc Pennington 2003-01-07 16:48:09 EST
*** Bug 76201 has been marked as a duplicate of this bug. ***
Comment 11 Havoc Pennington 2003-01-31 15:53:13 EST
Clicking links in GNOME 1.4 apps such as evolution should now always run 
htmlview.
Comment 12 Jay Turner 2003-02-07 09:07:31 EST
Fix confirmed with gnome-libs-1.4.1.2.90-31.

Note You need to log in before you can comment on or make changes to this bug.