Bug 746920 - autihinting has no effect on DejavuSansMono with freetype 2.4.6 (patch found)
autihinting has no effect on DejavuSansMono with freetype 2.4.6 (patch found)
Status: CLOSED DUPLICATE of bug 752538
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-18 05:44 EDT by Alphonse Steiner
Modified: 2011-11-24 10:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-24 10:15:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alphonse Steiner 2011-10-18 05:44:32 EDT
Hello, here is a summary of the problem:
- with freetype 2.4.2, DejavuSansMono is rendered normally;
- with freetype 2.4.6, DejavuSansMono and the other fonts are rendered badly (badly means here "not in the same way as with 2.4.2"): after some googling, I have found it is due to the fact that the bytecode interpreter is now enabled, and the workaround is to use autohinting:
"ln -s /etc/fonts/conf.avail/10-autohint.conf /etc/fonts/conf.d/"

This works great, but not for DejavuSansMono.
After trying freetype 2.4.5 without having any problem, I found it: it is the patch 
http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=b0962ac34e66052ccfee7996e5468f30d4bd5a72
that is faulty.
Without it, DejavuSansMono is rendered normally using the last 2.4.6 sources and autohinting.

Regards,
Alphonse
Comment 1 Marek Kašík 2011-11-24 10:15:16 EST
Hi,

this is not a bug. The commit fixes a bug which was present in freetype for a long time. This was discussed here:
http://savannah.nongnu.org/bugs/?34507,
http://savannah.nongnu.org/bugs/?33939 and
http://savannah.nongnu.org/bugs/?34156.

I'm closing this as a duplicate of #752538.

Regards

Marek

*** This bug has been marked as a duplicate of bug 752538 ***

Note You need to log in before you can comment on or make changes to this bug.