Bug 74703 - Registration fails with "no entitlements" leaving things in bad state
Registration fails with "no entitlements" leaving things in bad state
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Jamison
Red Hat Satellite QA List
:
Depends On: 71181 76180
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-30 20:41 EDT by Aleksey Nogin
Modified: 2007-10-23 22:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 23:42:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-09-30 20:41:15 EDT
Description of Problem:

During the registration process, up2date consistently fails telling me that the
system is enentitled (of course it is, how could I entitle it *before* it's
registered???). If I log into the RHN after such failure, I see that the system
is there, but wich empty package and hardware profiles. Running "up2date -p;
up2date --hardware" gets me where I want to be, but this all is very
unconvenient (and would probably be very confusing to novice users).

Version-Release number of selected component (if applicable):

Psyche 8.0, up2date-3.0.7-1

How Reproducible:

Always

Steps to Reproduce:
1. up2date --register
2. Use existing account (I have I paid and one free subscription on my account).
3. Keep the checkbox for sharing hardware profile checked
4. Keep the checkbox for sharing package profile checked
5. Submit

Actual Results:

Fails in the middle complaining about a non-entitled system. RHN shows system
profile is created, but has empty hardware and package profiles.

Expected Results:

Best: registration succeeds, hardware and software profiles are updated.
Alternative: registration process pauses and instructs me to go to a web site
and to entitle the new system before pressing "Next".
Comment 1 Josef Komenda 2002-10-14 14:40:58 EDT
Known issue - over to Misa, who will be addressing it this week.
Comment 2 Mihai Ibanescu 2002-10-21 18:01:57 EDT
Should be fixed now (it's been fixed for some time, but I kept misreading this
bug report).
Comment 3 Josef Komenda 2002-10-22 10:19:53 EDT
Not seeing a fix on QA or live. To clarify the initial report, the behavior is
as follows. 

 - Run up2date --register on an 8.0 system
 - Register to an account that is using all of its basic entitlements
 - Registration succeeds, but the system is not entitled
 - since up2date tries to run immediately after registration, it fails 
   with the following error message:

Error Message:
    Service not enabled for server profile: "dhcp59-208"
Error Class Code: 31
Error Class Info: 
     This server does not have a valid entitlement for Red Hat Network.
     Please login at https://rhn.redhat.com/, and from the "Your RHN"
     section, select "Entitlements" to enable RHN service for this server.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

The lack of a package profile under 8.0 is a seperate bug, and should be
addressed by bug #76180. There's an RFE for improving the way up2date handles
unentitled systems - bug #75925. I'm adding both of those as dependencies to
this one, so that we can get this fixed without opening more bug reports.
Comment 4 Josef Komenda 2002-10-22 10:21:51 EDT
Kicking the priority level up as well.
Comment 5 Mihai Ibanescu 2002-10-22 12:29:58 EDT
Do you have the hardware profile information correctly filled in? Yes, the
package profile will not be there :-(
Comment 6 Josef Komenda 2002-10-22 13:48:51 EDT
It looks like the hardware profile was reported correctly, so 2 out of 3.
Comment 7 Mihai Ibanescu 2002-12-13 09:43:59 EST
jkomenda: what exactly is it left to be fixed in this bug? I kind of don't
understand why it's not closed yet.
Comment 8 Josef Komenda 2002-12-13 10:42:50 EST
This bug is waiting on Titan to go live (resolving bug #71181), and to a lesser
degree an up2date errata (resolving bug #76180). I'll assign it to myself,
awaiting those fixes.

Note You need to log in before you can comment on or make changes to this bug.