Bug 74708 - xmms segfaults on default install (gdb gives: no debugging symbols found)
xmms segfaults on default install (gdb gives: no debugging symbols found)
Status: CLOSED DUPLICATE of bug 74717
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2002-09-30 21:45 EDT by Need Real Name
Modified: 2014-03-16 22:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-11 23:15:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output of (strace -ff -o xmms_strace xmms) (12.46 KB, text/plain)
2002-10-01 00:41 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-09-30 21:45:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
The default install of xmms segfaults when run. gdb provides no debugging
information. platform IBM thinkpad 390E ES1969 Solo AudioDrive. All other system
sounds work. Sound module loaded: esssolo1

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.type 'xmms &' from xterm window

Actual Results:  xmms

Segmentation fault

You've probably found a bug in XMMS, please visit
http://bugs.xmms.org and fill out a bug report.

Expected Results:  xmms should have loaded producing xmms window in x session

Additional info:
Comment 1 Bill Nottingham 2002-09-30 23:01:20 EDT
Out of curiousity, what happens if you move your .xmms dir out of the way?

Do you have any not-shipped-with-xmms plugins installed?
Comment 2 Need Real Name 2002-10-01 00:39:41 EDT
Same problem here. Clean install, user had no .xmms directory. No plugins/any
other external programs installed.
(Tyan S2460, Athlon MP, 512 MB RAM - Using the stock kernel-smp 1.4.18-14 for
the athlon arch)
Comment 3 Need Real Name 2002-10-01 00:41:21 EDT
Created attachment 77764 [details]
Output of (strace -ff -o xmms_strace xmms)
Comment 4 Ali-Reza Anghaie 2002-10-01 08:39:57 EDT
Just for the record, XMMS worked for me under 8.0. 
Perhaps one of the users with the problem would be willing to rebuild XMMS 
from SRPM w/ debugging? I can't seem to get anybody in #redhat on freenode to 
do that and I don't have the problem to replicate. 
Just a thought. -Ali
Comment 5 Need Real Name 2002-10-04 04:10:04 EDT

I've got the same segmentation fault as you do.

My work around:

- Install arts-1.0.3-1 on RH8.0 CD 2
- Install xmms-mpe123 rpm at www.xmms.org
- Disable the MPEG Layer Placeholder Plugin on XMMS

This should do the work.

Vitor Domingos
Comment 6 Bill Nottingham 2002-10-04 12:59:40 EDT
Only the step 1 you mentioned is actually necessary.
Comment 7 Paul Berger 2002-10-11 23:14:54 EDT
I'm having the same issue here with a fresh install of RH 8.0 but installing
arts-1.0.3-1 appears to fix the segfault issue.  Bad dependency in xmms rpm?

Athlon 1600+, Abit KT7A-RAID, SB Live EMU10k1
Comment 8 Bill Nottingham 2002-10-11 23:28:28 EDT

*** This bug has been marked as a duplicate of 74717 ***

Note You need to log in before you can comment on or make changes to this bug.