Bug 74717 - xmms segfaults at startup, if arts is not installed (not a dep)
xmms segfaults at startup, if arts is not installed (not a dep)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 72440 74708 75303 75337 75619 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 00:30 EDT by Mike Shaver
Modified: 2014-03-16 22:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 21:19:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Shaver 2002-10-01 00:30:01 EDT
xmms tries to dlopen libartsc.so.2 and crashes if it can't find it.  xmms has no
dependency on arts-1.0.3 (so, using redhat-config-packages, you have to install
all of KDE base!).
Comment 1 Bill Nottingham 2002-10-01 00:32:06 EDT
Hm, I can't reproduce this.
[notting@nostromo: ~]$ rpm -q arts
package arts is not installed
[notting@nostromo: ~]$ xmms
libartsc.so.0: cannot open shared object file: No such file or directory

<runs ok>
Comment 2 Mike Shaver 2002-10-01 00:35:05 EDT
You'll forgive me if I don't undo the arts install and thereby break my xmms
install, I hope.  Here's some ltrace, though:

xmms_cfg_open_file(0x08143540, 0x0811abc8, 0, 0x4202bdd4, 0x42126064) = 0
g_strdup(0x0811bd80, 0x0811abc8, 0, 0x4202bdd4, 0x42126064) = 0x08143560
g_strdup(0x0811bd40, 0x0811abc8, 0, 0x4202bdd4, 0x42126064) = 0x08143588
g_strdup(0x0811b4c9, 0x0811abc8, 0, 0x4202bdd4, 0x42126064) = 0x081435b0
g_strdup(0x0811bd00, 0x0811abc8, 0, 0x4202bdd4, 0x42126064) = 0x08143060
dlopen("libartsc.so.0", 2)                        = NULL
--- SIGSEGV (Segmentation fault) ---

Mike
Comment 3 Bill Nottingham 2002-10-01 00:49:02 EDT
*grumble* Got it.
Comment 4 Ali-Reza Anghaie 2002-10-01 13:51:59 EDT
Shouldn't bug 74708 be referenced or merged with this one. Perhaps they're the  
same? Cheers, -Ali 
  
Comment 5 Shawn Walker 2002-10-01 14:10:14 EDT
I have this issue as well. I don't have arts installed, nor do I wants arts
installed. I guess I'll have to rebuild xmms from the source rpm now.
Comment 6 Bill Nottingham 2002-10-01 14:13:08 EDT
xmms-1.2.7-dlopen.patch, change
  LoadARTSLibrary() < 0
to 
  LoadARTSLibrary() >= 0

alternatively, install arts, start xmms, exit, and then you can remove arts...
Comment 7 Shawn Walker 2002-10-01 14:19:56 EDT
That's what I was going to try doing. I guess the default is to use arts? Seems
silly since Gnome is the default install :) Thanks for the suggestion. Nasty
little buglet for shipping release.
Comment 8 Bill Nottingham 2002-10-01 14:53:20 EDT
No, the default is not arts. the code was just stupidly broken.
Comment 9 Mike A. Harris 2002-10-01 22:10:29 EDT
This happens in 7.1 as well for me FWIW
Comment 10 Bill Nottingham 2002-10-07 15:12:44 EDT
*** Bug 75337 has been marked as a duplicate of this bug. ***
Comment 11 Bill Nottingham 2002-10-07 15:13:57 EDT
*** Bug 75303 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2002-10-10 12:57:10 EDT
*** Bug 75619 has been marked as a duplicate of this bug. ***
Comment 13 Bill Nottingham 2002-10-11 23:28:21 EDT
*** Bug 74708 has been marked as a duplicate of this bug. ***
Comment 14 Need Real Name 2002-10-16 23:02:13 EDT
Hi there.

No, you don't need to install the entire KDE packages. Instead, you can go to
rpmfind.net and download an older version of arts. Just type "arts" into the
search field and download the RPM for RedHat 7.2.

Cheers.

Dan
Comment 15 Ovidiu D. Damian 2002-10-27 02:03:09 EST
Even better, install arts-1.0.3-1.i386.rpm from Red Hat 8.0 CD2. Unless you want
to install the entire KDE base, this needs to be done manually via either the
command prompt or through Nautilus.
Comment 16 Bill Nottingham 2002-11-25 17:04:09 EST
*** Bug 72440 has been marked as a duplicate of this bug. ***
Comment 17 Tommy McNeely 2003-01-18 23:20:08 EST
(phoebe) my XMMS wouldnt play...  it defaulted to "arts" .. I changed it to OSS
and it worked fine.. but I always do an everything install :) i guess that makes
me lazy :)

Tommy
Comment 18 Bill Nottingham 2004-01-28 21:19:44 EST
This has since been fixed.

Note You need to log in before you can comment on or make changes to this bug.