Bug 74718 - Installer crash during Custom and Workstation
Installer crash during Custom and Workstation
Status: CLOSED DUPLICATE of bug 75377
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 01:06 EDT by Josiah Royse
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 15:29:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump from original post (66.42 KB, text/plain)
2002-10-01 01:08 EDT, Josiah Royse
no flags Details
Anaconda dump (61.46 KB, text/plain)
2002-10-06 03:03 EDT, Adam Pribyl
no flags Details
corrupted perl-Filter package grabed from disk after crashed installation (68.14 KB, application/octet-stream)
2002-10-06 03:06 EDT, Adam Pribyl
no flags Details

  None (edit)
Description Josiah Royse 2002-10-01 01:06:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Error: The file /mnt/sysimage/var/tmp/zlib-1.1.4-4.i386.rpm cannot be opened.  
This is due to a missing file, a bad package, etc... Press <return>

Exception Occured:

<Lists anaconda dump>

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use prepartitioned disk, format / and swap
2. select either "workstation" or "custom" (later select all)
3. installer starts installing, hangs on zlib, crashes
	

Actual Results:  crashes on zlib.

Expected Results:  install zlib, continue.

Additional info:

This is only disk 1 of 3, and the media-check PASSED.
Comment 1 Josiah Royse 2002-10-01 01:08:12 EDT
Created attachment 77784 [details]
anaconda dump from original post
Comment 2 Josiah Royse 2002-10-01 11:45:11 EDT
It looks like the mountpoint [/tmp/cdrom /mnt/source] gets droppped right 
before the zlib-1*.rpm transaction.  Going into the shell, the 
mountpoint /mnt/source has vanished at the error "The 
file /mnt/sysimage/var/tmp/zlib-1.1.4-4.i386.rpm cannot be opened."

In the shell:
1. mkdir /mnt/source
2. mount /dev/hdc /mnt/source

Results:
1. Hit return at the Error box
2. Anaconda kicks out cdrom tray, asks for disc 1
3. push cdrom tray back in. Continues to install normally.

This computer has two CDROM drives.  The file /tmp/cdrom IS linked to /dev/hdc, 
which is correct.  But there is a /tmp/hdd for the second CDROM (not used).  

After Anaconda finishes with disc 1, disc 2 is mounted from /tmp/hdc.  This is 
different than the original mount for disc 1 that vanished originally 
(/tmp/cdrom).
Comment 3 Benjamin Kosnik 2002-10-01 12:36:54 EDT
I can reproduce this as well, only after selecting "custom" the installer just
freezes: I can move the mouse, and click on other buttons on the screen, but no
cdrom activity, and clicking "next" or "back" doesn't work.

-benjamin
Comment 4 Benjamin Kosnik 2002-10-01 12:58:48 EDT
... more info. This is a clean istall of RH 8 on a Dell Lattitude C600.

-/bin/sh-2.05b# cd /mnt/cdrom
-/bin/sh: cd: /mnt/cdrom: No such file or directory

hmmm.... but

-/bin/sh-2.05b# cd /mnt/source

-/bin/sh-2.05b# ls

EULA
GPL
...

etc, so that's  not the problem. FYI, the text install mode works fine.I've
verified the media, so that's not an issue. I've also tried it without an
external USB mouse, and with no PCMCIA devices, no dice. 

A-HA! 

Doing a "linux lowres" install at the initial boot prompt does actually work,
and gets past this issue. Weird.

-benjamin


Comment 5 Michael Fulbright 2002-10-01 14:37:55 EDT
We umount the CD when we hit an error so its possible to eject the CD.

This sounds like a intermitantly bad interactions between CD media and a CD
drive. You may want to consider putting the ISOs on a hard drive partition and
installing via the hard drive install method.
Comment 6 oliver 2002-10-03 12:39:12 EDT
I see the same problem as described in the first post.  Again media checks OK,
custom install, AMD Duron IDE system with two CDROM drives (BIOS will let me boot
only from on of them, so cannot test booting from the other), and package 
where the problem occurs is again zlib.  

Problem occurs both in text and graphical mode, and using "linux lowres" as
suggested in a previous post does not help either.
Comment 7 oliver 2002-10-03 15:05:03 EDT
To follow up: The workaround suggested by josiah_royse@yahoo.com works for me as
well.  To make it clear for other people who stumble on this bug (it took me a
while to find out):  One can obtain an installer shell by using the text-based
installer, and switching to virtual console 2 (i.e. ALT-F2), the installer
screen is virtual console 1 (i.e. back with ALT-F1).

Here my IDE configuration (seems to be relevant):

primary master: hard drive
primary slave: empty
secondary master: CDRW (the install drive) with ATAPI-SCSI interface
secondary slave: old ATAPI CD drive
Comment 8 Adam Pribyl 2002-10-06 03:01:47 EDT
This bug appears to me too. It happens on machine with VIA C3, MSI 694T, Radeon
7500 and CDRW Acer.
I suggest to devide this bug to two separated:
1. installer crash due to error in code of installer which is not able to handle
case when instalation of some package is canceled due to fact that it can not
find this package. Installation then asks if I want to repeat a try then it
crashes with bug report save to floopy.

2.Reason why installation of some package is canceled because "missing file, a
bad package". To me it happens on different package depending on type of
instalation.

If I choose workstation, then it crashes on perl-Filters. After crashed
instalation I booted with rescue and I find package perl-Filter in /var/tmp
directory of /mnt/sysimage. CMP says perl-Filter differs against one on CD on
first byte (see attachments). This is not due to bad/corrypted CD/ISO! I check them.

I have to say one more thing - the same thing happens instaling Mandrake9.0. I
am susspicious about some hardware related troubles.. but who knows.
Comment 9 Adam Pribyl 2002-10-06 03:03:46 EDT
Created attachment 79024 [details]
Anaconda dump
Comment 10 Adam Pribyl 2002-10-06 03:06:46 EDT
Created attachment 79025 [details]
corrupted perl-Filter package grabed from disk after crashed installation
Comment 11 Adam Pribyl 2002-10-06 04:44:54 EDT
THESE ARE DEFINITELY TWO BUGS!

1. Installer not able to handle retries of reading missed instalation package
(See anaconda tracebacks)

2. Why installer misses some packages.

Related to 2: I found following - using textmode workstation install I got also
to problem reading zlib package - it helps to
mkdir /mnt/source
mount /tmp/hdc /mnt/source
because /mnt/source was not existing anymore!

Next time (same continued installation!!) same happens on different package, BUT
(!):
mkdir /mnt/source
mount /tmp/hdc /mnt/source FAILS! No device /tmp/hdc!
mount /tmp/cdrom solves situation.
Comment 12 Josiah Royse 2002-10-06 11:22:14 EDT
Due to the occurrence on multiple machines this eliminates the possibility of an
intermitantly bad connection on only my machine- these problems may need more
investigation on a two CDROM (one CDR/W?) machine.
Comment 13 Rusty Samuelson 2002-10-06 16:33:11 EDT
I am getting the same error message from my Linux 8.0 install as the originator of this 
bug:

Description of problem:
Error: The file /mnt/sysimage/var/tmp/zlib-1.1.4-
4.i386.rpm cannot be opened. 
This is due to a missing file, a bad package, etc... Press 
<return>

As with yours, errors on zlib, three times now. Same conditions of custom install; 
closer to full than minimal. My system is an Abit KX7 board, Athlon 1GHz, Radeon 7000 and a Acer CD 
Writer (like Czech fellow)- the only CD drive. New 40 GB Hdrive with first half of drive holding 
WinXP and partitioning the second half for this install of Linux 8.0. Installing in graphic mode 
and will try in text mode now.

This negates shipping RH Linux 8.0 via Second Day Air. Lets get 
this resolved.
I will also try detuning my machine, lowering read speed of the CD and 
performance of the IDE controller. 



Comment 14 oliver 2002-10-07 15:29:17 EDT
Just in case this helps debugging: My setup is similar to the previous poster's
in that I am running an AMD system with AMD-751 [Irongate] Chipset and Duron
processor, I also have an Acer CDRW (shows up in Linux as Atapi CD-R/RW 20X10,
the front simply says CDRW 20x10x40) as the install drive on the second IDE
cable as the IDE Master, and I have also been installing into a root partition
located in the last 20GB of a 40GB Hard drive.

The second package that the installer consistently bumbed out on is libmng.
Comment 15 Jeremy Katz 2002-10-07 16:54:30 EDT

*** This bug has been marked as a duplicate of 75377 ***
Comment 16 Todd Keyser 2002-10-30 20:40:06 EST
the only way i found to work around this is to burn two sets of cd's from 
different ftp sites and  swap them when setup couldn't locate the files

Note You need to log in before you can comment on or make changes to this bug.