This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 747195 - ibus failed to work in Gnome / kde application with Ctrl+Space
ibus failed to work in Gnome / kde application with Ctrl+Space
Status: CLOSED DUPLICATE of bug 746869
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 00:36 EDT by A S Alam
Modified: 2013-07-02 21:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 01:08:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2011-10-19 00:36:10 EDT
Description of problem:
ibus randomly failed to work in Gnome / kde application with Ctrl+Space. I have only Keymap selected (remove other for Punjabi). Punjabi Jhelum layout is there

Version-Release number of selected component (if applicable):
ibus-qt-1.3.1-5.fc16.i686
ibus-m17n-1.3.3-5.fc16.i686
ibus-1.4.0-3.fc16.i686
ibus-gtk3-1.4.0-3.fc16.i686
libuser-python-0.57.2-1.fc16.i686
ibus-hangul-1.3.1-7.fc16.i686
ibus-rawcode-1.3.1.20100707-5.fc16.i686
libusb1-1.0.9-0.3.rc1.fc16.i686
ibus-gnome3-1.4.0-3.fc16.i686
libuser-0.57.2-1.fc16.i686
ibus-pinyin-1.3.99.20110706-2.fc16.i686
ibus-pinyin-db-android-1.3.99.20110706-2.fc16.noarch
ibus-libs-1.4.0-3.fc16.i686
ibus-xkbc-1.3.3.20100922-1.fc16.noarch
ibus-gtk2-1.4.0-3.fc16.i686
libusb-0.1.3-9.fc16.i686
ibus-anthy-1.2.6-3.fc16.i686
ibus-chewing-1.3.10-1.fc16.i686

How reproducible:


Steps to Reproduce:
1. sometime ibus failed to trigger with Ctrl+Space
2. Gnome and KDe both has problem
3. 
  
Actual results:
it is not working Ctrl+Space, but manual need to select.

Expected results:
it should work with Ctrl+Space

Additional info:
------
[aalam@busyhawk ~]$ cat .config/ibus/bus/9f4c92f3a7bdd91bc55ccc4300000009-unix-0 
# This file is created by ibus-daemon, please do not modify it
IBUS_ADDRESS=unix:abstract=/tmp/dbus-fOOobA6I,guid=8bf169fc1731d2102be5f6ff4e9e526d
IBUS_DAEMON_PID=1776
-----

----
 cat .imsettings.log 
[ 1318998419.380189]: IMSettings-Daemon[1275]: INFO: Starting imsettings-daemon...
[ 1318998419.380845]: IMSettings-Daemon[1275]: INFO:   [HOME=/home/aalam]
[ 1318998419.380949]: IMSettings-Daemon[1275]: INFO:   [XINPUTRCDIR=/etc/X11/xinit/]
[ 1318998419.381043]: IMSettings-Daemon[1275]: INFO:   [XINPUTDIR=/etc/X11/xinit/xinput.d/]

[ 1318998419.381136]: IMSettings-Daemon[1275]: INFO:   [MODULEDIR=/usr/lib/imsettings]

[ 1318998419.381231]: IMSettings-Daemon[1275]: INFO:   [MODULES=gsettings, qt]


[ 1318998419.400546]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.441866]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.470513]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.498547]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.538137]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.566334]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'
imsettings information
==========================
Is DBus enabled: yes
Is imsettings enabled: yes
Is GTK+ supported: 
[ 1318998419.654226]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.676782]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.704126]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.732257]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'
yes
Is Qt supported: 
[ 1318998419.761111]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'

[ 1318998419.788907]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'
yes
DESKTOP_SESSION: gnome
DISABLE_IMSETTINGS: 
IMSETTINGS_DISABLE_DESKTOP_CHECK: 
DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-MGpc3IREIZ,guid=ba1831a125400fd06009ecc500000038
GTK_IM_MODULE: 
QT_IM_MODULE: ibus
XMODIFIERS: @im=ibus
IMSETTINGS_MODULE: IBus
IMSETTINGS_INTEGRATE_DESKTOP: yes


[ 1318998433.356474]: IMSettings-Qt backend[1275]: WARNING **: Unable to obtain the DefaultInputMethod: Key file does not have group 'Qt'
[ 1318998433.952133]: IMSettings-Daemon[1275]: INFO: Attempting to switch IM to IBus [lang=pa_IN.utf8, update=false]
[ 1318998434.305974]: IMSettings-Daemon[1275]: INFO:   no need to invoke any auxiliary process for IBus
[ 1318998434.306166]: IMSettings-Daemon[1275]: INFO:   Starting the main process for IBus [lang:pa_IN.utf8]
[ 1318998434.316585]: IMSettings-Daemon[1275]: INFO:   Started IBus: [process: /usr/bin/ibus-daemon -r --xim, lang: pa_IN.utf8, pid: 1776, id: 59, time: 2011-10-19T04:27:14.316302Z
[ 1318998434.372379]: IMSettings-Qt backend[1275]: INFO: Setting up ibus as Qt immodule
[ 1318998434.373551]: IMSettings-GSettings backend[1275]: INFO: Setting up ibus as gtk+ immodule
[ 1318998637.582290]: IBus[1776]: 

[ 1318998637.583283]: IBus[1776]: (ibus-daemon:1776): GLib-WARNING **: Failed to read from child watch wake up pipe: Bad file descriptor
-----
Comment 1 A S Alam 2011-10-19 23:24:29 EDT
it is not random, but produced 100%
Comment 2 fujiwara 2011-10-19 23:33:42 EDT
Could you test if the following ibus fixes your bug?
http://koji.fedoraproject.org/koji/taskinfo?taskID=3445513

It the fix of bug 746869.

Thanks.
Comment 3 A S Alam 2011-10-20 01:03:28 EDT
(In reply to comment #2)
> Could you test if the following ibus fixes your bug?
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3445513
> 
> It the fix of bug 746869.
> 
> Thanks.

this is working as expected.
thanks for build.
Comment 4 fujiwara 2011-10-20 01:08:15 EDT

*** This bug has been marked as a duplicate of bug 746869 ***

Note You need to log in before you can comment on or make changes to this bug.