Bug 746869 - ibus cannot get the current keymap if the XKB has no group and no variant
ibus cannot get the current keymap if the XKB has no group and no variant
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
AcceptedBlocker
: i18n, Regression
: 747195 747473 (view as bug list)
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-18 00:07 EDT by fujiwara
Modified: 2013-01-13 07:09 EST (History)
8 users (show)

See Also:
Fixed In Version: ibus-1.4.0-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 23:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fujiwara 2011-10-18 00:07:20 EDT
ibus cannot get the current keymap if there are no XKB group layouts and no variant (e.g. jp only).

The result shows anthy only on ibus gtk panel icon.

Expected result: anthy and jp are shown.
Comment 1 fujiwara 2011-10-18 00:12:30 EDT
--- ibus-1.4.0/ui/gtk/panel.py
+++ ibus-1.4.0/ui/gtk/panel.py
@@ -281,15 +281,16 @@ class Panel(ibus.PanelBase):
                 if i == 0:
                     layout = default_layout
                     model = default_model
-                elif i < len(models):
+                elif models != None and i < len(models):
                     model = models[i]
                 if model == '':
                     model = None
                 model_desc = _("Default Layout")
                 if i == 0:
                     l = 0
-                    for j in range(0, len(models)):
-                        l = l + len(models[j])
+                    if models != None:
+                        for j in range(0, len(models)):
+                            l = l + len(models[j])
                     if l != 0:
                         model_desc = model_desc + " (" + model + ")"
                 elif model != None:
Comment 2 fujiwara 2011-10-19 21:04:23 EDT
*** Bug 747473 has been marked as a duplicate of this bug. ***
Comment 3 Akira TAGOH 2011-10-19 22:49:08 EDT
Proposing this as f16 nth bug. unfortunately there are no particular criterion met but I'd suggest to reconsider it to add a criterion for basic input.

Affects:
Japanese users can't input Japanese through ibus.
Comment 4 A S Alam 2011-10-19 23:23:14 EDT
Can bug #747195 be possible due to this? (other than Japanese)
Comment 5 Adam Williamson 2011-10-19 23:27:42 EDT
+1 nth, affects a significant language and would hit the lives so can't be fixed entirely with an update.

might be a blocker - akira, previously we've taken input issues simply as hitting one of the existing criteria, as a system you can't type japanese into is an unusable system for a Japanese user. so we say it makes the desktop unusable.

So, let's propose as a blocker too, Alpha criterion "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied", affecting at least Japanese and possibly other ibus-based langs.
Comment 6 Jens Petersen 2011-10-20 00:40:01 EDT
To me this is a rather serious regression: I fully support proposing
as a blocker.

Anyway I think Fujiwara-san to going to submit a fix to updates-testing today.

Currently ibus can't be disabled and the ibus status icon is out
of sync with the actual input state.
Comment 7 Jens Petersen 2011-10-20 00:48:50 EDT
I see the following test build by Fujiwara:

http://koji.fedoraproject.org/koji/buildinfo?buildID=269607
(same build referenced in bug 747195)

seems to fix the problems for me.
Comment 8 Fedora Update System 2011-10-20 01:06:39 EDT
ibus-1.4.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-1.4.0-4.fc16
Comment 9 fujiwara 2011-10-20 01:08:15 EDT
*** Bug 747195 has been marked as a duplicate of this bug. ***
Comment 10 Jens Petersen 2011-10-20 01:11:34 EDT
(In reply to comment #5)
> +1 nth, affects a significant language and would hit the lives so can't be
> fixed entirely with an update.

Just to clarify, this is not Japanese specific but affects all ibus users.
Comment 11 Hajime Taira 2011-10-20 02:29:35 EDT
I tried ibus-1.4.0-4.fc16 on my environment.
I can toggle ibus via Control+Space hot-key. (Locale is Japanese)
Comment 12 Fedora Update System 2011-10-20 18:14:47 EDT
Package ibus-1.4.0-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.0-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14681
then log in and leave karma (feedback).
Comment 13 Adam Williamson 2011-10-21 14:04:06 EDT
Discussed at 2011-10-21 blocker review meeting, accepted as a blocker per criterion discussed in comment #5.
Comment 14 Fedora Update System 2011-10-24 23:39:14 EDT
ibus-1.4.0-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.