This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 74722 - G-T UI glitch while adding a tab in full-screen mode.
G-T UI glitch while adding a tab in full-screen mode.
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Havoc Pennington
http://www.nakedsoul.org/~abraar/bugz...
:
: 76069 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 01:41 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-01 01:41:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-01 01:41:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
G-T's fullscreen mode works fine till you add a tab.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open gnome-terminal
2.View/Fullscreen. Everything's OK.
3.Ctrl-Shift-T. See URL for the problem.

	

Actual Results:  See the provided URL. G-T doesn't fully stay in fullscreen
mode. As you can see see, a little part of my menu panel is visible (and I can
click the shortcuts on it).

Expected Results:  G-T should actually stay in fullscreen (as when it has only
one tab).

Additional info:

Using Metacity.
Video driver: radeon_drv.o

Marking as low priority as it is only a little UI glitch.

BTW, Really nice release! :)
Comment 1 Havoc Pennington 2002-10-01 09:05:30 EDT
This isn't really a bug; it's just that the terminal's size has to be aligned to
a grid (so you can resize to 80x23 and 80x24 characters, but not 80x23.5).
So that kind of messes up attempts to make it match the screen size exactly.
You'll see the same when maximizing the window. It happens when adding a tab
just from luck, the way the numbers work out with your font.

In CVS metacity I just updated it to snap to the top of the screen always, which
looks nicer. We'll get that cleanup next time we upgrade metacity.
Comment 2 Ed Halley 2002-10-01 10:28:04 EDT
I think to fit the user's expectations, perhaps applications that lay themselves
out in a grid fashion (as you mention, hp), need to override their usual layout
behavior when assigned a fullscreen mode.

When the grid is overridden, the app should use all of the space it is given,
rather than resizing the window to fit the grid.  Any excess space from
fractional grid leftover space should just be drawn in the background style,
either rather than trying to shrink the frame to fit.  Whether the "useful" grid
area is centered in the available area, or gravitated to an edge, is up for debate.

When the grid is not overridden, such as a terminal window that's not in
full-screen mode, it should of course work the way it does now, preferring
layouts that fit internal constraints such as grids.

Just my opinion, of course, but I think this will better fit users' expectations
of what "full screen" means.
Comment 3 Havoc Pennington 2002-10-01 11:11:37 EDT
I think you're right, it's just hard to implement for obscure technical reasons.
I have vague ideas about how to approach it but it'll all happen on the
gnome.org level, not in Red Hat specific patches.
Comment 4 Havoc Pennington 2002-10-16 16:17:42 EDT
*** Bug 76069 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.