This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 747507 - ibus contains duplicate entries for keyboard layouts from m17n and xkb
ibus contains duplicate entries for keyboard layouts from m17n and xkb
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-20 00:54 EDT by A S Alam
Modified: 2013-07-02 21:09 EDT (History)
7 users (show)

See Also:
Fixed In Version: ibus-1.4.0-10.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-10 12:41:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2011-10-20 00:54:17 EDT
Description of problem:
there are various m17n and xkb keyboard layouts, which are common. Those appear in ibus selection menu. We can disable some of them so avoid confusion regarding same layout twice. Bug #740447 can be example for such problem

Version-Release number of selected component (if applicable):
ibus-1.4.0-3.fc16.i686
ibus-m17n-1.3.3-5.fc16.i686
m17n-lib-1.6.3-1.fc16.i686
m17n-db-1.6.3-1.fc16.noarch
m17n-contrib-1.1.13-1.fc16.noarch
ibus-xkbc-1.3.3.20100922-1.fc16.noarch
xkeyboard-config-2.3-2.fc16.noarch

How reproducible:
Everytime

Steps to Reproduce:
1. ibus-preference
2. select Input method
3. Show All input method 
4. Check Oriya
5 there is Oriya Inscript (m17n) and Oriya (xkb)
  
Actual results:
both are two Inscript layouts

Expected results:
Only one need to make available to choose

Additional info:

$cat /usr/share/X11/xkb/symbols/in|grep INSCRIPT
// - Indic INSCRIPT keyboard layout diagrams:

(compare in (from xkb) with /usr/share/m17n) 

$cat /usr/share/X11/xkb/symbols/in|grep xkb_
xkb_symbols "deva" {                   - Inscript - Duplicate
xkb_symbols "bolnagri" {
xkb_symbols "ben" {                   - Inscript - Duplicate
xkb_symbols "ben_probhat" {                   - Probhat - Duplicate
xkb_symbols "guj" {                   - Inscript - Duplicate
xkb_symbols "kan" {                   - Inscript - Duplicate
xkb_symbols "mal" {                   - Inscript - Duplicate
xkb_symbols "mal_lalitha" {
xkb_symbols "ori" {                   - Inscript - Duplicate
xkb_symbols "tam" {                   - Inscript - Duplicate
xkb_symbols "tam_unicode" {
xkb_symbols "tam_keyboard_with_numerals" {
xkb_symbols "tam_TSCII" {
xkb_symbols "tam_TAB" {
xkb_symbols "tel" {
xkb_symbols "urd-phonetic" {                    - Inscript - Duplicate
xkb_symbols "urd-phonetic3" {
xkb_symbols "urd-winkeys" {
xkb_symbols "guru" {                   - Inscript - Duplicate
xkb_symbols "jhelum" {                   - Jhulem - Duplicate
xkb_symbols "olpc" {
xkb_symbols "hin-wx" {
xkb_symbols "eng" {
xkb_symbols "mal_enhanced" {
Comment 1 fujiwara 2011-10-28 04:52:30 EDT
Why you don't remove the m17n layouts instead?
Actually I don't understand what is inscript.
The IBus XKB layouts are compatible with X11 layouts.

I think Bug #740447 is another bug since the descriptions are different.
Comment 2 A S Alam 2011-10-31 05:08:37 EDT
(In reply to comment #1)
> Why you don't remove the m17n layouts instead?
xkb layouts are not updated as compared to m17n, from last many years we are working on scim or ibus, which use m17n, so most of changes are made in m17n instead of m17n.

> Actually I don't understand what is inscript.

it is common keyboard layout of all Indic locales created by Govt. of India.
http://en.wikipedia.org/wiki/InScript_keyboard

> The IBus XKB layouts are compatible with X11 layouts.
> 
> I think Bug #740447 is another bug since the descriptions are different.

I checked that bug before file this one, still filed because

1) This bug is to remove duplication of all keymaps from m17n and xkb (keep either one) - Either those are same name (bug #740447) or different name.

2) if we fix this bug by disabling xkb (or m17n), then bug #740447 need not to be fixed.

3) If not going to fix this, then bug #740447 Must need to fix

4) bug #740447 is specific on Bengali only (although xkb keyboard layout names are too generic (only language) to identify, but still different enough while using with ibus from m17n names)
Comment 3 fujiwara 2011-10-31 06:40:50 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > Why you don't remove the m17n layouts instead?
> xkb layouts are not updated as compared to m17n, from last many years we are
> working on scim or ibus, which use m17n, so most of changes are made in m17n
> instead of m17n.
> 
> > Actually I don't understand what is inscript.
> 
> it is common keyboard layout of all Indic locales created by Govt. of India.
> http://en.wikipedia.org/wiki/InScript_keyboard

OK, my understanding is the XKB layouts are compatible with the inscript.
Probably I don't understand the differences between XKB and m17n.
But I asked this to know if your problem is Fedora specific or not.

Currently I'd think your issue is Fedora specific and and maybe I don't think we recommend to depend on m17n.

OK, I will modify the default configuration for Fedora.
Comment 4 A S Alam 2011-10-31 07:03:16 EDT
> OK, my understanding is the XKB layouts are compatible with the inscript.
> Probably I don't understand the differences between XKB and m17n.
> But I asked this to know if your problem is Fedora specific or not.
> 
> Currently I'd think your issue is Fedora specific and and maybe I don't think
> we recommend to depend on m17n.
> 

I used ubuntu and openSUSE with ibus and m17n. And if ibus has plan to include xkb not only for fedora, then this problem may come to other distributions.
Comment 6 fujiwara 2011-11-01 03:34:35 EDT
(In reply to comment #5)
> I really don't see from where need comes for xkb integration in ibus. IMHO, we
> don't need xkb in ibus at all.

ibus xkb is for the european keymaps originally.
And now ibus xkb is being integrated with xim.
I don't understand your mention.

I don't think it's good to have the m17n dependencies by default.
Comment 7 Fedora Update System 2011-11-02 05:53:25 EDT
ibus-1.4.0-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-15023
Comment 8 Fedora Update System 2011-11-02 05:57:27 EDT
ibus-1.4.0-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/FEDORA-2011-15125
Comment 9 Fedora Update System 2011-11-02 13:55:14 EDT
Package ibus-1.4.0-9.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.0-9.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15023
then log in and leave karma (feedback).
Comment 10 Akira TAGOH 2011-11-03 23:19:04 EDT
I'm not sure if I should open a new bug for possibly a regression of this change. the problem is no default layout on Indic locale. the steps to reproduce:

1. boot Live
2. change the language on gnomecc to Oriya and the keyboard to English (India, with RupeeSign)
3. restart the desktop
4. click on the ibus icon

Actual result:
no default layout

Expected result:
the default layout should be available.

On the menu, ibus says "Inscript (m17n)" is active as decorated to the bold though, I can only type ASCII only. once clicking it explicitly, I can see the Indic scripts there though, apparently ctrl+space doesn't work to disable it.
Comment 11 fujiwara 2011-11-04 02:52:59 EDT
(In reply to comment #10)
> I'm not sure if I should open a new bug for possibly a regression of this
> change. the problem is no default layout on Indic locale. the steps to
> reproduce:
> 
> 1. boot Live
> 2. change the language on gnomecc to Oriya and the keyboard to English (India,
> with RupeeSign)
> 3. restart the desktop
> 4. click on the ibus icon
> 
> Actual result:
> no default layout
> 
> Expected result:
> the default layout should be available.
> 
> On the menu, ibus says "Inscript (m17n)" is active as decorated to the bold
> though, I can only type ASCII only. once clicking it explicitly, I can see the
> Indic scripts there though, apparently ctrl+space doesn't work to disable it.

Thanks. it's a new bug but you don't have to file it.
I will update ibus again for this issue.
Comment 12 fujiwara 2011-11-04 06:39:00 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > I'm not sure if I should open a new bug for possibly a regression of this
> > change. the problem is no default layout on Indic locale. the steps to
> > reproduce:
> > 
> > 1. boot Live
> > 2. change the language on gnomecc to Oriya and the keyboard to English (India,
> > with RupeeSign)
> > 3. restart the desktop
> > 4. click on the ibus icon
> > 
> > Actual result:
> > no default layout
> > 
> > Expected result:
> > the default layout should be available.
> > 
> > On the menu, ibus says "Inscript (m17n)" is active as decorated to the bold
> > though, I can only type ASCII only. once clicking it explicitly, I can see the
> > Indic scripts there though, apparently ctrl+space doesn't work to disable it.
> 
> Thanks. it's a new bug but you don't have to file it.
> I will update ibus again for this issue.

Fixed this in ibus-1.4.0-10.fc16 .
Comment 13 Fedora Update System 2011-11-10 12:41:25 EST
ibus-1.4.0-10.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2011-11-14 17:29:21 EST
ibus-1.4.0-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.