Bug 748209 - KeyError: '/boot/efi': anaconda will try to do an EFI install if there is an existing EFI system partition but it has not been set as /boot/efi
KeyError: '/boot/efi': anaconda will try to do an EFI install if there is an ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:5e6ed86b6d03b59b025f5cd7f3b...
:
: 799588 806494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-22 21:10 EDT by viz_skywalker
Modified: 2012-05-08 18:34 EDT (History)
17 users (show)

See Also:
Fixed In Version: anaconda-17.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 18:34:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-hgkbSl (1.11 MB, text/plain)
2011-10-22 21:11 EDT, viz_skywalker
no flags Details

  None (edit)
Description viz_skywalker 2011-10-22 21:10:49 EDT
libreport version: 2.0.5.982
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc6.git0.3.fc16.x86_64
product:        Fedora
reason:         KeyError: '/boot/efi'
time:           Sat Oct 22 10:05:21 2011
version:        16-Beta

anaconda-tb-hgkbSl: Binary file, 1168550 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.20 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1408, in add_efi_boot_target
:    boot_efi = self.storage.mountpoints["/boot/efi"]
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1429, in install
:    self.add_efi_boot_target(install_root=install_root)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1445, in write
:    self.install(install_root=install_root)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2110, in writeBootloader
:    anaconda.bootloader.write(install_root=anaconda.rootPath)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 241, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1203, in nextClicked
:    self.anaconda.dispatch.go_forward()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
:    self.intf.icw.nextClicked()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1223, in handleRenderCallback
:    self.currentWindow.renderCallback()
:KeyError: '/boot/efi'
Comment 1 viz_skywalker 2011-10-22 21:11:05 EDT
Created attachment 529651 [details]
File: anaconda-tb-hgkbSl
Comment 2 Andrew Gormanly 2011-11-08 11:36:49 EST
Just hit this.

System is an Intel DH67CL board, Core i3-2100, WD Caviar Black WD5002AALX, GPT-formatted and UEFI booting.

Install was from Fedora 16 x86_64 full DVD.
Comment 3 viz_skywalker 2011-11-08 14:56:00 EST
(In reply to comment #2)
> Just hit this.
> 
> System is an Intel DH67CL board, Core i3-2100, WD Caviar Black WD5002AALX,
> GPT-formatted and UEFI booting.
> 
> Install was from Fedora 16 x86_64 full DVD.

I did find a a work around, if you haven't managed to get past this.  When you create your EFI partition, you need to set the mount point to /boot/efi.  It would still be nice if this gets fixed so it has a nice informative message instead of an exception.
Comment 4 Jacek Krüger 2011-11-11 09:19:46 EST
Same occured on my ASUS P8H67-M PRO. UEFI booted from efidisk.img on a USB stick. Setting the mount point like viz_skywalker said fixed this problem. I later hit another bug https://bugzilla.redhat.com/show_bug.cgi?id=749818 but it's probably unrelated
Comment 5 Brian Lane 2012-01-19 14:46:09 EST
Did you do custom partitioning and did you have a /boot/efi mountpoint created?
Comment 6 joshua 2012-01-19 15:08:44 EST
Yes, and yes
Comment 7 Tony White 2012-01-24 14:57:21 EST
Just to add -- this bug is "I booted using EFI, I tried custom partitioning, forgot to create and mount /boot/efi, then anaconda let me install but it failed and filed this bug report."

Anaconda needs to prevent progression to the next installation step if being booted from EFI and no /boot/efi exists when manually partitioning an install, to fix this.
Comment 8 myrtuser 2012-03-04 06:30:30 EST
*** Bug 799588 has been marked as a duplicate of this bug. ***
Comment 9 Adam Williamson 2012-03-05 18:11:15 EST
anaconda team, it'd be great to improve this, as it does seem to be catching more and more people out as time goes by.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Brian Lane 2012-03-08 18:45:05 EST
I cannot reproduce this with F17 Beta TC1 -- if I don't make a /boot/efi it tells me 'you have not created a bootloader stage1 device'. That's not a terribly clear error, but it doesn't let me continue until I make a /boot/efi
Comment 11 Adam Williamson 2012-03-09 22:07:54 EST
can the reporters test with 17 Beta TC1 - http://dl.fedoraproject.org/pub/alt/stage/17-Beta.TC1/ - and see if they can reproduce?

Behaviour may change depending on specific system configuration here, I think...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2012-03-24 16:51:37 EDT
*** Bug 806494 has been marked as a duplicate of this bug. ***
Comment 13 Adam Williamson 2012-03-24 16:53:20 EDT
Brian: https://bugzilla.redhat.com/show_bug.cgi?id=806494 hit this. I think maybe it happens if there is an existing EFI system partition somewhere (which makes the 'bootloader stage1 device' test pass) but it's not actually mounted as /boot/efi in the partition layout for the Fedora install? storage.log should have details, I guess.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Brian Lane 2012-03-26 16:01:39 EDT
I can reproduce this by doing a custom partition over the top of a previous EFI install. If I only create a / partition (no boot, no boot/efi) I can proceed without any warnings.
Comment 15 Adam Williamson 2012-03-26 19:00:14 EDT
Proposing as a final blocker: let's say it's "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above". Arguably, this isn't strictly a 'workable partition layout', but the EFI system partition _is_ present and it's bad form for anaconda to let you screw up this way.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Fedora Update System 2012-04-18 20:22:57 EDT
anaconda-17.21-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.21-1.fc17
Comment 17 Fedora Update System 2012-04-19 22:26:50 EDT
Package anaconda-17.21-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.21-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6240/anaconda-17.21-1.fc17
then log in and leave karma (feedback).
Comment 18 Adam Williamson 2012-04-20 14:02:32 EDT
Discussed at 2012-04-20 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-20/fedora-bugzappers.2012-04-20-17.01.log.txt . Rejected as a blocker as it's just too much of a corner case, and we don't really consider it a 'valid partition layout' (though it's very easy to make the mistake).
Comment 19 Adam Williamson 2012-05-08 18:34:06 EDT
This should be fixed by now, we're up to 17.25 in stable. I'm gonna close. If anyone can reproduce with TC3, please re-open.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.