Bug 799588 - KeyError: '/boot/efi'
KeyError: '/boot/efi'
Status: CLOSED DUPLICATE of bug 748209
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Mac OS
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:56ad6f46f66acf2d8375032d048...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 03:48 EST by myrtuser
Modified: 2012-03-05 18:29 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-04 06:30:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-4RxSWP (760.87 KB, text/plain)
2012-03-03 03:49 EST, myrtuser
no flags Details

  None (edit)
Description myrtuser 2012-03-03 03:48:59 EST
libreport version: 2.0.8
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/loop3 --lang en_US.UTF-8
executable:     /sbin/anaconda
exnFileName:    /tmp/anaconda-tb-4RxSWP
hashmarkername: anaconda
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
other involved packages: 
product:        Fedora
reason:         KeyError: '/boot/efi'
release:        Fedora release 17 (Beefy Miracle)
time:           Sat 03 Mar 2012 02:18:07 PM IST
version:        17

anaconda-tb-4RxSWP: Binary file, 779132 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1494, in add_efi_boot_target
:    boot_efi = self.storage.mountpoints["/boot/efi"]
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1515, in install
:    self.add_efi_boot_target()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1531, in write
:    self.install()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2250, in writeBootloader
:    anaconda.bootloader.write()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1200, in nextClicked
:    self.anaconda.dispatch.go_forward()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
:    self.intf.icw.nextClicked()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1220, in handleRenderCallback
:    self.currentWindow.renderCallback()
:KeyError: '/boot/efi'

environ:
:LC_NUMERIC=C
:LIBUSER_CONF=/tmp/libuser.zlKeTx
:LVM_SUPPRESS_FD_WARNINGS=1
:LOGNAME=root
:USER=root
:GCONF_GLOBAL_LOCKS=1
:PATH=/sbin:/usr/sbin:/usr/sbin:/usr/bin:/sbin:/bin:/root/bin:/sbin:/usr/sbin
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:HOME=/tmp
:DISPLAY=:0
:ANACONDA_PRODUCTNAME=Fedora
:LANG=en_US.UTF-8
:TERM=dumb
:SHELL=/bin/bash
:TZ=Asia/Kolkata
:XAUTHORITY=/root/.xauthEOYCqD
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=1
:GNOME_DISABLE_CRASH_DIALOG=1
:ANACONDA_PRODUCTVERSION=17
:ANACONDA_BUGURL=https://bugzilla.redhat.com/bugzilla/
:USERHELPER_UID=1000
:ANACONDA_ISFINAL=false
:_=/sbin/anaconda
:PWD=/home/liveuser
:DESKTOP_STARTUP_ID=userhelper/Starting Install to Hard Drive/1429-0-localhost.localdomain_TIME0
Comment 1 myrtuser 2012-03-03 03:49:25 EST
Created attachment 567248 [details]
File: anaconda-tb-4RxSWP
Comment 2 myrtuser 2012-03-03 04:01:15 EST
F17 x86_64 LiveCD boots my Late 2011 Macbook Pro 8.1.  Install to Hard drive completes HDD resizing and then fails during boot loader configuration. This prevents me from installing F17 alpha.

I boot live USB via refit installed on lion 10.7.3 with firmware B27 (latest).
Comment 3 myrtuser 2012-03-04 06:30:30 EST
Jason Montelon was kind enough to point me to a duplicate bug which had a resolution for my issue. It appears that for EFI systems /boot/efi partition has to be created during install.

I've installed Fedora 16 on my MBP 8.1 and all is swimmingly well.

Closing the bug,

*** This bug has been marked as a duplicate of bug 748209 ***

Note You need to log in before you can comment on or make changes to this bug.