This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 748210 - Kernel panic when turning off screen backlight using laptop Fn key
Kernel panic when turning off screen backlight using laptop Fn key
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 745568 746016 (view as bug list)
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-10-22 21:52 EDT by Hexchain Tong
Modified: 2011-12-23 03:03 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-29 03:24:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The kernel oops - the first screen. (98.97 KB, image/jpeg)
2011-10-26 19:10 EDT, Václav Mocek
no flags Details
The kernel oops - the second screen. (100.88 KB, image/jpeg)
2011-10-26 19:11 EDT, Václav Mocek
no flags Details

  None (edit)
Description Hexchain Tong 2011-10-22 21:52:51 EDT
Description of problem:
Since I installed Fedora 16 I'm not able to turn off the screen backlight using the Fn key. It is a Lenovo Ideapad Y450-PEI. When I press Fn + F2 (key to toggle screen backlight), my screen is black and I'm not able to get it back. I managed to get a strong light and see things like stack trace on my screen and something like "Kernel is unable to handle ......"

Version-Release number of selected component (if applicable):
kernel-3.1.0-0.rc10.git0.1.fc16.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Press Fn + F2 to turn off screen backlight
2. Press Fn + F2 again to turn it on
3.
  
Actual results:
The screen backlight isn't on and something is printed on the screen.

Expected results:
The screen backlight is on and nothing is affected

Additional info:
If possible, please don't let me try to read the screen when error occurs. It's so hard to do so...
Comment 1 Hexchain Tong 2011-10-22 21:58:54 EDT
I'm using the nouveau driver with a nVIDIA GT130M card. Haven't tried if proprietary driver will solve the problem.
Comment 2 Josh Boyer 2011-10-24 11:27:32 EDT
Can you take a picture of the screen?  We need the backtrace to really get started here.
Comment 3 Hexchain Tong 2011-10-25 06:42:06 EDT
(In reply to comment #2)
> Can you take a picture of the screen?  We need the backtrace to really get
> started here.

I'm sorry, when I press Fn + F2 the screen backlight turns off immediately so I can't see anything unless I use a torch... and it seems that the length of the backtrace exceeded the height of the screen...

I'll try my best to put them down. I'll reply later here.
Comment 4 Václav Mocek 2011-10-26 19:09:32 EDT
The same problem with Lenovo Ideapad S205 when I switch off/on backlight. The result is kernel oops and nothing in /var/log/messages, the version of kernel is 3.1.0-1.fc16.x86_64. 

I suspect, that the culprit is the ideapad-laptop module, see the attached pictures of the screen.
Comment 5 Václav Mocek 2011-10-26 19:10:59 EDT
Created attachment 530403 [details]
The kernel oops - the first screen.
Comment 6 Václav Mocek 2011-10-26 19:11:39 EDT
Created attachment 530405 [details]
The kernel oops - the second screen.
Comment 7 Václav Mocek 2011-10-26 19:24:11 EDT
My HW profile:
http://www.smolts.org/client/show/pub_7c1cd1be-666f-4cdb-a5da-1ef1cae21c35
Comment 8 Hexchain Tong 2011-10-27 10:06:43 EDT
(In reply to comment #6)
> Created attachment 530405 [details]
> The kernel oops - the second screen.

Oh thank you very much for these pictures. My screen turns off after Fn + F2 so I can't see anything.

Using Fn to toggle screen backlight is working very well in my Archlinux with the latest kernel, installed on the same machine.
Comment 9 Björn Ruberg 2011-11-02 06:16:29 EDT
I have read somewhere that the problem does not occur on ubuntu 32-bit. It does however on Ubuntu 64-bit, I confirm. So - has anybody tried this with a 32-bit Fedora installation?
Comment 10 Hexchain Tong 2011-11-02 08:03:20 EDT
I've updated my Archlinux to the latest kernel 3.1.0-2 and the problem can now be reproduced on Arch.
Comment 11 Václav Mocek 2011-11-02 17:31:32 EDT
It is an upstream problem and the patch is available.

https://lkml.org/lkml/2011/10/19/485

http://www.mail-archive.com/platform-driver-x86@vger.kernel.org/msg02343.html
Comment 12 Adam Williamson 2011-11-02 18:34:01 EDT
Proposing as NTH for F16: system crasher, will be present in live images hence can't be entirely fixed with an update.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Josh Boyer 2011-11-03 09:45:42 EDT
This when upstream in 3.2 as commit d4afc7754a60b885b63ef23fd194984e2d53a4e6.  I'll bring it back to f16.
Comment 14 Josh Boyer 2011-11-03 09:53:03 EDT
The patch was added.  It will be in the next kernel build.
Comment 15 Josh Boyer 2011-11-07 15:00:29 EST
*** Bug 746016 has been marked as a duplicate of this bug. ***
Comment 16 Jacek Pawlyta 2011-11-10 04:41:48 EST
*** Bug 745568 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.