Bug 74825 - gnome-terminal copy-paste does not work properly
Summary: gnome-terminal copy-paste does not work properly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
: 75906 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-01 22:42 UTC by Satish Balay
Modified: 2007-04-18 16:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 17:50:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Satish Balay 2002-10-01 22:42:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
When using mouse to copy/paste between gnome-teminals, if the second terminal is
selected by clicking on the terminal rather than on the border, the selected
text is cleared from the clipboard(?) and when middle mouse is used to paste -
nothing is pasted.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open 2 gnome-terminal applications
2. Select some text in terminal 1 using mouse (either double/tripple click or
click & drag)
3. Now select the second terminal by clicking mouse-Left on it (inside)
4. Try pasting in the 2nd terminal using middle mouse button
	

Actual Results:  Nothing happens. 

Expected Results:  The selected text should be pasted in the second window

Additional info:

konsole & xterm don't exhibit this bad behavior.

Comment 1 Pete Zaitcev 2002-10-14 22:25:49 UTC
*** Bug 75906 has been marked as a duplicate of this bug. ***

Comment 2 Pete Zaitcev 2003-02-08 04:12:45 UTC
Fixed in Phoebe-2.



Note You need to log in before you can comment on or make changes to this bug.